Author Topic: How about adding WH56 Lightning Sensor support?  (Read 398 times)

0 Members and 1 Guest are viewing this topic.

Offline azchrisf

  • Cobra Weather Dominator Operator
  • Forecaster
  • *****
  • Posts: 341
How about adding WH56 Lightning Sensor support?
« on: April 05, 2021, 02:43:32 PM »
I'd like to see support for the WH56 Lightning Sensor added in a future version.
This is a great sensor that can feed webpages with lightning sensor data. Granted it's not a Boltek but hey it's affordable.

This should be simple to add since Boris already has supported for Ecowitt sensors.

For Boris - this may help:
https://www.weather-watch.com/smf/index.php?topic=70002.0
Davis Vantage Pro 2 Plus 6163 w/ 8 Transmitters!
Also doing Soil and Leaf 4x
WU: KAZGLEND106 CWOP: FW1398 (F1398) Purpleair: 98793/LAZGLEND8

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 478
Re: How about adding WH56 Lightning Sensor support?
« Reply #1 on: April 09, 2021, 12:41:13 PM »
I guess you mean the FineOffset/Ecowitt WH57 sensor (the "6" might have been a typo).
The Wh57 is supported by Meteobridge since long - if you have one, it shows under the live data as "lightning"
if you have MB connected to a GW1000/WH2650 console.
 [ You are not allowed to view attachments ]
Froggit WH4000SE (=EW 2320E) 1.5.7/Froggit DP1500 1.6.6 (+2 x EW GW1000 1.6.6 test/backup)/HP1000SE Pro (HP2551) 1.5.7/1.6.9, WH2650 WiFi (2) 1.6.7-
Ecowitt WS80,WH40,WH65,WH31(6),WH31-EP(1), WH32 (1),WH32B [T/H/P] (1), WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 [SoilMoisture] (5), WH45
Meteobridge Pro (2) [test,prod] 5.1 Mar 11 2021, build 142351 - Barani MeteoshieldPro - Blake-Larsen Sun Recorder-RPi4/weewx/CumulusMX/MB
Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553);Weathercloud 3011399141, http://meshka.eu/meteo/template  -  http://meshka.eu/Weather34 - http://meshka.eu/pwsWD

Offline azchrisf

  • Cobra Weather Dominator Operator
  • Forecaster
  • *****
  • Posts: 341
Re: How about adding WH56 Lightning Sensor support?
« Reply #2 on: April 09, 2021, 02:55:31 PM »
Yeah it was. Weird thing is mine does not show up even with strikes in Meteobridge, though it does in the Ecowitt app.
Davis Vantage Pro 2 Plus 6163 w/ 8 Transmitters!
Also doing Soil and Leaf 4x
WU: KAZGLEND106 CWOP: FW1398 (F1398) Purpleair: 98793/LAZGLEND8

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 478
Re: How about adding WH56 Lightning Sensor support?
« Reply #3 on: April 09, 2021, 05:00:12 PM »
I see that you have a Davis station.
Have you connected a GW1000 too as 2nd station ?
Primary station = Vantage, Station 1 the GW1000 ?
If you have only the Davis connected, MB will only show the Davis sensors ...
Froggit WH4000SE (=EW 2320E) 1.5.7/Froggit DP1500 1.6.6 (+2 x EW GW1000 1.6.6 test/backup)/HP1000SE Pro (HP2551) 1.5.7/1.6.9, WH2650 WiFi (2) 1.6.7-
Ecowitt WS80,WH40,WH65,WH31(6),WH31-EP(1), WH32 (1),WH32B [T/H/P] (1), WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 [SoilMoisture] (5), WH45
Meteobridge Pro (2) [test,prod] 5.1 Mar 11 2021, build 142351 - Barani MeteoshieldPro - Blake-Larsen Sun Recorder-RPi4/weewx/CumulusMX/MB
Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553);Weathercloud 3011399141, http://meshka.eu/meteo/template  -  http://meshka.eu/Weather34 - http://meshka.eu/pwsWD

Offline azchrisf

  • Cobra Weather Dominator Operator
  • Forecaster
  • *****
  • Posts: 341
Re: How about adding WH56 Lightning Sensor support?
« Reply #4 on: April 09, 2021, 05:49:04 PM »
Actually 3 stations - Davis, Purpleair and the GW1000 :-)
I can see the Indoor Air quality one (forgot model number) from the GW1000, the Indoor temp sensor, and an addtl. temp/hum sensor I have for it on MB, but the Lightning detector does not show up, even with strikes.
Davis Vantage Pro 2 Plus 6163 w/ 8 Transmitters!
Also doing Soil and Leaf 4x
WU: KAZGLEND106 CWOP: FW1398 (F1398) Purpleair: 98793/LAZGLEND8

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 478
Re: How about adding WH56 Lightning Sensor support?
« Reply #5 on: April 10, 2021, 07:56:49 AM »
Actually 3 stations - Davis, Purpleair and the GW1000 :-)
I can see the Indoor Air quality one (forgot model number) from the GW1000, the Indoor temp sensor, and an addtl. temp/hum sensor I have for it on MB, but the Lightning detector does not show up, even with strikes.
From the GW1000 inbuilt sensors you should see indoor temperature, humidity and air pressure. The additional T/H sensor would be a WH31.
Did you check in the WSView app under Device List ---> GW1000B-WIFIxxxx  -->  More --> Sensors ID the WH57 ?
Assuming the batteries put into the WH57 are good and proper polarity is set (better to cross check that again), i.e. batteries put and in the right direction.
For a test, put the WH57 near the GW1000 to exclude potential interference or attenuation. Take the batteries out in put them back again (check polarity)
to make it send its signal anew.
What do you see in the WSView app ? The WH57 is #6 (or #7 if it's a WH2650) from the top, under the ultrasonic anemometer and above the WH45 (CO2).
Press re-register. There should be a battery symbol and a signal strength icon visible next to an ID (may take some time after starting the re-register process).
 [ You are not allowed to view attachments ]
If nothing appears there in spite of new batteries and verified insertion polarity, the WH57 is defective.

The only thing that might also help is to reboot your GW1000 (power-cycle it = disconnect, wait 5 seconds and re-connect the USB power supply) and let it acquire the sensors again.

Or finally a factory reset of the GW1000 by help of a staple. The hole is between the two top air slits on the reverse side.
"Reset Mode: Hold the black button for about 10 seconds till the red light and blue light flash simultaneously for three times will reset the gateway to factory settings.
The history data, Wi-Fi settings, calibration etc. are all lost and need to be setup again via WS View app."
« Last Edit: April 10, 2021, 08:28:20 AM by Gyvate »
Froggit WH4000SE (=EW 2320E) 1.5.7/Froggit DP1500 1.6.6 (+2 x EW GW1000 1.6.6 test/backup)/HP1000SE Pro (HP2551) 1.5.7/1.6.9, WH2650 WiFi (2) 1.6.7-
Ecowitt WS80,WH40,WH65,WH31(6),WH31-EP(1), WH32 (1),WH32B [T/H/P] (1), WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 [SoilMoisture] (5), WH45
Meteobridge Pro (2) [test,prod] 5.1 Mar 11 2021, build 142351 - Barani MeteoshieldPro - Blake-Larsen Sun Recorder-RPi4/weewx/CumulusMX/MB
Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553);Weathercloud 3011399141, http://meshka.eu/meteo/template  -  http://meshka.eu/Weather34 - http://meshka.eu/pwsWD

Offline azchrisf

  • Cobra Weather Dominator Operator
  • Forecaster
  • *****
  • Posts: 341
Re: How about adding WH56 Lightning Sensor support?
« Reply #6 on: April 10, 2021, 01:33:57 PM »
The WH57 appears in the WSView app, has an ID and signal strength.
I have tried all of the above options before and it still does not show up in Meteobridge.

I believe the unit may be defective I will try another.
Davis Vantage Pro 2 Plus 6163 w/ 8 Transmitters!
Also doing Soil and Leaf 4x
WU: KAZGLEND106 CWOP: FW1398 (F1398) Purpleair: 98793/LAZGLEND8

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 478
Re: How about adding WH56 Lightning Sensor support?
« Reply #7 on: April 10, 2021, 01:55:43 PM »
The WH57 appears in the WSView app, has an ID and signal strength.
I have tried all of the above options before and it still does not show up in Meteobridge.

I believe the unit may be defective I will try another.
Does it also show a value in the Live data view of the WSView app ?  - it should show date/time and distance of the last strike.
If it doesn't, it's defective. (Unless you rebooted the GW1000 between the last strike and now - then the GW1000 forgets the last strike).
You can try creating a fake strike - e.g. with the flash of a camera in front of the WH57.
« Last Edit: April 10, 2021, 01:57:41 PM by Gyvate »
Froggit WH4000SE (=EW 2320E) 1.5.7/Froggit DP1500 1.6.6 (+2 x EW GW1000 1.6.6 test/backup)/HP1000SE Pro (HP2551) 1.5.7/1.6.9, WH2650 WiFi (2) 1.6.7-
Ecowitt WS80,WH40,WH65,WH31(6),WH31-EP(1), WH32 (1),WH32B [T/H/P] (1), WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 [SoilMoisture] (5), WH45
Meteobridge Pro (2) [test,prod] 5.1 Mar 11 2021, build 142351 - Barani MeteoshieldPro - Blake-Larsen Sun Recorder-RPi4/weewx/CumulusMX/MB
Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553);Weathercloud 3011399141, http://meshka.eu/meteo/template  -  http://meshka.eu/Weather34 - http://meshka.eu/pwsWD

Offline azchrisf

  • Cobra Weather Dominator Operator
  • Forecaster
  • *****
  • Posts: 341
Re: How about adding WH56 Lightning Sensor support?
« Reply #8 on: April 10, 2021, 02:26:05 PM »
Yes it does show strike data in live view.
Davis Vantage Pro 2 Plus 6163 w/ 8 Transmitters!
Also doing Soil and Leaf 4x
WU: KAZGLEND106 CWOP: FW1398 (F1398) Purpleair: 98793/LAZGLEND8

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 478
Re: How about adding WH56 Lightning Sensor support?
« Reply #9 on: April 10, 2021, 03:52:00 PM »
And what's your GW1000 firmware version ?
Latest version is 1.6.6
And - what's your Meteobridge version ?
(the numbering differs  depending on whether you use it on a MB, MB Nano, MB Pro or MB RPi - latest date is 9-April-2021).
The latest MB versions are compatible with the 1.6.6 firmware. Earlier ones not.
There were issues with several sensors as with FW 1.6.3/1.6.6 the GW1000 API changed significantly - so that needed to be mirrored at the MB end.
From what you tell so far, the GW1000 and the WH57 seem to work properly - and lightning data is shown on ecowitt.net and in the WSView app...
=>
Something could be fishy with your MB installation then ...
You might want to do a full refresh of your MB installation then (keep/make a database backup beforehand and import that database after the fresh re-install).
Froggit WH4000SE (=EW 2320E) 1.5.7/Froggit DP1500 1.6.6 (+2 x EW GW1000 1.6.6 test/backup)/HP1000SE Pro (HP2551) 1.5.7/1.6.9, WH2650 WiFi (2) 1.6.7-
Ecowitt WS80,WH40,WH65,WH31(6),WH31-EP(1), WH32 (1),WH32B [T/H/P] (1), WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 [SoilMoisture] (5), WH45
Meteobridge Pro (2) [test,prod] 5.1 Mar 11 2021, build 142351 - Barani MeteoshieldPro - Blake-Larsen Sun Recorder-RPi4/weewx/CumulusMX/MB
Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553);Weathercloud 3011399141, http://meshka.eu/meteo/template  -  http://meshka.eu/Weather34 - http://meshka.eu/pwsWD

Offline azchrisf

  • Cobra Weather Dominator Operator
  • Forecaster
  • *****
  • Posts: 341
Re: How about adding WH56 Lightning Sensor support?
« Reply #10 on: April 10, 2021, 05:30:35 PM »
1.6.6
I am running the latest Meteobridge (5.1 Apr 8th)

Today I got a new WH57 from Amazon, it shows in the Ecowitt app too, shows strikes, etc.

I reset the Meteobridge. The same issue, all sensors except the lightning will appear.

This appears to be a Meteobridge programming issue.

I have tried contacting Boris about it but he ignores me.
Davis Vantage Pro 2 Plus 6163 w/ 8 Transmitters!
Also doing Soil and Leaf 4x
WU: KAZGLEND106 CWOP: FW1398 (F1398) Purpleair: 98793/LAZGLEND8

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 478
Re: How about adding WH57 Lightning Sensor support?
« Reply #11 on: April 11, 2021, 09:39:37 AM »
Boris' reaction times are unpredictable.
Also, you sometimes have to be careful with your tone, wording etc. - he can be sensitive there.
Plus, working on other things - his priority list is not published.  8-)

Did you open a ticket (created a post) in the forum.meteohub.de ?
(I didn't see it there yet - or it is already pretty old - or has some enigmatic subject).
https://forum.meteohub.de/viewforum.php?f=61
Assuming you fit into this category - otherwise it's the other one.

I would give it the subject - "WH57 lightning sensor values don't show in raw live data (station=GW1000)"
describe your setup: primary station = Vantage, station 1 = GW1000;
WH57 shows in ecowitt.net and WSView but not in MB raw live data.
latest FW: GW1000 1.6.6 - MB 5.1 8-Apr-2021

There it will get more attention - also from users who are meeting the same or similar issue(s).

Also, if I were you, I would correct the typo in the subject of the original post: change WH56 to WH57 !
« Last Edit: April 11, 2021, 09:43:28 AM by Gyvate »
Froggit WH4000SE (=EW 2320E) 1.5.7/Froggit DP1500 1.6.6 (+2 x EW GW1000 1.6.6 test/backup)/HP1000SE Pro (HP2551) 1.5.7/1.6.9, WH2650 WiFi (2) 1.6.7-
Ecowitt WS80,WH40,WH65,WH31(6),WH31-EP(1), WH32 (1),WH32B [T/H/P] (1), WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 [SoilMoisture] (5), WH45
Meteobridge Pro (2) [test,prod] 5.1 Mar 11 2021, build 142351 - Barani MeteoshieldPro - Blake-Larsen Sun Recorder-RPi4/weewx/CumulusMX/MB
Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553);Weathercloud 3011399141, http://meshka.eu/meteo/template  -  http://meshka.eu/Weather34 - http://meshka.eu/pwsWD