Author Topic: ECOWITT HP2551 WiFi Weather Station outside temp not working  (Read 204 times)

0 Members and 1 Guest are viewing this topic.

Offline bunty13

  • Member
  • *
  • Posts: 7
ECOWITT HP2551 WiFi Weather Station outside temp not working
« on: October 07, 2020, 12:21:04 AM »
Hi all
Sorry if this has been asked before . I have a ECOWITT HP2551 WiFi Weather Station that  i got in july and the outside temp stopped working today , also the feels like ,dew point and humidity everything else seems to be working ok . Is there anything i can try to get this working or do i need to contact the company . Any info is appreciated

Offline sky_watcher

  • Senior Member
  • **
  • Posts: 59
Re: ECOWITT HP2551 WiFi Weather Station outside temp not working
« Reply #1 on: October 07, 2020, 01:11:32 AM »
Hi all
Sorry if this has been asked before . I have a ECOWITT HP2551 WiFi Weather Station that  i got in july and the outside temp stopped working today , also the feels like ,dew point and humidity everything else seems to be working ok . Is there anything i can try to get this working or do i need to contact the company . Any info is appreciated
It seems odd that the "feels like" is working if the temperature sensor is kaput because that sort of reading is normally associated with the external temperature, external humidity and wind speed. The temperature and relative humidity are in the same sensor, so usually both readings go haywire with a failure, but having one reading fail is not impossible.

Have you tried the "usual suspects"? (1) Re-Registering the external sensors. (2) Rebooting the console and the external sensor head. (3) Making sure that you have the latest firmware? BTW, just removing the battery from the WH65 will not power cycle it, as there is a supercapacitor which will keep power the unit for some time. 

Have you confirmed that your console is actually locking onto your external sensor? I do this be bringing the external sensor inside, putting in new batteries, and watching that the wind direction and wind speed is altered by moving the wind vane by hand and then blowing on the cups. It should also (hopefully) give plenty of signal strength so you won't be getting any issues caused by interference.

If you contact your supplier, they will ask if you have done this sort of thing to confirm that you are conencting to your external senor and that your sensor is actually not working. I have just had the external temp/humidity sensor fail myself.

After asking for me to check the above steps, the supplier asked when I wanted to send back the unit for repair, or whether they could send me the sensor to replace it. I said that I would do it as long as I didn't need to chisel the sensor out of a glued mounting. They said that this was not required and now I'm waiting for the replacement.

The reason they will ask if you are sure that you are connected to your external sensor is that your console could lock onto near-by sensors. Not just another HP2551, but something like the head of a HP1000 which is compatible. I'm currently using an old HP1000 head with my HP2550 console until I replace the dud sensor in the WH65 unit, so locking onto the wrong unit is a real possibility.

Hope this helps.
“The more a man knows, the more willing he is to learn. The less a man knows, the more positive he is that he knows everything...” ― Robert G. Ingersoll

Offline bunty13

  • Member
  • *
  • Posts: 7
Re: ECOWITT HP2551 WiFi Weather Station outside temp not working
« Reply #2 on: October 07, 2020, 01:16:23 AM »
Sorry I meant that the temp ,feels like dew point and humidity are not working but all others are .I have not tried the things you said but will try as soon as the light rain stops lol . But thanks for the reply gives me some place to start

Offline Mandrake

  • Forecaster
  • *****
  • Posts: 815
Re: ECOWITT HP2551 WiFi Weather Station outside temp not working
« Reply #3 on: October 07, 2020, 03:05:14 AM »
Just be aware that removing the batteries will not stop the array transmiting straight away.
The batteries are backups only to provide power once the super capacitor (fed from the solar array) has run down.
You may need to place it in a dark room for a few days.

You could try a reset on the sensor array (there is a pin hole to do that) and then you will probably need to re-register the array on the console via the sensor ID page.

However all that done and if you still have no temp/humidity then I would say you need to do a RMA and get a replacement sensor array
Retired: Old Maplin N96Y/FO Weather station
G1ZFO

Ecowitt HP2551A + WH65 Tri-Wing (Wunderground: IGUILDFO67)
Ecowitt GW1000 (Wunderground: IGUILDFO68)
Ecowitt GW1000 (Mk2) test environment driving CumulusMX on a RPi 3b
Ecowitt WH51 (x6) Soil Moisture Sensor
Ecowitt WH41 PM2.5 AQM Sensor
Ecowitt WH31 (x8) Thermo/Hygro Sensor
Ecowitt WS80 Ultrasonic Anemometer (pre-prod test)
Ecowitt WH57 Lightning Sensor (pre-prod test)
Ecowitt WH32-EP (SHT35)

Offline bunty13

  • Member
  • *
  • Posts: 7
Re: ECOWITT HP2551 WiFi Weather Station outside temp not working
« Reply #4 on: October 20, 2020, 01:10:58 AM »
Just to let you know after contacting them they asked me to link them to the web page that i have my unit linked , after 24 hours they contacted me to say they were going to replace the unit and its on the way now . Thanks so much for you help as i tried everything you said so when i contacted them it was all done :)