Author Topic: Virtual VP and Windows 10  (Read 397 times)

0 Members and 1 Guest are viewing this topic.

Offline tmabell

  • Forecaster
  • *****
  • Posts: 319
Virtual VP and Windows 10
« on: July 07, 2020, 03:17:04 PM »
I've seen a few mentions here regarding Windows 10 (x86) and Virtual VP but nothing too recently.  I'm interested in opinions from those who use VVP on Windows 10,  successes & failures to be specific.  I'll be upgrading from a smooth-running Win 7 Pro system to Win 10 Pro soon and I'd like to have all possible issues ironed out before I flip the switch.

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2391
    • SouthEast Lincoln, NE Weather
Re: Virtual VP and Windows 10
« Reply #1 on: July 07, 2020, 06:52:35 PM »
I'm running VVPro as the primary data source on the computer connected to my VPro2+ via a USB to Serial adapter.  The data is forked from there to three other computers via VVPro on each of them using TCPIP.  All of these computers are running Windows 10, the latest version.

I have occasionally seen the VVPro's lose interconnectivity, but restarting the offending VVPro(s) (not the computer(s) itself(themselves)) almost invariably restores communications.  Rarely is a computer restart required.

Good old com0com 64-bit null port emulator handles the ports on the primary computer.
Regards, Jerry Wilkins
gwwilk@gmail.com

Offline tmabell

  • Forecaster
  • *****
  • Posts: 319
Re: Virtual VP and Windows 10
« Reply #2 on: July 07, 2020, 07:06:51 PM »
Do you recall any connection loss occurring when you were using it with Win 7? 

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2391
    • SouthEast Lincoln, NE Weather
Re: Virtual VP and Windows 10
« Reply #3 on: July 08, 2020, 07:17:54 AM »
A connection would occasionally fail, but restarting VVPro on the computer with the failed connection usually worked.  On rare occasions the entire setup would fail, but restarting them all quickly solved the problem.  My old Lenovo Athlon dual core running Win7 Ultimate was dog slow and temperamental before it finally gave up the ghost with a failed main hard drive.

I ran the current primary Win10 Ryzen7 for about a year as a backup in reserve before I swapped it in as my main WD computer that now feeds the three dependent WD computers, two of which are 'reserve backups'.  Over the years I've had enough computers fail for myriad reasons that the only secure backup to my mind is another computer that duplicates the function of the primary computer.  It may seem like overkill, but the quick installation of the Ryzen7 in place of the Athlon a couple of weeks ago just took minutes instead of the days that would otherwise have been required.  Setting up the backup computers before they're needed may take the same amount of time, but they're off line during setup and my website's down time is then minimal when the backup is called into duty.
Regards, Jerry Wilkins
gwwilk@gmail.com