Author Topic: Virtual VP TCIP drops connection  (Read 163 times)

0 Members and 1 Guest are viewing this topic.

Offline Garth Bock

  • Table Rock Lake Weather
  • Forecaster
  • *****
  • Posts: 2149
Virtual VP TCIP drops connection
« on: March 16, 2020, 02:15:22 PM »
I recently upgraded from Win7 to 10 on the weather station. Switched VVpro from comm to TCIP. My weather station is running 1.90 firmware. I am currently running Cumulus, Virtual Weather Station, and WLink. I lost my number to VVpro so I am using the free number from his website. Every 2 days on the average I find that all weather programs have lost connection. If I start VVpro and all the weather programs everything runs again for about 2 days and then I have to do it again. Any ideas ? Please do not say I need Startwatch. Everything ran fine on Win7 on the same computer. I have checked my serial port driver and settings and that doesnt seem to be it. What serial port program is everyone using to keep multiple programs running and is there a screen shot of how to configure it ? I moved to Missouri from the screwed up corrupt state of Illinois and I want to get my website up and running but cant if the weather software keeps dropping.

Online saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 7651
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Virtual VP TCIP drops connection
« Reply #1 on: March 16, 2020, 03:13:20 PM »
The VirtualVP page has a key that should work indefinitely, and that should fix the shutdown every 2-days issue (I think).
I'm using Eterlogic VSPE paid version for 64bit Windows (only the 32bit version is free, but doesn't work on Win10 as they've turned off 32bit drivers).  Also, if your station is really USB, check the drivers there.. they may need an update.  Real serial port drivers should be fine as built-in to Windows 10.
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline Garth Bock

  • Table Rock Lake Weather
  • Forecaster
  • *****
  • Posts: 2149
Re: Virtual VP TCIP drops connection
« Reply #2 on: March 16, 2020, 03:39:48 PM »
The VirtualVP page has a key that should work indefinitely, and that should fix the shutdown every 2-days issue (I think).
I'm using Eterlogic VSPE paid version for 64bit Windows (only the 32bit version is free, but doesn't work on Win10 as they've turned off 32bit drivers).  Also, if your station is really USB, check the drivers there.. they may need an update.  Real serial port drivers should be fine as built-in to Windows 10.

Forgot to mention that my weatherlink is serial. The key I used was off the softwx site. I will try the etherlogic drivers. I would like to go back to using comm ports. Everything was working fine with that.
 

Offline Garth Bock

  • Table Rock Lake Weather
  • Forecaster
  • *****
  • Posts: 2149
Re: Virtual VP TCIP drops connection
« Reply #3 on: March 20, 2020, 03:30:15 PM »
The VirtualVP page has a key that should work indefinitely, and that should fix the shutdown every 2-days issue (I think).
I'm using Eterlogic VSPE paid version for 64bit Windows (only the 32bit version is free, but doesn't work on Win10 as they've turned off 32bit drivers).  Also, if your station is really USB, check the drivers there.. they may need an update.  Real serial port drivers should be fine as built-in to Windows 10.

Thanks for the tip. Running VSPE and everything is stable now. Working on getting a website up and running. Looking over Meteo and FreshWDL but havent decided yet. So far here on the MoArk border we have had 7 inches this month with 17 inches of rain since January 1st.