Author Topic: Weather Underground keeps showing Web Cam Offline  (Read 1125 times)

0 Members and 1 Guest are viewing this topic.

Offline tochs

  • Member
  • *
  • Posts: 8
Weather Underground keeps showing Web Cam Offline
« on: January 16, 2020, 02:37:20 PM »
I installed a Reolink RLC-511 camera and am trying to get it to work with my Weatherundergound account.  I added the device on my WU account and received the device ID and upload key (password).  I configured the FTP settings in my camera and when I test it, it says FTP test successful.  When I check my WU devices it shows my PWS online, but the camera is offline and no images appear.  If I log onto the FTP server I can see my tests are uploading, but there are no images on WU.  I have tried finding a solution online, but with no success.  Can someone offer me any help?  I am attaching a jpg of my FTP camera settings. 

Offline rormeister

  • Senior Contributor
  • ****
  • Posts: 196
Re: Weather Underground keeps showing Web Cam Offline
« Reply #1 on: January 16, 2020, 03:09:44 PM »
Check your image file size. Max is 150kb.

Offline tochs

  • Member
  • *
  • Posts: 8
Re: Weather Underground keeps showing Web Cam Offline
« Reply #2 on: January 16, 2020, 03:23:30 PM »
I'm assuming you're referring to the maximum file length in my FTP settings?  it won't accept any value below 10.  Not sure how to make it any smaller?

Offline rormeister

  • Senior Contributor
  • ****
  • Posts: 196
Re: Weather Underground keeps showing Web Cam Offline
« Reply #3 on: January 16, 2020, 03:30:31 PM »
Are you able to actually see the .jpg file you're sending up to WU?  Check it's file size. This most likely is the hurdle you need to jump. Reolink (according to their PR fluff) boasts high res and my guess is it results in a file too large for their process.

Offline tochs

  • Member
  • *
  • Posts: 8
Re: Weather Underground keeps showing Web Cam Offline
« Reply #4 on: January 16, 2020, 03:37:59 PM »
I'm afraid you may be correct.  I don't know how I would check to see the file it's trying to send?  I specifically bought this camera to use with my PWS, but I may be screwed unless I can figure out some work around.   Thanks.

Offline rormeister

  • Senior Contributor
  • ****
  • Posts: 196
Re: Weather Underground keeps showing Web Cam Offline
« Reply #5 on: January 16, 2020, 03:46:34 PM »
Here's a local URL which might work:

The URL should be:
http://(ip address)/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=(any combination of numbers and letters)&user=(user name)&password=(user password)

For example, if your camera's IP address is 192.168.2.119, the username is "admin" and the password is "123456", then the URL should be:

http://192.168.2.119/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=wuuPhkmUCeI9WG7C&user=admin&password=123456

You may refresh the website to get a new snapshot of your live image. Try this. If you're successful, an image will appear in your web browser. Save it locally and then check it's statistics.

Credit: (https://support.reolink.com/hc/en-us/articles/360007011233-How-to-Capture-Live-JPEG-Image-of-Reolink-Cameras-via-Web-Browsers)

Offline tochs

  • Member
  • *
  • Posts: 8
Re: Weather Underground keeps showing Web Cam Offline
« Reply #6 on: January 16, 2020, 04:09:45 PM »
Thank you for your help.  That worked.  it shows the file size is 581kb so you're correct in that it is too big for WU.  Now I have to see if that can be made smaller or some other work around.  Thanks again for helping me figure this out.  I just read on Reolink's web site if your camera FTP test is successful, but no images appear on WU, you may need to set up a local FTP server then send it from there.  Guess I'll have to Google how to do that.   As usual, this is turning into more work than I anticipated!

Offline rormeister

  • Senior Contributor
  • ****
  • Posts: 196
Re: Weather Underground keeps showing Web Cam Offline
« Reply #7 on: January 16, 2020, 04:31:46 PM »
If you're on a Win10 box, you can set up an FTP server on the box itself. That gets you half way there. The next step is to smoosh the file down to under 150k. This can be accomplished with the "convert.exe" piece of ImageMagick (ImageMagick.org). It's a command line tool that with a little scripting you can "read" the awaiting image from the camera, then "convert" it to a smaller version (re-naming it in the process), then it's ready do FTP to WU.

The command looks something like: "path-to-exe-file\convert.exe" "path-to-camera-image\imagename.jpg" -define jpeg:extent=145kb "path-to-ftp-imagefolder\image.jpg"

For the FTP piece I use WinSCP (WinSCP.net), another command line tool. Using scripts, driven by a Windows Scheduled Task, you can get your process rolling smoothly. Be sure to slow down the image delivery from the camera (like no more frequently than 5 minutes) to allow time for all the scripts to run.

YMMV

Offline tochs

  • Member
  • *
  • Posts: 8
Re: Weather Underground keeps showing Web Cam Offline
« Reply #8 on: January 16, 2020, 04:47:59 PM »
Thank you.  I just set up the FTP server on my PC.  Next will work on the remainder of your recommendations.  Wish me luck!

Offline tochs

  • Member
  • *
  • Posts: 8
Re: Weather Underground keeps showing Web Cam Offline
« Reply #9 on: January 21, 2020, 09:07:30 AM »
I set up an FTP server on my computer, changed some of the camera settings to make the image files smaller and had the camera send the images to my server.  The camera would send the images to my server at the designated intervals without a problem and the file size was well under 150kb Weatherunderground limit.  So I changed the cameras FTP settings back to WU’s FTP server.  The FTP tests were successful as before.  When I log onto WU’s FTP server I can see where it’s creating directories with the current date, but no image files appear in the folders and under my devices it still shows the camera offline.  Any ideas why no image files appear on WU’s FTP server and why it’s still showing my camera offline when it’s obviously communicating with WU?  Any more help or suggestions would be appreciated. 

Offline konz

  • Senior Contributor
  • ****
  • Posts: 165
    • ArlingtonWX
Re: Weather Underground keeps showing Web Cam Offline
« Reply #10 on: January 26, 2020, 08:39:29 AM »
...When I log onto WU’s FTP server I can see where it’s creating directories with the current date, but no image files appear in the folders and under my devices it still shows the camera offline. 

In your camera FTP Settings dialog, enter the forward slash (/) in the Upload Directory text box and try that.  I had a similar problem when using WPUT, the command would duplicate the same path on the FTP site as on my computer, and the WU process couldn't find the file because it is expected in the root path.  Using the forward-slash should ensure the file shows up in the root of the destination FTP site. 

You should also be able to use FileZilla to FTP into the WU site and delete these unnecessary directories.
« Last Edit: January 26, 2020, 08:44:07 AM by konz »

Offline tochs

  • Member
  • *
  • Posts: 8
Re: Weather Underground keeps showing Web Cam Offline
« Reply #11 on: January 26, 2020, 12:16:31 PM »
Thank you for your reply and suggestion.  Unfortunately I have tried it both with and without the "/" without any success.  The test goes into the root directory but the automated FTP's go into empty daily sub directories without any image files.   Do you know how critical the image file name is?  I know WU"s instructions give the example of a file name as image.jpg.  When my camera FTP's an image it gives it the camera name and a date and time stamp jpg and I can't find anywhere to configure the camera's FTP image name setting. 

As far as using FileZilla are there instructions somewhere on setting it up to send files to WU?  One thing I have learned by reading multiple posts, many people have problems getting web cams to work with Weather Underground.  Thanks for your help. 

Offline jimi

  • Member
  • *
  • Posts: 42
    • Well Road Weather
Re: Weather Underground keeps showing Web Cam Offline
« Reply #12 on: January 26, 2020, 05:15:06 PM »
IIIRC the file name needs to be image.jpg  it's not an example, it's what it needs to be, although I may be totally wrong about that.
« Last Edit: January 26, 2020, 05:48:47 PM by jimi »
Black is not a colour ! .... Its the absence of colour

Offline tochs

  • Member
  • *
  • Posts: 8
Re: Weather Underground keeps showing Web Cam Offline
« Reply #13 on: January 26, 2020, 05:19:58 PM »
Thank you.  I will need to see if you can configure the camera to FTP the image with that name. 

Offline jimi

  • Member
  • *
  • Posts: 42
    • Well Road Weather
Re: Weather Underground keeps showing Web Cam Offline
« Reply #14 on: January 26, 2020, 08:29:45 PM »
Been checking mine and althought one of my cams is set to upload image. jpg I can't find a setting for image name on the other, but it uploads to WU ok. So I may well be wrong on this.. sorry  :oops:
Black is not a colour ! .... Its the absence of colour

Offline konz

  • Senior Contributor
  • ****
  • Posts: 165
    • ArlingtonWX
Re: Weather Underground keeps showing Web Cam Offline
« Reply #15 on: January 26, 2020, 10:45:59 PM »
I think the only thing you have left is to try renaming your output file to image.jpg

Curious, does your camera have a red or green dot in your WU device list?

Offline rormeister

  • Senior Contributor
  • ****
  • Posts: 196
Re: Weather Underground keeps showing Web Cam Offline
« Reply #16 on: January 27, 2020, 05:56:12 PM »
Before I finally gave up entirely on having a web cam associated with my site, using the URL pull method, I ‘tricked’ WU by placing 3 images one for each of “3” cameras all taken from the same spot. Basically there was a image_l.jpg, image_c.jpg, and image_r.jpg (left, center, right). The left and right images matched the dashboard display size justified left or right. The center image was the full width (1920x1080) image that would appear correctly on the wundermap but was trimmed on the left and right by WU. It was slick until WU flat out stopped pulling ANY of my images.

Offline railrode1

  • Member
  • *
  • Posts: 42
Re: Weather Underground keeps showing Web Cam Offline
« Reply #17 on: January 30, 2020, 07:26:33 AM »
I had a similar issue and my cam only shows up on WU when I keep the infrared led's on. It shows as Black and white image. When I switch it to auto day/night, I lose upload because it goes to color. I set a schedule 7 days a week from 00:01 to 00:00 to keep it in night mode.

Offline awsum140

  • Forecaster
  • *****
  • Posts: 341
Re: Weather Underground keeps showing Web Cam Offline
« Reply #18 on: January 30, 2020, 08:50:29 AM »
@railrode1 When your camera goes into color mode the size of the image increases to to all the additional information needed to construct a color image.  A better solution, than keeping it in B&W mode, would be to reduce the image "size' either by resolution of just sending a percentage of the image if your software allows it.
If it's not a Boerboel it's just a dog.

KNJSOUTH86


Offline awsum140

  • Forecaster
  • *****
  • Posts: 341
Re: Weather Underground keeps showing Web Cam Offline
« Reply #19 on: January 30, 2020, 11:13:50 AM »
Looks like WU has broken the webcam feature yet again.  Mine is the spinning wheel of death and there are multiple reports of the same from other stations as well.
If it's not a Boerboel it's just a dog.

KNJSOUTH86


Offline Aaron407

  • Member
  • *
  • Posts: 12
Re: Weather Underground keeps showing Web Cam Offline
« Reply #20 on: January 30, 2020, 01:53:11 PM »
Looks like WU has broken the webcam feature yet again.  Mine is the spinning wheel of death and there are multiple reports of the same from other stations as well.
I had the same issue for the last day or so, but it looks like it just started working again a few minutes ago. Not holding my breath that it doesn't break again, though...