Author Topic: Anybody need a Texas Weather Instruments WRL-32  (Read 380 times)

0 Members and 1 Guest are viewing this topic.

Offline mijmoto

  • Member
  • *
  • Posts: 3
Anybody need a Texas Weather Instruments WRL-32
« on: November 04, 2019, 05:11:28 PM »
Hi All, recently replaced my WRL-32 with a Davis Vantage Pro 2.  Seems that TWI has closed their doors so I was unable to get my outdoor temperature sensor repaired.  I have the console, rain gauge, pagoda with non-functional tempurature sensor, anemometer, rooftop j box and the ethernet interface.  Looking to sell the lot to someone that needs parts.  The only thing that is non-functional is the outdoor temp. I don't have a number in mind so I am flexible.  Thanks.  Jim

 [ You are not allowed to view attachments ]  [ You are not allowed to view attachments ]

Offline CW2274

  • Forecaster
  • *****
  • Posts: 5163
    • Conditions @ CW2274 West Tucson-Painted Hills Ranch
Re: Anybody need a Texas Weather Instruments WRL-32
« Reply #1 on: November 04, 2019, 05:22:47 PM »
Seems that TWI has closed their doors
Just as an FYI, there was a thread here a couple of months ago that discussed this very thing and indeed they've gone under.

Offline mijmoto

  • Member
  • *
  • Posts: 3
Re: Anybody need a Texas Weather Instruments WRL-32
« Reply #2 on: November 04, 2019, 05:54:57 PM »
Yep.  Maybe my old unit can help somebody out.

Offline DaleReid

  • Forecaster
  • *****
  • Posts: 1545
    • Weather at Eau Claire, WI
Re: Anybody need a Texas Weather Instruments WRL-32
« Reply #3 on: November 04, 2019, 07:33:06 PM »
I am not aware of anyone locally that wants to put time into one of these.

There were a couple of guys this spring, summer maybe, that were looking for just the part you have that isn't working.  I think there was some fix possible, but my schedule went absolutely crazy, along with a flare up of my arthritis which you can't believe how that hinders one's energy and stamina.

Nonetheless, the worst part will be the packing and shipping.  Have you weighed it, and seen what size of box it can SAFELY fit it?

I would advise strongly against selling it peicemeal unless you just have to.  Finding individual parts, especially those that work, has become close to impossible.

On the other hand, while I have three of the 25s laying around, I'm very hesitant to see one of these go to the scrap pile.

If you can get an estimate of what to ship to zip 54701 and what you'd like for the stuff, let me know.  I know that near complete systems had been going for less than $300 a few years ago, and a full system, still in box, was last seen by me going for about $275, so used and with a wayward temp sensor, it no doubt wouldn't be that.

I don't mean to bear bad news, but you might be pleasantly surprised prove me way wrong by putting it in the For Sale part of WxForum to see if there are any takers.

I have a couple of Taylor Windscope/Stormscope units, new in very old box, that the killer is the shippping charges for them.  If it doesnt fit in a USPS box, it can become pricey.  Please check directly with UPS or FedEx, since the 'stores' for UPS charge a premium to ship the same box compared to the UPS place directly.

Keep me posted.  Dale
reid@eau.net
ECWx.info
&
ECWx.info/t/index.php

Offline DaleReid

  • Forecaster
  • *****
  • Posts: 1545
    • Weather at Eau Claire, WI
Re: Anybody need a Texas Weather Instruments WRL-32
« Reply #4 on: November 04, 2019, 07:34:47 PM »
Jim,
I forgot to ask if the outdoor humidity sensor is still working, or at least within ball park of the values your other stations report?

That is harder to fix than is the temp sensor.  But would be a positive in selling/giving it away.
Dale
ECWx.info
&
ECWx.info/t/index.php

Offline mijmoto

  • Member
  • *
  • Posts: 3
Re: Anybody need a Texas Weather Instruments WRL-32
« Reply #5 on: November 04, 2019, 11:09:02 PM »
Hi Dale, I appreciate your comments.  I am like minded in that I can't throw this away but realize that it's value lies in the parts.  I am pretty sure that the humidty sensor was fine although the pictures show a zero value.  I removed the pagoda from the roof to see about the temp sensor so the humidy sensor was not connected at the time of the photo.  I am a little surprised that the value is "0" versus some error.  I shipped this unit back to Texas years ago for some reason then hand carried it in 2016 to get the ethernet card installed.  Good guys at the facility and I am surprised that there isn't a trace of them at this point.  In any case, I will think about what to do and move my post to the for sale section.  Probably be happy to get the shipping paid.  Thanks for your thoughts. Jim

 

anything