Author Topic: Bad solar panel in 5 in 1 Pro +  (Read 371 times)

0 Members and 1 Guest are viewing this topic.

Offline Glenn

  • Forecaster
  • *****
  • Posts: 389
Bad solar panel in 5 in 1 Pro +
« on: October 21, 2019, 01:43:15 PM »
I took my CT unit down this weekend to change the batteries. Amazon Basic AA's lasted two years and two months. Not bad!

I've noticed that my station gets a slight temp spike in the morning when the sun hits it, then settles back down. Found out that one of the solar panels isn't working.

How do you remove that part of the unit? I was able to get the part with the wind cups and panels off the body, but couldn't dissemble it from there. Not sure what was holding it together?

Edit: It's a Pro + unit with two solar panels.

Open to any tips or pics!
« Last Edit: October 21, 2019, 01:45:53 PM by Glenn »
Acurite 5 in 1 Pro+
Southern VT
Connecticut


Offline Glenn

  • Forecaster
  • *****
  • Posts: 389
Re: Bad solar panel in 5 in 1 Pro +
« Reply #2 on: October 22, 2019, 09:23:06 AM »
https://www.acurite.com/media/manuals/06003RM-5N1DSSA-instructions.pdf

https://www.acurite.com/pro-plus-upgrade-for-5-in-1-weather-sensor.html

Thanks for posting those! I was actually able to get the unit separated as listed in the directions. I was looking for some guidance on how to take the unit apart from there, getting access to the backside of the panels and the motor that powers the fan.
Acurite 5 in 1 Pro+
Southern VT
Connecticut

Offline Glenn

  • Forecaster
  • *****
  • Posts: 389
Re: Bad solar panel in 5 in 1 Pro +
« Reply #3 on: November 05, 2019, 01:25:20 PM »
Anyone know how to get the panels off of the unit or remove the shaft that holds the wind cups?
Acurite 5 in 1 Pro+
Southern VT
Connecticut

Offline DoctorKnow

  • Forecaster
  • *****
  • Posts: 1597
Re: Bad solar panel in 5 in 1 Pro +
« Reply #4 on: November 05, 2019, 01:48:02 PM »
Vice grips on the top of the shaft. Then wiggle the magnet bar back and forth as you pull it off while pulling the vice grip. It's not easy. Maybe put some spray on it like WD-40 first to help loosen the magnet bar. The wires for the solar panel are soldered to a regulator board. The solar panel is just glued to the plastic wind topper portion of the outer fan/wind part. You just carefully pry them off with a small flat tool.

Offline Glenn

  • Forecaster
  • *****
  • Posts: 389
Re: Bad solar panel in 5 in 1 Pro +
« Reply #5 on: November 07, 2019, 01:26:55 PM »
Vice grips on the top of the shaft. Then wiggle the magnet bar back and forth as you pull it off while pulling the vice grip. It's not easy. Maybe put some spray on it like WD-40 first to help loosen the magnet bar. The wires for the solar panel are soldered to a regulator board. The solar panel is just glued to the plastic wind topper portion of the outer fan/wind part. You just carefully pry them off with a small flat tool.

This is very helpful! Thanks so much for posting this.
Acurite 5 in 1 Pro+
Southern VT
Connecticut

Offline DoctorKnow

  • Forecaster
  • *****
  • Posts: 1597
Re: Bad solar panel in 5 in 1 Pro +
« Reply #6 on: November 07, 2019, 04:36:45 PM »
Vice grips on the top of the shaft. Then wiggle the magnet bar back and forth as you pull it off while pulling the vice grip. It's not easy. Maybe put some spray on it like WD-40 first to help loosen the magnet bar. The wires for the solar panel are soldered to a regulator board. The solar panel is just glued to the plastic wind topper portion of the outer fan/wind part. You just carefully pry them off with a small flat tool.

This is very helpful! Thanks so much for posting this.

No prob. Hope you figure out the issues. We can help if you are not sure.

Offline Glenn

  • Forecaster
  • *****
  • Posts: 389
Re: Bad solar panel in 5 in 1 Pro +
« Reply #7 on: November 08, 2019, 02:03:34 PM »
Me too! It may not get resolved until Spring, but I'll get there eventually.
Acurite 5 in 1 Pro+
Southern VT
Connecticut