Author Topic: Cumulus 3051  (Read 678 times)

0 Members and 1 Guest are viewing this topic.

Offline franmiele

  • Member
  • *
  • Posts: 9
Cumulus 3051
« on: September 12, 2019, 04:48:22 PM »
I just installed the latest version on a raspberry PI. I can't get it to FTP to connect to my hosting site. I also installed it on a win10 machine and I can get the FTP to work fine. Is there something wrong with FTP when running on a RPI?

Offline WSWeather

  • Forecaster
  • *****
  • Posts: 302
Re: Cumulus 3051
« Reply #1 on: September 12, 2019, 08:54:27 PM »
Can you FTP from the Linux command line to the site you wish to connect to?

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #2 on: September 12, 2019, 10:40:04 PM »
Iím not sure I know how in Debian

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #3 on: September 13, 2019, 11:27:27 AM »
I have done more testing and find that CumulusMX on my RPI will FTP to a site that does not require SFTP. As I stated earlier, running CumulusMX on a win10 system the FTP works also. There must be something wrong when running under MONO on the RPI when the FTP site requires SFTP.

Does anyone know how to fix this?

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #4 on: September 13, 2019, 11:28:37 AM »
Can you FTP from the Linux command line to the site you wish to connect to?

I don't find any FTP client on my RPI running Buster. I'll have to figure out how to install it

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #5 on: September 13, 2019, 12:34:15 PM »
Can you FTP from the Linux command line to the site you wish to connect to?

Yes, I can ftp to the site using lftp.

Offline the beteljuice

  • the beteljuice
  • Senior Contributor
  • ****
  • Posts: 159
    • test site
Re: Cumulus 3051
« Reply #6 on: September 13, 2019, 05:39:55 PM »
If you are running mono 6 it is not at the moment 'stable' enough to run CUmx (lots of 'locale' setting problems etc.)
Imagine what you will KNOW tomorrow !

Offline the beteljuice

  • the beteljuice
  • Senior Contributor
  • ****
  • Posts: 159
    • test site
Re: Cumulus 3051
« Reply #7 on: September 13, 2019, 06:02:24 PM »
regarding SFTP ... I found this snippet:

After disabling Active FTP mode the upload went well.
In the ftplog.txt file is says: ....

Have you looked in your logs ?
Imagine what you will KNOW tomorrow !

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #8 on: September 13, 2019, 06:05:06 PM »
regarding SFTP ... I found this snippet:

After disabling Active FTP mode the upload went well.
In the ftplog.txt file is says: ....

Have you looked in your logs ?

Yes, The FTP never makes the connection to the site. I have tried with "active ftp" and without. Same result..

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #9 on: September 13, 2019, 06:05:56 PM »
If you are running mono 6 it is not at the moment 'stable' enough to run CUmx (lots of 'locale' setting problems etc.)

I don't know which version of mono is running. How do I find out?

Offline freddie

  • Member
  • *
  • Posts: 19
    • Dorrington Weather
Re: Cumulus 3051
« Reply #10 on: September 14, 2019, 07:28:38 AM »
If you are running mono 6 it is not at the moment 'stable' enough to run CUmx (lots of 'locale' setting problems etc.)

I don't know which version of mono is running. How do I find out?
Type the following on the command line:
Code: [Select]
mono --versionThis will tell you the version of mono in use.
Freddie

Offline freddie

  • Member
  • *
  • Posts: 19
    • Dorrington Weather
Re: Cumulus 3051
« Reply #11 on: September 14, 2019, 07:35:40 AM »
I have done more testing and find that CumulusMX on my RPI will FTP to a site that does not require SFTP. As I stated earlier, running CumulusMX on a win10 system the FTP works also. There must be something wrong when running under MONO on the RPI when the FTP site requires SFTP.

Does anyone know how to fix this?
Cumulus MX does not support SFTP natively, although it does support FTPS - which is a secure protocol, but different to SFTP.  If your host supports FTPS then I would recommend using it.  If you need SFTP then you can configure Cumulus MX to use an external program such as scp to do it for you.  There is an article on the Cumulus Wiki which describes how to do this.

SFTP may be available in a future release of MX, but the above should suffice for the short term.
Freddie

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #12 on: September 14, 2019, 12:34:52 PM »
I have done more testing and find that CumulusMX on my RPI will FTP to a site that does not require SFTP. As I stated earlier, running CumulusMX on a win10 system the FTP works also. There must be something wrong when running under MONO on the RPI when the FTP site requires SFTP.

Does anyone know how to fix this?
Cumulus MX does not support SFTP natively, although it does support FTPS - which is a secure protocol, but different to SFTP.  If your host supports FTPS then I would recommend using it.  If you need SFTP then you can configure Cumulus MX to use an external program such as scp to do it for you.  There is an article on the Cumulus Wiki which describes how to do this.

SFTP may be available in a future release of MX, but the above should suffice for the short term.

Freddie, My hosting site requires sftp. The article you refer to seems to be for a windows implementation. I am trying to do this on a Raspberry PI  running Debian Buster.

What is baffling me is that when I am setup on my win10 system the FTP works fine, but not on the RPI system.

Fran

Offline franmiele

  • Member
  • *
  • Posts: 9
Re: Cumulus 3051
« Reply #13 on: September 14, 2019, 01:15:08 PM »
If you are running mono 6 it is not at the moment 'stable' enough to run CUmx (lots of 'locale' setting problems etc.)

I don't know which version of mono is running. How do I find out?
Type the following on the command line:
Code: [Select]
mono --versionThis will tell you the version of mono in use.

Thank you . found it. Not running ver 6