Author Topic: Bricked WS-1000  (Read 316 times)

0 Members and 1 Guest are viewing this topic.

Offline aherb

  • Member
  • *
  • Posts: 3
Bricked WS-1000
« on: September 10, 2019, 02:51:57 PM »
Hopefully this hasn't been thoroughly covered already. I did search around and didn't see any threads on this topic.

I inherited a WS-1000 weather station from a coworker who left the company about a year ago. This morning I decided to update the firmware to see if it would help the wifi connection problems that I've been having. I happened to miss the little not that says "Before you upgrade the firmware, check the About Page on your display console, and make certain you are running Firmware Version 2.0.0 or greater Failure to do so may cause your console to stop working." Guess what happened next?

Well now I'm the proud owner of a new paper weight. Ambient weather's email support was very responsive and helpful, but ultimately just told me to buy a new one for 150 bucks. I don't really expect them to replace a 4-5 year old console under this circumstance, but I find the whole thing pretty ridiculous. I feel like they could do a lot more to avoid this happening to their customers. Surely though, it's my fault for being a bit cavalier with the process and not reading the whole block of text.

Anybody else had this problem?

Online galfert

  • Forecaster
  • *****
  • Posts: 2918
Re: Bricked WS-1000
« Reply #1 on: September 10, 2019, 04:59:00 PM »
Sorry to hear that. That is what I call learning the hard way.

If it is of any consolation the newer models are much improved since the WS-1000. Sensors are better and newer models have access to Ambientweather.net.

Definitely do not get a replacement display for the WS-1000. That is dumping money into an old sensor. Good news is that maybe someone with bad sensors may want your old sensor array.

If you want to get it running you could get an Ecowitt GW1000 and it will pick up the data from your old sensor array. The GW1000 is very handy to have even for those with the newest model stations because of the added capabilities to use with other software like Weather-Display and Meteobridge. But the GW1000 works by itself also. So essentially you can have a weather station without a display. It will report to Weather Underground, Ecowitt.net, WeatherCloud, PWSweather, and WOW. It will also show you live data on local network on you mobile with the WS View app.

I would recommend the WS-2000 as a complete station replacement ($213) which makes more sense than $150 for a WS-1000 display....and yes use it with the Ecowitt GW1000.
« Last Edit: September 10, 2019, 05:02:26 PM by galfert »
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline aherb

  • Member
  • *
  • Posts: 3
Re: Bricked WS-1000
« Reply #2 on: September 11, 2019, 12:54:00 PM »
Thanks galfert! Very helpful advice. The GW1000 sounds perfect for me at the moment. I'd love to get this thing back up and running in the short term but I'm not in a position to spend more on a whole new system at the moment.

KWAMUKIL6 is the station (on wunderground). Hopefully I'll have it up again in a few days.

Online galfert

  • Forecaster
  • *****
  • Posts: 2918
Re: Bricked WS-1000
« Reply #3 on: September 11, 2019, 01:59:08 PM »
Looks like you were running firmware version V1.10.1 prior to the mishap. (got your version number from WU).

I've looked at this issue and the Ambient firmware download page is not providing enough information on how to get your station to version 2.0.0.

The downloads offered are only for the 1001 and 1002 models. You had a 1000 and there is no landing page for this older model. Essentially you attempted to install firmware that was not designed for the 1000. It clearly says that it is only for the 1001 and 1002.

Still I don't fault you for not reading the warning. It is a mistake that anyone could make. The firmware should check what is installed and throw up and error message that it is not compatible and not brick the unit. They should at least release a newer version that corrects this. This is common practice today so it is unfortunate to see this occurrence.

But there is a way to navigate the firmware repository (if you know how). I found an undocumented landing directory where all the old WS-1000 firmware are stored and this is undocumented and no link exists to get here:
https://p10.secure.hostingprod.com/@site.ambientweatherstore.com/ssl/easyweather/ws1000/

Probably too late now but if I had an old WS-1000 and I wanted to upgrade it I would one by one upgrade in order of what is published in this page I've linked. There are no instructions for this. There are no warnings for this. So proceed at your own risk if you are reading this and you have a WS-1000. Eventually this gets you past version 2.1.2. Therefore I would guess that you can then upgrade to version 2.1.7 which is the first available of the WS-1001/1002.

It is interesting to note that version 2.0.0, 2.0.1 and 2.0.2 are huge in comparison to all prior and afterwards versions.  These 3 versions are 19 MB. Every other version prior or afterwards is of size between 700 KB and 800 KB. The interesting part is that this shows that these other firmware versions are incremental. They assume a compatible base of a prior version. It is not until version 2.0.0, 2.0.1 and 2.0.2 that the base is overwritten as only these versions are a full upgrade to the device. There is no need for every version to be a full upgrade...but what is required from a reputable company would have been some safeguard of version checking.

And this is the directory for the 1001 and 1002 firmware (this one is linked on Ambient's website):
https://p10.secure.hostingprod.com/@site.ambientweatherstore.com/ssl/easyweather/ws1001/
« Last Edit: September 11, 2019, 02:03:34 PM by galfert »
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline aherb

  • Member
  • *
  • Posts: 3
Re: Bricked WS-1000
« Reply #4 on: September 11, 2019, 02:43:39 PM »
Great sleuthing! Just for fun a tried loading a few different firmware versions (1.10.1, 2.0.0, and 1.3.1). Unfortunately, all of them freeze while booting up. Worth a shot though!

I design things that require maintenance for a living and I've definitely been on the other side of this kind of mistake many times. It's hard to put yourself in the mind of a distracted and unfamiliar person working on something that you spend all day every day thinking about. The best method is always to remove the possibility of making a mistake, rather than try to warn against mistakes, but it's not always possible. So I'm not to worked up about it, stuff happens. Mostly I hope other people don't make the same mistake.

Offline Mandrake

  • Senior Contributor
  • ****
  • Posts: 216
Re: Bricked WS-1000
« Reply #5 on: September 12, 2019, 02:41:07 AM »
Great work finding the old versions Galfert.
I would say from your descriptions that the problem at hand is the bootloader. The big firmware files obviously include the new bootloader. In order to get back to a working system you will somehow need to find an original firmware V1 that includes the bootloader. Sadly that might never have been published, but if it has then that will get you working again and then you can proceed through the upgrade path.

You might have more luck searching the web for the Fine-offset original model number rather than Ambient as undoubtedly someone somewhere will have tripped over this before.
Very Old Maplin N96Y/FO Weather station w/ Cumulus MX

Ecowitt HP2550A (IGUILDFO67)
Ecowitt GW-1000 (IGUILDFO68)
Ecowitt GW-1000 (Mk2) test environment
Ecowitt WH-51 Soil Moisture Sensor
Ecowitt WH-41 PM2.5 AQM Sensor
Ecowitt WS-80 Ultrasonic Anemometer

Online galfert

  • Forecaster
  • *****
  • Posts: 2918
Re: Bricked WS-1000
« Reply #6 on: September 16, 2019, 09:27:40 AM »
I think at this point the device is bricked and even with an original 1.x.x full firmware there would be no way to load it normally.

The only solution is to wipe the firmware clean with a JTAG and then upload a fresh full 2.0.0 (one of the 19 MB versions).
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline Mandrake

  • Senior Contributor
  • ****
  • Posts: 216
Re: Bricked WS-1000
« Reply #7 on: September 16, 2019, 09:46:57 AM »
Agreed, I should probably have been clearer that with no effective bootloader (because the V2.x Firmware overwrote the original) that you cannot go backwards.

As you say you would need a mechanism to flash the ROM which is non trivial and a non starter for most.
I suspect there is no way back and that the item is permanently bricked beyond economical repair. Sometimes however there is a protected recovery partition but I doubt that this is likely in this implementation.
Very Old Maplin N96Y/FO Weather station w/ Cumulus MX

Ecowitt HP2550A (IGUILDFO67)
Ecowitt GW-1000 (IGUILDFO68)
Ecowitt GW-1000 (Mk2) test environment
Ecowitt WH-51 Soil Moisture Sensor
Ecowitt WH-41 PM2.5 AQM Sensor
Ecowitt WS-80 Ultrasonic Anemometer