Author Topic: Wunderground widgets not displaying on website with ssl  (Read 2521 times)

0 Members and 1 Guest are viewing this topic.

Offline WSWeather

  • Forecaster
  • *****
  • Posts: 411
Re: Wunderground widgets not displaying on website with ssl
« Reply #25 on: February 03, 2020, 03:09:20 PM »
I poked around with the "new" widget world order and there does not appear to be a way to specify an individual PWS as the current conditions source, and what they do provide is locked to specific websites you have to disclose the URLs of upfront.

That's a deal breaker.

Offline Bunty

  • Forecaster
  • *****
  • Posts: 2215
  • Stillwater, home of Oklahoma State University
    • Welcome to Stillwater Weather
Re: Wunderground widgets not displaying on website with ssl
« Reply #26 on: February 04, 2020, 05:39:28 AM »
Apparently the banners are still there, just moved to another URL.  I haven't worked out all the parameters yet but I am able to display this now where it was just "data unavailable" before:

 [ You are not allowed to view attachments ]

Code: [Select]
http://banners.wunderground.com/cgi-bin/banner/ban/wxBanner?bannertype=big2_cond&weatherstationcount=KILWESTE2

Nothing is working above now.

Also the 2nd home page using modified AltDashboard 6.95 at http://stillwaterweather.com/wx/2ndhome.php

Offline Elgin

  • Member
  • *
  • Posts: 4
Re: Wunderground widgets not displaying on website with ssl
« Reply #27 on: February 04, 2020, 04:55:56 PM »
The Wunderground supplied widget I've used for years on a community web site stopped functioning. The PWS is reporting on the WU site, but not to the widget. I think I've spent at least a accumulated 5 hours attempting to correct this problem - which I thought was my error!
So the good news for me is that I finally found out it wasn't at fault...the bad news is that I will no longer have a functioning widget.
And if the new ones offered by TWC come with ads...will that's it then.
I'm paid up at Wunderground until this time next year; after that, I'm out.

Offline K5GHS

  • Senior Member
  • **
  • Posts: 67
    • K5GHS's Website
Re: Wunderground widgets not displaying on website with ssl
« Reply #28 on: February 04, 2020, 07:52:47 PM »
From what I'm seeing, anything to do with WU apikeys is gone.  We'll see if it comes back, but as of right now I have an app on Android that is totally dead in the water because it says my apikey is invalid.

We'll see if it comes back from the dead or not.

EDIT:  Oddly enough, going on WU, "requesting" the apikey (it gave me the same one as a 'reply') and then reinserting it into said app (again, it was the exact same) caused it to start working again.  Might be that with the move they disabled them all and to re-enable you have to re-request.
« Last Edit: February 04, 2020, 08:14:20 PM by K5GHS »
Joshua
K5GHS
http://www.k5ghs.radio

Collin County, TX  Grid: EM13qd  CWOP: AV590
Skywarn Repeaters:  147.180 Primary 146.740 Secondary
100% Emergency Powered Ham Radio Station (540AH Batteries/Solar Rechargeable)
Ambient Weather WS-2000
Ecowitt GW1000

Offline am_dew

  • Member
  • *
  • Posts: 5
Re: Wunderground widgets not displaying on website with ssl
« Reply #29 on: February 04, 2020, 08:11:09 PM »
I have several WU widgets on my personal home page and interestingly enough, one still works. ](*,)

Offline Elgin

  • Member
  • *
  • Posts: 4
Re: Wunderground widgets not displaying on website with ssl
« Reply #30 on: February 04, 2020, 08:24:51 PM »
So what does one do with an API key?
When I look at "my devices" I see my pws, its status (online), ID, and "key" (dfb6dead). Under a second tab on that page is an API Key - and it shows "My Key" with a really long alpha/numeric number.
Not being very computer literate, I have no clue as to what the API key does for me...or doesn't. (I've read the common usage guide and frankly it's way over my head! :(

Offline am_dew

  • Member
  • *
  • Posts: 5
Re: Wunderground widgets not displaying on website with ssl
« Reply #31 on: February 04, 2020, 09:55:36 PM »
Al my widgets are suddenly working again! Check the link in my sig.  Go figure...  ](*,)
« Last Edit: February 04, 2020, 10:21:02 PM by am_dew »

Offline WSWeather

  • Forecaster
  • *****
  • Posts: 411
Re: Wunderground widgets not displaying on website with ssl
« Reply #32 on: February 04, 2020, 10:42:07 PM »
Al my widgets are suddenly working again! Check the link in my sig.  Go figure...  ](*,)

All I see are maps below the drop-down lists in the header.

ADDED:  Evidently when they rolled back the recent PWS data ingestion "improvement" it also rolled back the public data access portion of the old API so even the flash widget is working again.  I wouldn't get too used to it though.
« Last Edit: February 04, 2020, 10:48:58 PM by WSWeather »

Offline am_dew

  • Member
  • *
  • Posts: 5
Re: Wunderground widgets not displaying on website with ssl
« Reply #33 on: February 05, 2020, 01:00:45 AM »
Al my widgets are suddenly working again! Check the link in my sig.  Go figure...  ](*,)

All I see are maps below the drop-down lists in the header.
It looks like this to me...
« Last Edit: February 05, 2020, 09:27:17 AM by am_dew »

Offline RK

  • Member
  • *
  • Posts: 1
    • Genoa City Weather
Re: Wunderground widgets not displaying on website with ssl
« Reply #34 on: February 05, 2020, 10:22:03 AM »
Apparently the banners are still there, just moved to another URL.  I haven't worked out all the parameters yet but I am able to display this now where it was just "data unavailable" before:

 [ You are not allowed to view attachments ]

Code: [Select]
http://banners.wunderground.com/cgi-bin/banner/ban/wxBanner?bannertype=big2_cond&weatherstationcount=KILWESTE2

I guess things are about to change. I emailed WU and this is the response I got back.

JAN 27, 2020  |  04:10PM EST
Victoria replied:
Hi, Edward!

Moved off to a different location: https://doc.media.weather.com/products/v3.1/home.php

Thank you for using Weather Underground!

—Victoria

How satisfied were you with the resolution we provided today?
Poor | Fair | Good | Great
JAN 27, 2020  |  04:03PM EST
Original message
Edward wrote:

Just a quick question. Where did the weather website widgets / banners go? I dont see the option to get them anymore on my dashboard.

Thanks for any help.
KPAWEATH4

I received basically the same reply when I contacted them about the banner no longer working.  However, this morning (2/5/20), the banner works!  Don't know for how long, but at least it is there and updating with current readings.  Maybe they had a change of heart... <grin>

rk

Offline Elgin

  • Member
  • *
  • Posts: 4
Re: Wunderground widgets not displaying on website with ssl
« Reply #35 on: February 05, 2020, 10:27:54 AM »
Ok. Now I'm really confused! I had written an email as directed on their site, asking for a widget, and got back a reply:

"Hello. If you are trying to implement Max Web - Weather Widgets, you need to license the product. Let me know if you'd like to be put in touch with a sales representative for a quote.  Thanks, Billy Warner - Digital Content Support - The Weather Company, an IBM Business -TWCDigitalSupport@us.ibm.com"

That was not a surprise, since I figured a license would cost $$$ (which I'm not interested in buying)...but what is surprising is that the widget is working again! Perhaps because my account at WU is still paid up for another year?

In any case it will only last until the end of this year, after which (according to messages received), Adobe Flash will no longer be supported. I know it probably will still work for a while, but no support means no security, so I'll have to hunt for another widget then.
Meantime, I'm just glad it works! :)


« Last Edit: February 05, 2020, 10:29:53 AM by Elgin »

Offline Mabcmb

  • My WU page
  • Senior Contributor
  • ****
  • Posts: 259
Re: Wunderground widgets not displaying on website with ssl
« Reply #36 on: February 05, 2020, 10:32:25 AM »
Ok. Now I'm really confused! I had written an email as directed on their site, asking for a widget, and got back a reply:

"Hello. If you are trying to implement Max Web - Weather Widgets, you need to license the product. Let me know if you'd like to be put in touch with a sales representative for a quote.  Thanks, Billy Warner - Digital Content Support - The Weather Company, an IBM Business -TWCDigitalSupport@us.ibm.com"

That was not a surprise, since I figured a license would cost $$$ (which I'm not interested in buying)...but what is surprising is that the widget is working again! Perhaps because my account at WU is still paid up for another year?

In any case it will only last until the end of this year, after which (according to messages received), Adobe Flash will no longer be supported. I know it probably will still work for a while, but no support means no security, so I'll have to hunt for another widget then.
Meantime, I'm just glad it works! :)

 They rolled back the software so  " some " of the old widgets started working again . Now they also said they are working on another update so who knows how long the widgets will work for . My guess is a couple of weeks . As you can see the one in my signature now started working again after saying " no data " since the last failed update .

Offline emoyer70

  • Member
  • *
  • Posts: 7
Re: Wunderground widgets not displaying on website with ssl
« Reply #37 on: February 05, 2020, 10:41:17 AM »
Apparently the banners are still there, just moved to another URL.  I haven't worked out all the parameters yet but I am able to display this now where it was just "data unavailable" before:

 [ You are not allowed to view attachments ]

Code: [Select]
http://banners.wunderground.com/cgi-bin/banner/ban/wxBanner?bannertype=big2_cond&weatherstationcount=KILWESTE2

I guess things are about to change. I emailed WU and this is the response I got back.

JAN 27, 2020  |  04:10PM EST
Victoria replied:
Hi, Edward!

Moved off to a different location: https://doc.media.weather.com/products/v3.1/home.php

Thank you for using Weather Underground!

—Victoria

How satisfied were you with the resolution we provided today?
Poor | Fair | Good | Great
JAN 27, 2020  |  04:03PM EST
Original message
Edward wrote:

Just a quick question. Where did the weather website widgets / banners go? I dont see the option to get them anymore on my dashboard.

Thanks for any help.
KPAWEATH4

I received basically the same reply when I contacted them about the banner no longer working.  However, this morning (2/5/20), the banner works!  Don't know for how long, but at least it is there and updating with current readings.  Maybe they had a change of heart... <grin>

rk

I doubt it. Never expect anything and you wont be disappointed.

Offline am_dew

  • Member
  • *
  • Posts: 5
Re: Wunderground widgets not displaying on website with ssl
« Reply #38 on: June 03, 2020, 12:47:07 PM »
Widgets are off line again...