Author Topic: Intermittent loss of web GUI access on RED  (Read 508 times)

0 Members and 1 Guest are viewing this topic.

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3137
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Intermittent loss of web GUI access on RED
« on: September 03, 2018, 01:58:37 PM »
I am getting either a blank screen or very basic black and white display every so often with the GUI for the RED only. It requires a hard reset (out at the controller) to get it back running. I do not see this happening with my Blue unit.

I tried setting the "Ignore Signals below Threshold" to 20% and reverted to Manual instead of Automatic mode. (this seemed to be coincident with the "Auto" change, but I guess that this is not the problem)

The detector does seem to be very busy with a lot of signals. Maybe the processor is running out of mips. I just tried lowering my gains to reduce the signal processing of spurious signals. I'll have to see if this helps or not.

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3137
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Intermittent loss of web GUI access on RED
« Reply #1 on: September 04, 2018, 08:18:54 AM »
That didn't help, I had the black/white header names only on the GUI this morning. Strangely, it still is reporting to BO...

I attached a screenshot of what it is doing.

Greg H.






Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #2 on: September 04, 2018, 08:44:58 AM »
I'm also having the same problem with the web GUI disappearing on my RED only to be restored by a hard reset.  :-(
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline dupreezd

  • Forecaster
  • *****
  • Posts: 457
Re: Intermittent loss of web GUI access on RED
« Reply #3 on: September 04, 2018, 08:48:58 AM »
Greg, the only thing I can suggest is to see what is actually being sent to the screen.

While on that screen, turn off Auto Refresh first. Then press F12. At the bottom another screen will open with some code as per the attached screen shot.
Click on the tab with the square and the arrow (1) then highlight Tracker (2). The bottom screen will jump to the line "Tracker"
Now look at the right hand side and see what color the text should be (3)

 [ You are not allowed to view attachments ]
« Last Edit: September 04, 2018, 09:08:38 AM by dupreezd »
WS-1200-IP | ObserverIP | Meteobridge
WU, PWSWeather - KTXCONRO61
CWOP - FW0717
Blitzortung 2100

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #4 on: September 04, 2018, 08:51:53 AM »
'Inspect' in Chrome shows a blank screen with no code at all.
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline dupreezd

  • Forecaster
  • *****
  • Posts: 457
Re: Intermittent loss of web GUI access on RED
« Reply #5 on: September 04, 2018, 08:54:12 AM »
I used FireFox.
WS-1200-IP | ObserverIP | Meteobridge
WU, PWSWeather - KTXCONRO61
CWOP - FW0717
Blitzortung 2100

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #6 on: September 04, 2018, 08:56:55 AM »
Firefox => same thing...

I'm going to reset it now.

And it's back, but for how long I don't know.
« Last Edit: September 04, 2018, 09:00:46 AM by gwwilk »
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline dupreezd

  • Forecaster
  • *****
  • Posts: 457
Re: Intermittent loss of web GUI access on RED
« Reply #7 on: September 04, 2018, 09:05:06 AM »
Does "Inspect Element" display anything now?
WS-1200-IP | ObserverIP | Meteobridge
WU, PWSWeather - KTXCONRO61
CWOP - FW0717
Blitzortung 2100

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #8 on: September 04, 2018, 09:08:24 AM »
Of course since there's now html being sent from RED.

This appears to be a firmware bug which no amount of fiddling on our part will remedy.
« Last Edit: September 04, 2018, 09:10:34 AM by gwwilk »
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3137
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Intermittent loss of web GUI access on RED
« Reply #9 on: September 04, 2018, 09:16:17 AM »
Once the rain lets up, I'll go out to the garage and reset the controller. I am going to revert the code to an earlier level. Maybe I'll try 8.4 since it was stable for a long time.

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #10 on: September 04, 2018, 09:26:20 AM »
Once the rain lets up, I'll go out to the garage and reset the controller. I am going to revert the code to an earlier level. Maybe I'll try 8.4 since it was stable for a long time.

Greg H.
Good idea, Greg.  Reverting to 8.4 now.
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline 92merc

  • BismarckWeather.net
  • Forecaster
  • *****
  • Posts: 671
  • BismarckWeather.net
    • BismarckWeather.net
Re: Intermittent loss of web GUI access on RED
« Reply #11 on: September 04, 2018, 09:45:06 AM »
I've run across the same issue before.  What usually happens is I know there is a storm front near and I'm in interference mode.  I go in and drop the settings down.  If it's not quite enough, I get the same blank-ish screen.

What I've done is just leave it and come back in 10 minutes.  It'll then let me in normally and I can drop the settings some more.  Once I get out of interference mode, then it seems to behave normally again.

I've seen this on V8 and V9.  IIRC, it started back on 7, but not as often.  I've just been living with it.
http://www.BismarckWeather.net
Davis VP2, Cumulus, Blitzortung, Bloomsky, Saratoga Scripts

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3137
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Intermittent loss of web GUI access on RED
« Reply #12 on: September 04, 2018, 10:17:25 AM »
I went out and reset the RED controller. I just reverted it to v8.4. I'll monitor it for a while and see what happens.

Blue is still working, no problem there.

My antenna complement is quite different between RED and Blue. It seems that the RED E-Field is pretty sensitive compared to the Blue unit.

I am leaving the RED settings unchanged from prior to the "flash-back"...

92merc, it could be that we have just had a quieter lightning year coincident with the previous level. Maybe this experiment will tell us something. gwwilk, keep us posted on your results, whether it is any better or not. I don't know what the mean-time-between incidents is, but it has been a daily occurrence lately.

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #13 on: September 04, 2018, 10:55:09 AM »
I just reverted to Firmware Version 9.1 Red in order to see how long the GUI lasts.
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3137
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Intermittent loss of web GUI access on RED
« Reply #14 on: September 05, 2018, 08:26:13 AM »
The GUI access on RED was still OK this morning with v8.4. I am keeping v9.1 on my Blue unit. Only time will tell.

The RED still has the reduced gains and back to manual mode. Also has the 20% "Ignore Signals below Threshold" as described previously.

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #15 on: September 05, 2018, 08:48:39 AM »
This morning my RED 9.1 GUI displayed the data without the menu!  It's starting to fail...



All I could do is exit the window without changing anything or even logging out.

When I closed the browser and tried to log in again, I got the blank screen.  Hopefully this will give the BO coding gurus some helpful information.

Back-leveled firmware to 8.4 just now.
« Last Edit: September 05, 2018, 08:53:15 AM by gwwilk »
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline Cutty Sark Sailor

  • WxElement panel
  • Forecaster
  • *****
  • Posts: 2936
    • Frankfort Weather - TwinHollies WeatherCenter
Re: Intermittent loss of web GUI access on RED
« Reply #16 on: September 05, 2018, 09:19:58 PM »
The controller runs out of memory., and sacrifices GUI first. a system runing auto, close to interference or cycling in and out, and or have unsaved settings, increases memory load... Prefetch, buzzers, displays, etc consume the available memory... etc.. The latest firmware included an assist for that, obviously hasn't solved it.  I've had a few situations with that... one of the first things that helped me on my systems was accessing them in from WAN rather than LAN... go figure...Some of us who run multiple systems, on some browsers, may have a 'cache read' problem, since the files in browser from each system are often same... css, etc... I've suspected that running several systems with very heavy system activity... also note it more frequently when the Wonderful World Wide Web causesslow data transmissions to servers... once the real time 'stroke' display' on the maps hits >6 seconds, and I've got a lot of activity on my controllers, I can almost predict a 'fault' in GUI display... not always, however....
« Last Edit: September 05, 2018, 09:27:30 PM by Cutty Sark Sailor »
 

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3137
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Intermittent loss of web GUI access on RED
« Reply #17 on: September 06, 2018, 08:23:38 AM »
RED with v8.4 is still OK this morning. (lightning activity may have decreased)
Blue with v9.1 is still OK also.
Cutty, I also suspect that excessive activity is part of the problem, hence decreasing gain and increasing thresholds. I also set the "Ignore Signals below Threshold" to 20%.
I am also going to disable the beeps, boops and ticks. Nobody is out there in the garage to hear them normally anyways except when I go to check on things.
The problem did seem to track with the reversion of the firmware, but it is easy to be fooled by these things.
I also have an AS3935 connected, which may not be helping matters either...  :-k

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2007
    • SouthEast Lincoln, NE Weather
Re: Intermittent loss of web GUI access on RED
« Reply #18 on: September 06, 2018, 08:31:07 AM »
So far no problems with my RED on FW 8.4.
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline Cutty Sark Sailor

  • WxElement panel
  • Forecaster
  • *****
  • Posts: 2936
    • Frankfort Weather - TwinHollies WeatherCenter
Re: Intermittent loss of web GUI access on RED
« Reply #19 on: September 06, 2018, 12:23:18 PM »

I also have an AS3935 connected, which may not be helping matters either...  :-k

Greg H.

Yeah... the AS3935 option has been abandoned by BT... and no new support offered... Frankly, I would suspect Tobi will 'eliminate' it from firmware at some point on system RED future updates... it is useless for BT purposes, but interesting... RED and BLUE have much more impulse parameter capabilities than is currently exploited, and I suspect the 'resources' onboard to utilize Red's potential might require dumping the AS3935 firmware section.  Just a thought.
You know, especially in High data situations, if the Server attempts to 'adjust' one of those 'hidden'  controller algorithms, the 'proprietary' controls we really aren't aware of... (we know about the interference modes, and the 'automatic' filters... etc... but there are some 'others',... often used as 'testing' or compression... etc...
when we call GUI...one of the watchdogs barks, and we may simply catch the 'dogs' in between bones... and not get a proper GUI...as the browser attempts to fill from cache, and not new parameters... again as a 'sacrifice' under those conditions....

The GUI really is designed more for 'casual' or short term adjustments and checks...  I know a couple fo operators who are constantly running debug data, etc, and pulling extra stuff out of the controller for scripts, etc.. I wonder how they are faring with these extra 'loads' on the controller resources?????


 

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3137
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Intermittent loss of web GUI access on RED
« Reply #20 on: September 10, 2018, 06:59:36 PM »
Every time I have accessed the RED controller since reverting to v8.4 the GUI come up just fine.

Admittedly, there is a bit of "shotgunning the problem" with multiple actions that I have taken. None of which seemed to help however prior to the FW reversion.

Still no issues on Blue with v9.1 however.

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

 

anything