Author Topic: Error Log Issues  (Read 1760 times)

0 Members and 1 Guest are viewing this topic.

Offline Stryder87

  • Senior Member
  • **
  • Posts: 64
    • Moody Weather
Re: Error Log Issues
« Reply #25 on: August 12, 2018, 11:35:18 PM »
Sigh, Guess I'm getting a bit unmindful in my dotage ..  It's really V1.17 despite what the above attached .zip and comments say about V1.18

Thanks for letting me know that it fixed your Notice errata too.  I'm waiting to hear from Stryder87 about his error_log before I release it generally :)
Alright, I've let it run a couple days.  I deleted my error log when I put the new file in.  I still don't have one, so that would mean there are no errors being generated at all.   \:D/

Thanks a lot, Ken!  I have no idea what I'm doing script-wise (other than mucking around doing small things), so you taking the time to work on this is greatly appreciated!!   =D>

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6880
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Error Log Issues
« Reply #26 on: August 13, 2018, 12:33:34 AM »
Ahhh.. an empty error_log is a happy thing  \:D/

I'm pleased I could be of assistance.

Best regards,
Ken
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline zmarfak

  • Member
  • *
  • Posts: 41
    • Matar
Re: Error Log Issues
« Reply #27 on: August 13, 2018, 04:00:26 AM »
Hi,
installed it also yesterday.
No errors regarding this script so far on PHP 7.2.8
--
Patrick

Davis Vantage Pro2 with a WLIP logger, Intel NUC with WL6.0.4 https://www.matar.be

Offline Stryder87

  • Senior Member
  • **
  • Posts: 64
    • Moody Weather
Re: Error Log Issues
« Reply #28 on: August 20, 2018, 07:10:07 PM »
So I took a look and I have an error log again, but only a couple entries.  Completely new items.

PHP Warning:  Invalid argument supplied for foreach() in .../public_html/get-USNO-sunmoon.php on line 360
Line=     foreach($MoonJSON['sundata'] as $n => $d) {

PHP Warning:  Invalid argument supplied for foreach() in .../public_html/get-USNO-sunmoon.php on line 371
Line=    foreach($MoonJSON['moondata'] as $n => $d) {

It's only happened once since I got the log all cleared up, today at 13:05.  Not sure if it's just a communication problem with another server or not, but since it's never happened before, I'm not sure if it's really a big issue.
 :-k

 

anything