Author Topic: Weatherlink IP not working  (Read 3165 times)

0 Members and 1 Guest are viewing this topic.

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Weatherlink IP not working
« on: April 21, 2018, 06:56:13 PM »
Just noticed since yesterday that I'm no longer connecting to my Weatherlink IP, and even going directly to it via browser, I'm failing to connect.

I'm assuming it has died all of a sudden, for reasons unknown.

Nothing else has died on my local network, so I'm for now assuming it died of 'natural causes'.

This is rather disappointing for it to fail this way, so I'm wondering if anyone else has had their Weatherlink IP fail like this ?
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #1 on: April 21, 2018, 07:43:30 PM »
Interestingly I've pulled the old serial data logger out of my old VP2, done the uninstall/install routine, and it comes up as an incompatible datalogger !!

I've also tried another Weatherlink IP I had accidentally ordered a few years ago, and still can't get my weather data.


Is there a default IP address that these WL IP's come up with? ... I would have thought they'd go DHCP , but nothing is showing up there for me.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline Mattk

  • Forecaster
  • *****
  • Posts: 1420
Re: Weatherlink IP not working
« Reply #2 on: April 21, 2018, 08:00:20 PM »
I would suspect more to do with the network/router than the WLIP at this stage. Do you know how your WLIP is configured on the network, Static or DHCP? Do you have Weatherlink software? If so have you tried to find the logger under the Communications Port>Local Port ID> Find?

Two things you could try first is re-booting your router, if no changes then remove all power from the console, reseat logger then repower

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #3 on: April 21, 2018, 08:16:03 PM »
I would suspect more to do with the network/router than the WLIP at this stage. Do you know how your WLIP is configured on the network, Static or DHCP? Do you have Weatherlink software? If so have you tried to find the logger under the Communications Port>Local Port ID> Find?

Two things you could try first is re-booting your router, if no changes then remove all power from the console, reseat logger then repower

I'm running a static IP to the weatherlink IP, and have also tried to find it using that same method without any luck.

I've power cycled my network switch that it runs through, as well as removing all power from console, removed the logger, even replaced it with another one without any luck. :(
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline Mattk

  • Forecaster
  • *****
  • Posts: 1420
Re: Weatherlink IP not working
« Reply #4 on: April 21, 2018, 08:24:50 PM »
Would you have another console to prove it's not the console?

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #5 on: April 21, 2018, 10:11:51 PM »
Would you have another console to prove it's not the console?

Okay, just tried that.

appears to have killed my old console now.... the display is full of corrupted data. :(

Although after powering it off for a few minutes has rectified it.


Even the main console I have been using, I plugged in a brand new weatherlink IP, and still couldn't see it on my network.


Okay, now I've tried a brand new weatherlink IP in to my old console, and it still can't be seen.... seems like not so much weatherlink ip, but something awfully screwy on my network
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline Mattk

  • Forecaster
  • *****
  • Posts: 1420
Re: Weatherlink IP not working
« Reply #6 on: April 22, 2018, 12:04:42 AM »
Try replacing your Ethernet cables, try different port on router/switch/hub etc.

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #7 on: April 22, 2018, 05:26:03 AM »
Try replacing your Ethernet cables, try different port on router/switch/hub etc.

One of the first things I tried was both changing cables and ports. :(


Just makes no sense it has stopped without any changes being made to my network.

disabled firewall on the machine as well, in case that was it.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline johnd

  • Forecaster
  • *****
  • Posts: 3766
    • www.weatherstations.co.uk
Re: Weatherlink IP not working
« Reply #8 on: April 22, 2018, 05:42:18 AM »
Too late now I know, but I really don't recommend using a static IP address unless unavoidable due to local policies - it often ends up causing tricky problems. Best to stick to DHCP if at all possible.

If you run a network scanner like AngryIP can you see an IP address for your logger?

I assume that you have rebooted your console - again if necessary - that the console is definitely running on mains power, not battery power and that no changes have been made to the private IP address range your router is using?

It may be worth trying to download and run the IP logger firmware update tool from the Davis site. This only has a limited chance of working - if the updater tool can't see the logger then it obviously can't work. But sometimes it does fix this sort of problem.
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Littleport, Ely, Cambs UK

Sorry, but I can't help with individual issues by email. Please post your issue in the relevant forum section here & I will comment there if I have anything useful to add.

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #9 on: April 22, 2018, 09:02:29 AM »
Too late now I know, but I really don't recommend using a static IP address unless unavoidable due to local policies - it often ends up causing tricky problems. Best to stick to DHCP if at all possible.

If you run a network scanner like AngryIP can you see an IP address for your logger?

The IP is showing up as red rather than blue, so it's getting no response.


Quote
I assume that you have rebooted your console - again if necessary - that the console is definitely running on mains power, not battery power and that no changes have been made to the private IP address range your router is using?

Yes, definately running from mains power, not just batteries.

I actually have public address range coming down my link.

I haven't changed anything here though.

Quote
It may be worth trying to download and run the IP logger firmware update tool from the Davis site. This only has a limited chance of working - if the updater tool can't see the logger then it obviously can't work. But sometimes it does fix this sort of problem.

Didn't know there was an update. I'll go look now for it, unless you have a link I could try for it.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline johnd

  • Forecaster
  • *****
  • Posts: 3766
    • www.weatherstations.co.uk
Re: Weatherlink IP not working
« Reply #10 on: April 22, 2018, 09:07:35 AM »
Didn't know there was an update. I'll go look now for it, unless you have a link I could try for it.

The update itself is probably of no consequence, unless your logger is quite old. But reflashing is just one way of clearing any possible corruption in the logger that may have occurred. I'm not very optimistic that it will work because the update utility obviously needs to be able to talk to the logger across the network, but always worth a try. Other thoughts:

Do you definitely get the right number of beeps at reboot? (3 for a regular VP2 console, but maybe you have a Vue or Envoy?)

If still no luck can you take the unit eg to a friend's house with a different network and see if that helps at all?
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Littleport, Ely, Cambs UK

Sorry, but I can't help with individual issues by email. Please post your issue in the relevant forum section here & I will comment there if I have anything useful to add.

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #11 on: April 22, 2018, 09:34:29 AM »
update couldn't find it.....  got the 3 beeps with a pause between them for my vp2 console.

Don't have a crossover cable, but I'm sure I could find a switch/hub and a laptop tomorrow to try something similar to see if that makes a difference.

So frustrating that it suddenly happened.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline Mattk

  • Forecaster
  • *****
  • Posts: 1420
Re: Weatherlink IP not working
« Reply #12 on: April 22, 2018, 04:22:29 PM »
And just to clarify, you have added/connected absolutely nothing to this network?

Offline waiukuweather

  • Forecaster
  • *****
  • Posts: 908
Re: Weatherlink IP not working
« Reply #13 on: April 22, 2018, 04:34:53 PM »
what about resetting the router

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #14 on: April 22, 2018, 08:12:09 PM »
And just to clarify, you have added/connected absolutely nothing to this network?

nothing new ... have rebooted router too, but no change.

Might be time to disconnect stuff one by one to see if something else is hammering it.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline waiukuweather

  • Forecaster
  • *****
  • Posts: 908
Re: Weatherlink IP not working
« Reply #15 on: April 22, 2018, 08:52:10 PM »
I have had an IP data logger die on me before

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #16 on: April 22, 2018, 10:08:12 PM »
Latest news is that I can ping it on my network, but can not access it.

The activity led is happily flashing away on it.

I've put in my spare WL IP (I accidentally ordered it when I ordered the 6163 station several years ago), and it is now running on my vp2.

The older WL IP is now in my older VP2, with the activity led flashing away, but not pingable, let alone accessible

I've flashed it to 1.12 firmware, from a laptop that was not on my network.

Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline Aardvark

  • Forecaster
  • *****
  • Posts: 2145
Re: Weatherlink IP not working
« Reply #17 on: April 23, 2018, 12:34:49 AM »
« Last Edit: April 23, 2018, 12:38:11 AM by Aardvark »
Davis VP2 Plus; 24h  FARS; Extra Temp Humid sensor (2); Extra Temp Station (2); Soil Moisture/Temp  https://www.weatherlink.com/embeddablePage/show/1c484adbfa914d1aa10a58ad53ccd563/summary;Weatherlink IP;USB; MAC Catalina
; Webcam;

Offline Mattk

  • Forecaster
  • *****
  • Posts: 1420
Re: Weatherlink IP not working
« Reply #18 on: April 23, 2018, 01:12:36 AM »
OK then where did FW 113 come from, has that been released yet or is this a very new WLIP?

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6407
    • Lee's Summit, MO
Re: Weatherlink IP not working
« Reply #19 on: April 23, 2018, 10:31:36 AM »
What operating system(s) and version(s) are your computers using? 

Was there an update just prior to noticing the problem?

(For instance - there was/is a problem with the latest Windows 7 update, that affected networks.

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #20 on: April 23, 2018, 11:30:47 PM »
What operating system(s) and version(s) are your computers using? 

Was there an update just prior to noticing the problem?

(For instance - there was/is a problem with the latest Windows 7 update, that affected networks.

Windows 7 here.... initially could only access a new one on winxp, then later could do it on Win7.

However that original WLIP is still not accessible, although it was for a while visible to the updater software, but not from anything else.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6407
    • Lee's Summit, MO
Re: Weatherlink IP not working
« Reply #21 on: April 23, 2018, 11:50:02 PM »
I'm guessing that the "nothing" that changed, was one or more Windows 7 updates.

What are the static IP addresses of the WLIPs?  And what are the IP addresses of the Windows XP and the Windows 7 computers?

Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #22 on: April 24, 2018, 08:34:23 AM »
I'm guessing that the "nothing" that changed, was one or more Windows 7 updates.

What are the static IP addresses of the WLIPs?  And what are the IP addresses of the Windows XP and the Windows 7 computers?

They are all on the same network, and are all publically addressable IP's too... gateway is .129 , WLIP's are .136 and .169 , the Win 7 box is .133

The WinXP box was disconnected from the rest of the network, and connected to the WLIP by switch that wasn't connected up to the rest of the network, just the WLIP's.

The WLIP that I was having the issues was then visible to WL updater, but not otherwise visible.


In response to Aardvark's
IF you put in the IP address of your IP logger do you get this ,  but for your logger. here is my  IP logger that goes to my WL2.0

Not with the original WLIP which started this all off, however with my other WLIP, it does.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline weatheroz

  • Senior Contributor
  • ****
  • Posts: 180
    • http://www.jimboombaweather.com
Re: Weatherlink IP not working
« Reply #23 on: April 24, 2018, 09:07:26 PM »
wake up today, and WLIP is not connecting.... this is the new one I put in the other day.

using a browser to the IP that it is on, won't bring up the configuration page anymore.

Can ping it fine from this computer.


I can't afford to buy another WLIP as they are just short of $400 each to buy over here.


This is really doing my head in, I've contacted Davis themselves via email, but have yet to get an email response back from them since this problem first started.
Brendan,
vk4blp
IRLP 6857 Echolink 672767


Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6407
    • Lee's Summit, MO
Re: Weatherlink IP not working
« Reply #24 on: April 24, 2018, 10:20:43 PM »
wake up today, and WLIP is not connecting.... this is the new one I put in the other day.

And I see it's back in operation.

 (The Jimboomba box image in your signature seems to be present if it's working, and absent if it isn't).  Do you suppose that might be a clue?  I don't know, of course.

The problem is with your network and/or the NIC card settings on your computer.  Davis can't help.  We can't help with the limited information available.  It has been suggested that you get rid of the static IP settings on the WLIPs.  That might or might not help. 
« Last Edit: April 24, 2018, 10:29:53 PM by dalecoy »