Author Topic: Stuck on "Accessing Data"  (Read 3421 times)

0 Members and 1 Guest are viewing this topic.

Offline robbieB

  • Member
  • *
  • Posts: 23
    • Royal Norfolk & Suffolk Yacht Club, Lowestoft, UK
Stuck on "Accessing Data"
« on: March 06, 2009, 03:49:24 PM »
First, my thanks to everyone who shares their know-how on WxForum; some of us wouldn't manage without your help.

I'm migrating my weather site from a domain hosted on a Microsoft server to a different domain hosted on a Linux server. I have a new key from Meteorologica, and have uploaded all the files, including the special files for PHP5 [the server runs PHP version 5.2.8]. I have checked that all the file names are correct, and I've substituted php for asp in the site.txt file. When I browse to the index file I get the Loading message followed by "Accessing Data ......", but that's it. My custom page does not load; the little Lock icon continues to say "Loading ...." and I can't open the configuration screen. I am using the "FTP to remote server" option, and the wflash.txt and wflash2.txt files are uploading OK; I've also tried the "PHP on remote server" option, but the result is the same -- sticks at "Accesssing Data......"

I guess I've missed something, but I can't think what.  #-o



Davis Vantage Pro 2 Wireless (2006)
Davis Weather Envoy
VWS v14
Weatherlink v5.5.1
Weatherflash v1.2
Stardot Netcam MP
Windows XP Home SP2

Offline WeatherBeacon

  • Chief
  • Forecaster
  • *****
  • Posts: 1369
    • http://www.wxbeacon.com
Re: Stuck on "Accessing Data"
« Reply #1 on: March 06, 2009, 04:16:20 PM »

Try setting all permissions (all WeatherFlash files and folders) to 777.
Mae govannen!
Kevin  (Member AMS) http://www.wxbeacon.com               Genesee County, Michigan
Hardware:  Davis Vantage Pro Wireless, Midland WR-300
Software: VWS 14.01p43, WeatherFlash, & GRLevel3

Offline Meteorologica

  • Contributor
  • ***
  • Posts: 106
Re: Stuck on "Accessing Data"
« Reply #2 on: March 07, 2009, 02:12:19 AM »
This is nothing to do with permissions it is simply that your mail client has added a hidden carriage return or linefeed character to the end of the data string in the key file. Use notepad to remove anything hidden at the end of the string and it should work okay.

You should NOT use the ftp to remote server option as its too slow.

Offline robbieB

  • Member
  • *
  • Posts: 23
    • Royal Norfolk & Suffolk Yacht Club, Lowestoft, UK
Re: Stuck on "Accessing Data"
« Reply #3 on: March 07, 2009, 03:31:05 AM »
Thanks for the response guys. I've checked the key.txt file and it's clean, no carriage returns or anything. The permissions are 0755 on folders and 0644 on files. I've switched to the "PHP on remote server" option and double checked the location of the renamed submit.php file. Still stuck at "Accesssing Data ....."

Update: Started again from scratch. Uploaded the latest Evaluation version and have the initial grey page loaded. Uploading the new key.txt file has removed the "Unlicensed" overlay, so no problem there. Will be doing the rest of the set up later today. Thanks again for the help.
« Last Edit: March 07, 2009, 04:49:06 AM by robbieB »
Davis Vantage Pro 2 Wireless (2006)
Davis Weather Envoy
VWS v14
Weatherlink v5.5.1
Weatherflash v1.2
Stardot Netcam MP
Windows XP Home SP2

Offline robbieB

  • Member
  • *
  • Posts: 23
    • Royal Norfolk & Suffolk Yacht Club, Lowestoft, UK
Re: Stuck on "Accessing Data"
« Reply #4 on: March 08, 2009, 04:45:10 AM »
Must have tweaked something that needed tweaking, don't know what, but the original install which was sticking at "Accessing Data ....." is now AOK. Sod must have dozed off!
Davis Vantage Pro 2 Wireless (2006)
Davis Weather Envoy
VWS v14
Weatherlink v5.5.1
Weatherflash v1.2
Stardot Netcam MP
Windows XP Home SP2

 

anything