Author Topic: USPLN Sensor Request  (Read 37276 times)

0 Members and 1 Guest are viewing this topic.

Offline hankster

  • Forecaster
  • *****
  • Posts: 481
    • NFM Weather
Re: USPLN Sensor Request
« Reply #250 on: April 07, 2020, 09:22:26 AM »
Yes. They have contacted me a couple times when the system was off line. Once my WiFi access point didn't reconnect after a power outage and once when the electric was off to my shed where the sensor is located due to work being done to the shed. Wish everything worked as smoothly as this does.

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3889
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: USPLN Sensor Request
« Reply #251 on: April 07, 2020, 10:44:57 AM »
I just logged into the Raspberry Pi with the USB connection to the controller. It reports everything OK and connected to Servers 1 & 2. Server 3 is disconnected.

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline WeatherHost

  • Forecaster
  • *****
  • Posts: 3592
Re: USPLN Sensor Request
« Reply #252 on: June 09, 2022, 07:10:29 PM »
Mine apparently croaked for unknown reasons.

Got an email a few days ago saying they weren't getting sufficient data.  They did some testing somehow and figured the sensor was bad, so they're sending a new one.

I was thinking of saying no, begging off the system and returning it all, but it isn't really costing me anything.


Offline DaleReid

  • Forecaster
  • *****
  • Posts: 1854
    • Weather at Eau Claire, WI
Re: USPLN Sensor Request
« Reply #253 on: June 09, 2022, 09:07:08 PM »
This is interesting,  A couple days ago I got an email saying my system was having a high noise level.  Please check things.  Make sure that the ground from the TOA box was to the outlet that it was plugged into and it was the ONLY thing plugged into that outlet.  Seems strange, but I fiddled, made sure that no motors were running, that the fluorescent and LED lights were off, etc.  I remade the ground, swapped out a UPS and then got a message that things were better, or at least I thought.  They wanted me to clean the terminal connections at the probe antenna (up on a roof where my hip health won't let me safely go any more) and also wanted a picture of the antenna.  Since I cannot get up there any more, I took one from the ground with a telephoto lens.

I just got a message back that it was the trees causing the problem. Trees?  They didn't just grow up suddenly and this thing as been A-OK since it was put up, the trees neither came out of nowhere nor does this acknowledge the fact that it was working flawlessly for years.

I haven't replied yet, but since they wanted me to move it and I have absolutely no other place to put it, will reply after I cool off a bit (their explanation sure doesn't pass critical thinking, nor scientific fact).

If they want it back I'll put the box and power dongle in a USPS and send it back but there is no way in hell lI can get the antenna off the roof.  I'll declare it abandoned in place and tell them to send a technician by to pick it up.

I know noise is a real son of a gun to engineer out but I cannot see how having anything else plugged into the same circuit as the TOA box is on can send noise via the wires back through a properly designed power supply or unit.

I'm happy to provide the power, the site, the internet and be part of their fee-charging network for the access I get but if they get pissy about it, I'm not sure I'll be a happy participant. 
ECWx.info
&
ECWx.info/t/index.php

Offline DaleReid

  • Forecaster
  • *****
  • Posts: 1854
    • Weather at Eau Claire, WI
Re: USPLN Sensor Request
« Reply #254 on: June 09, 2022, 09:12:19 PM »
Greg,
with the output you look at with the Pi, I see there is a sort of yes or no response out of the box about noise.  But there really isn't a display of the signal or the type of noise.

Have  you ever had the box tell you that there was a higher noise level or always been Noise: No?
Dale
ECWx.info
&
ECWx.info/t/index.php

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3889
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: USPLN Sensor Request
« Reply #255 on: June 10, 2022, 08:25:26 AM »
I don't usually log into the Pi to check that (it is always running an AIS script though), As of now, the STROKES NOISY status is "No". I don't recall a confirmed "noisy" status, but I might have missed it. The bigger issue is how frequently I check. Here is a current status dump:

status
[appLog.c:1434] CONFIG VALID   Yes - config was valid at startup
[appLog.c:1439] GPS LOCK       Yes
[appLog.c:1444] SERVER CONNECT Yes
[appLog.c:1451] FPGA LOADED    Yes
[appLog.c:1456] STROKES NOISY  No Cnt 0 (MAX STROKES/SEC 25)
[appLog.c:1464] NOISE DETECT: NOISY=DISABLE AFTER 3 SECS; QUIET=ENABLE AFTER 10 SECS


Greg H.


Greg,
with the output you look at with the Pi, I see there is a sort of yes or no response out of the box about noise.  But there really isn't a display of the signal or the type of noise.

Have  you ever had the box tell you that there was a higher noise level or always been Noise: No?
Dale


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3889
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: USPLN Sensor Request
« Reply #256 on: June 24, 2022, 08:47:33 AM »
Strangely enough, I recently received an email from TOA Systems claiming that my system was "deaf" and to check the antenna and send photos of the installation. (Unchanged since initial installation several years ago)

They suspect the antenna. I offered and subsequently measured SWR and coax loss using my MFJ-259C antenna analyzer.

SWR was under 1.8 at 165.41 MHz or so and the coax loss was 0.6 dB at or below 15 MHz. I also connected a HT and listened to the local VHF Wx at the local airport. (KPZQ 118.125 MHz). It came in fine.

With this I concluded that the antenna is OK, but they still insist that it't the antenna. I have my doubts based on my testing.

I agreed to "lash up" the antenna that they send for a test. I also no longer should go up on the roof to change antennas. The wife says not to and I agree, my balance isn't what it was when I installed this system.

I'm going to compare the strokes count (via Raspberry Pi minicom at the TOA USB connection) once this antenna arrives. I also have a mag mount 2 meter that I could easily plop on the roof of the Ford Flex which is right next to the lightning detector cabinet (TOA and Blitzortung controllers live there).

I'll give them the benefit of the doubt and rig up the replacement antenna temporarily, but if they want it changed out, they will need to pay for me hiring a tech to replace it.

I'll post additional info as I go through this testing.

Greg H.



Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3889
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: USPLN Sensor Request
« Reply #257 on: June 24, 2022, 09:35:34 AM »
Strangely enough, I recently received an email from TOA Systems claiming that my system was "deaf" and to check the antenna and send photos of the installation. (Unchanged since initial installation several years ago)

They suspect the antenna. I offered and subsequently measured SWR and coax loss using my MFJ-259C antenna analyzer.

SWR was under 1.8 at 165.41 MHz or so and the coax loss was 0.6 dB at or below 15 MHz. I also connected a HT and listened to the local VHF Wx at the local airport. (KPZQ 118.125 MHz). It came in fine.

With this I concluded that the antenna is OK, but they still insist that it't the antenna. I have my doubts based on my testing.

I agreed to "lash up" the antenna that they send for a test. I also no longer should go up on the roof to change antennas. The wife says not to and I agree, my balance isn't what it was when I installed this system.

I'm going to compare the strokes count (via Raspberry Pi minicom at the TOA USB connection) once this antenna arrives. I also have a mag mount 2 meter that I could easily plop on the roof of the Ford Flex which is right next to the lightning detector cabinet (TOA and Blitzortung controllers live there).

I'll give them the benefit of the doubt and rig up the replacement antenna temporarily, but if they want it changed out, they will need to pay for me hiring a tech to replace it.

I'll post additional info as I go through this testing.

Greg H.

I stand corrected. I put a 2 meter mag mount on the roof of my Flex parked next to the 'lightning cabinet'. I am now getting incrementing strokes. I saw some lightning across the lake between here an Manitoulin Island this morning and thought that the TOA should be able to sense the strikes.

Sure enough it is working now.

Before, it was stuck at 3924,
========================================================
strokes
[appLog.c:1659] CHAN C ENABLED 0: COUNT 1, OFFSET -1668, LP 1
[appLog.c:1664] CHAN C THRESH: POS 32767, NEG -32767
[appLog.c:1666] CHAN D ENABLED 1: COUNT 3924, OFFSET -1668, LP 1
[appLog.c:1671] CHAN D THRESH: POS 2617, NEG -2618
========================================================

With the mag mount on the Flex roof:

[appLog.c:1659] CHAN C ENABLED 0: COUNT 3, OFFSET -1668, LP 1
[appLog.c:1664] CHAN C THRESH: POS 32767, NEG -32767
[appLog.c:1666] CHAN D ENABLED 1: COUNT 30421, OFFSET -1668, LP 1
[appLog.c:1671] CHAN D THRESH: POS 2617, NEG -2618

[appLog.c:1659] CHAN C ENABLED 0: COUNT 3, OFFSET -1668, LP 1
[appLog.c:1664] CHAN C THRESH: POS 32767, NEG -32767
[appLog.c:1666] CHAN D ENABLED 1: COUNT 30454, OFFSET -1668, LP 1
[appLog.c:1671] CHAN D THRESH: POS 2617, NEG -2618

and the latest:
[appLog.c:1659] CHAN C ENABLED 0: COUNT 5, OFFSET -1668, LP 1
[appLog.c:1664] CHAN C THRESH: POS 32767, NEG -32767
[appLog.c:1666] CHAN D ENABLED 1: COUNT 35938, OFFSET -1668, LP 1
[appLog.c:1671] CHAN D THRESH: POS 2617, NEG -2618

Greg H


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

Offline DaleReid

  • Forecaster
  • *****
  • Posts: 1854
    • Weather at Eau Claire, WI
Re: USPLN Sensor Request
« Reply #258 on: June 24, 2022, 10:23:21 AM »
Greg,
When I put my system in years ago, I recall you mentioning you could use a Rasp Pi to monitor it since the TOA company didn't have any user friendly software to do that.  Not even knowing what a Pi was, I didn't followup what you did

I now have a few of them around running WeeWx software and an older one (a three?) that I might use to at least see what is going on with my unit.  Your ability to see data allowed you to fiddle with it more.

Was there a thread or something you put together on what you did?  I think you said you used a USB to USB connection and monitored that USBtt0 or such to see what was coming out of it.

Also, did you just leave the two meter antenna connected?  I have a bunch of old mag mount two meter antennas I could swap out with the bigger probe on my shed roof to see if they will notice a difference.  I assume that the antenna in the probe is an e-field probe, like the type that Blitz uses?  Or is it a tuned system?

I can't figure what might have gone wrong with an antenna short of a strike, and we'd both know if that had happened.  It is inside the PVC pipe, and the BNC type connectors should be good, one would think..

If you do have someone pull the old antenna, I'm sure you'll give it a very close inspection, both visually and electronically, to see what might be afoul there. 

Dale
ECWx.info
&
ECWx.info/t/index.php

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3889
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: USPLN Sensor Request
« Reply #259 on: June 24, 2022, 11:11:00 AM »
Greg,
When I put my system in years ago, I recall you mentioning you could use a Rasp Pi to monitor it since the TOA company didn't have any user friendly software to do that.  Not even knowing what a Pi was, I didn't followup what you did

I now have a few of them around running WeeWx software and an older one (a three?) that I might use to at least see what is going on with my unit.  Your ability to see data allowed you to fiddle with it more.

Was there a thread or something you put together on what you did?  I think you said you used a USB to USB connection and monitored that USBtt0 or such to see what was coming out of it.

Also, did you just leave the two meter antenna connected?  I have a bunch of old mag mount two meter antennas I could swap out with the bigger probe on my shed roof to see if they will notice a difference.  I assume that the antenna in the probe is an e-field probe, like the type that Blitz uses?  Or is it a tuned system?

I can't figure what might have gone wrong with an antenna short of a strike, and we'd both know if that had happened.  It is inside the PVC pipe, and the BNC type connectors should be good, one would think..

If you do have someone pull the old antenna, I'm sure you'll give it a very close inspection, both visually and electronically, to see what might be afoul there. 

Dale

There is a lot of swaying in the wind for their PVC antenna. It really gets going in strong winds, so I wouldn't be surprised if the cable broke internally from the action. If it ever comes down, I'll do an autopsy on it.

Nothing fancy on the Raspberry Pi, I just have the USB connected between the Pi and the TOA and use "minicom". It is an ancient terminal program but it works well. The script that I use uses this command:

Code: [Select]
minicom -b 115200 -o -D /dev/ttyUSB0

I made a short script that contains this line and is called TOA-USB.sh
Here is a screen grab of the pi prompt and a "cat" command do show the script contents. You could do something similar.

Quote
pi@raspberrypi ~ $ cat TOA-USB.sh
minicom -b 115200 -o -D /dev/ttyUSB0

Greg H.



Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF