Author Topic: Console loses communication with software  (Read 2280 times)

0 Members and 1 Guest are viewing this topic.

Offline johnnygeneric

  • Member
  • *
  • Posts: 1
Console loses communication with software
« on: August 05, 2012, 12:09:12 AM »
Hi guys.  I just joined this group today.  Originally, I was going to post a problem that I had with the console, but in the meantime I found a solution and thought I would share this rather odd tale.

I was having an issue with my WS-2080 console losing it's connection with the Cumulus software.  I would unplug the console, stop the program, plug the USB back in and restart the Cumulus software.  There wasn't any rhyme or reason for this. 

I decided that I was loading down all my USB ports and maybe the problem was caused by a power drain.  So I got on ebay and ordered a USB PCIe card.  It was actually a USB 3.0.  OK.  So what. Right? It came, I installed it and I was up and running with no problems.  But then disaster struck.  The USB card stopped working, screwed up my computer.  I removed the card and took the computer back several restore points.

That's when odd things started to happen. Whenever I plugged the console into the USB and ran the Cumulus (or Easyweather software, it didn't matter) the console would lose the weather station transmission signal (blanks on the console for temp, wind, etc). I spent hours trying to nail down the cause.  Whatever the new USB card did when it quit working, it did something to the console such that the software would no longer play nice with it.  I would have the console plugged into the USB port with no problems for 10 fifteen minutes.  But within 4 or 5 minutes of booting up the software, the console would lose the signal to the weather station.

I recalled that some software for one reason or another would sometimes not follow USB protocol like it should.  This is all beyond me but I had this problem with plugging a USB hard drive into an Apple Airport Extreme USB port.  I discovered at the time that if I put a USB hub between the hard drive and the Airport Extreme, the problem would go away and the hard drive worked.

I had a USB hub and tried it out.  No luck. Then I tried an odd USB hub called a Sima SUO-200M.  Bingo!  It worked.  And  mean it is working like nothing else ever has.  At first it was common to lose the connection between the software and the console. This would happen on a frequent basis.  I may be a little premature in saying this, but for the past eight hours, not one lost connection between the console and the software.

Or...maybe it was just a lose USB connection.  Or flare or sunspot activity.