Author Topic: communication errors  (Read 6583 times)

0 Members and 1 Guest are viewing this topic.

Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
communication errors
« on: December 21, 2011, 02:47:26 PM »
I'm having an issue between my 2 month old Davis Vantage Vue weather station and Weatherlink IP.  Slowly seems to be happening more frequently.  I have it uploading to my computer and website every 15mins.  But sometimes it will go for an hour or so unable to upload.  When I check the log for the day it seems to say something like: unable to retrieve data from station.  Communication error.  Then for some reason it will work again later on. I'm at work now and checked my website and last update was at 7:47am.  What is happening or what can I do?  WU is getting info every 15 mins still and working fine according to WU log  http://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=KCARIVER23

Stumped  :?:

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6413
    • Lee's Summit, MO
Re: communication errors
« Reply #1 on: December 21, 2011, 03:15:33 PM »
What weather software are you using to "uploading to my computer and website"?    What version?

What is sending data to WU?

What is your website?
« Last Edit: December 21, 2011, 03:31:04 PM by dalecoy »

Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
Re: communication errors
« Reply #2 on: December 21, 2011, 03:56:06 PM »
6555 WeatherLinkIP -SKU: 6555-D

http://patioworldonline.com/weather.php

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6413
    • Lee's Summit, MO
Re: communication errors
« Reply #3 on: December 21, 2011, 03:59:40 PM »
I asked:

What weather software are you using to "uploading to my computer and website"?    What version?

What is sending data to WU?


While I'm asking, also, what version of firmware is the WLIP?

Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
Re: communication errors
« Reply #4 on: December 21, 2011, 04:04:00 PM »
My bad.  At work.  will check.

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6413
    • Lee's Summit, MO
Re: communication errors
« Reply #5 on: December 21, 2011, 04:10:25 PM »
It looks like you are using multiple weather programs? 

Your patio world website seems to be using WeatherLink software, and hasn't updated since 7:47 AM.

But something is doing Weather Underground Rapid Fire continually (right now).  And that something certainly isn't WeatherLink.com.

http://www.wunderground.com/swf/Rapid_Fire.swf?units=english&station=KCARIVER23

Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
Re: communication errors
« Reply #6 on: December 21, 2011, 04:19:31 PM »
That is the only software I purchased/got.

I have a feeling it is something to do with my computer.  The data logger is hooked directly to my router from the console.  WU is able to get that and bypass my computer.  But my computer is not receiving the data and uploading to the server for my website. 

We will see what's up when I get home.
« Last Edit: December 21, 2011, 04:35:10 PM by Wayne_R »

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6413
    • Lee's Summit, MO
Re: communication errors
« Reply #7 on: December 21, 2011, 04:58:00 PM »
I think you have a misunderstanding about what parts are doing what things. 

But it appears that WeatherLink (through the add-on module that you installed) is sending rapid fire data to WeatherUnderground, even though it is not getting current data from your logger.  That data is clearly incorrect.

I would ask what version of the Weather Underground module you are using, and whether WU says it's compatible in rapid fire mode with WLIP, but that's probably overkill.

Your WeatherLink.com data is correct, though.  http://www.weatherlink.com/user/bamboleo/

I suggest you completely turn off the WeatherUnderground uploads from WeatherLink.  Then restart WeatherLink and see how things work.  If you have current versions of software and firmware, properly set up, that should work OK.


Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
Re: communication errors
« Reply #8 on: December 21, 2011, 05:14:49 PM »
Thank you.  I am definitely a newbie. (but hopefully learning a little at a time).

Offline JACK10562

  • Forecaster
  • *****
  • Posts: 433
  • DW5051
    • DW5051 East Harwich MA
Re: communication errors
« Reply #9 on: December 21, 2011, 07:21:38 PM »
That Weather Underground "Rapid fire" sticker linked above is not updated for this station every two seconds, as one would (mistakenly) be lead to believe. It just LOOKS like it. That particular link does this for all stations, but the information doesn't update until the regular upload.

Looking on your WU station page the Weather Station Software shown is weatherlink.com 1.10, indicating Davis is forwarding your data to them every 15 minutes, which is default.

For some reason your Patio.com site is not being updated. that is coming from your computer?  Maybe Weatherlink crashed on your computer.

CWOP:DW5051
MADIS ID:D5051
WU:KMAEASTH4
CoCoRaHS:MA-BA-23
DavisVantagePro2Plus#6163
Cumulus 1.9.4(1097)←☼

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6413
    • Lee's Summit, MO
Re: communication errors
« Reply #10 on: December 22, 2011, 12:15:34 AM »
That Weather Underground "Rapid fire" sticker linked above is not updated for this station every two seconds, as one would (mistakenly) be lead to believe. It just LOOKS like it. That particular link does this for all stations, but the information doesn't update until the regular upload.

Oh.  I didn't know that.  I would call that unreasonable behavior on the part of Weather Underground.  Sorry I misled.

I now see that if I look at http://www.wunderground.com/swf/Rapid_Fire.swf?units=english&station=KMOLEESS9 it says I'm doing rapid fire, and I certainly know that I am not.

Thanks for the information (I think).   :-)
« Last Edit: December 22, 2011, 12:19:01 AM by dalecoy »

Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
Re: communication errors
« Reply #11 on: December 22, 2011, 12:34:14 AM »
Old computer.

I just adjusted to update every 1 minute.  Now working.  I think my oldie gots some bugs or something in it.  We'll see what happens in next few days.  If it persists, time to start all over again with new computer, yes (when funds come available  :roll:)

Offline Aardvark

  • Forecaster
  • *****
  • Posts: 2146
Re: communication errors
« Reply #12 on: December 22, 2011, 09:47:09 AM »
sometimes, if something is sharing the same port, it won't release it so that the data goes.   IF you have weatherlink, the software running at the same time you have the IP sending data, the weatherlink will prevent the data from leaving.  It is a flaw in the software.

IF you have your station sending IP data and you have it set to Local Device ID, or Remote IP Address, then the software prevents the data from going to the internet because it is polling the station.   APRS and Weather Underground like 15 min updates, unless you are using WU rapid updater.  That is some thing you can download into weatherlink, a module , free no less, that sends the 1 min updates to WU and keeps APRS happy as well.  I'd have the Web download if you must have the two running at the same time.



Davis VP2 Plus; 24h  FARS; Extra Temp Humid sensor (2); Extra Temp Station (2); Soil Moisture/Temp  https://www.weatherlink.com/embeddablePage/show/1c484adbfa914d1aa10a58ad53ccd563/summary;Weatherlink IP;USB; MAC Catalina
; Webcam;

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6413
    • Lee's Summit, MO
Re: communication errors
« Reply #13 on: December 22, 2011, 09:54:05 AM »
OK, you're using WeatherLink software.

I asked:

...   What version?


While I'm asking, also, what version of firmware is the WLIP?

Offline JACK10562

  • Forecaster
  • *****
  • Posts: 433
  • DW5051
    • DW5051 East Harwich MA
Re: communication errors
« Reply #14 on: December 22, 2011, 10:31:46 AM »
If you continue to have unexplained data communication issues while using WeatherLink IP, you might want to consider swapping your datalogger for an USB or SERIAL version, provided you also decide to leave your computer on 24/7. Myself and others here have seen intermittent data communications troubles on WL IP and I for one, had them solved by switching dataloggers.
Another unintended benefit I find is my various weather software "feels" snappier and more responsive while communicating directly with the console on a COM port vs over my LAN, using TCP/IP.
CWOP:DW5051
MADIS ID:D5051
WU:KMAEASTH4
CoCoRaHS:MA-BA-23
DavisVantagePro2Plus#6163
Cumulus 1.9.4(1097)←☼

Offline Aardvark

  • Forecaster
  • *****
  • Posts: 2146
Re: communication errors
« Reply #15 on: December 22, 2011, 11:11:43 AM »
If you continue to have unexplained data communication issues while using WeatherLink IP, you might want to consider swapping your datalogger for an USB or SERIAL version, provided you also decide to leave your computer on 24/7. Myself and others here have seen intermittent data communications troubles on WL IP and I for one, had them solved by switching dataloggers.
Another unintended benefit I find is my various weather software "feels" snappier and more responsive while communicating directly with the console on a COM port vs over my LAN, using TCP/IP.
Depends on his computer.. the IP goes directly to the modem.  IT might be his logger.  I had one go bad like that and I had another logger for some reason and swapped it out.   New computers do not necessarily have the empty PCI slots for the time proved serial version, and the USB drivers are iffy and old at best.

I have a vista 64 bit and wanted to go serial , swap out my aging xp system as a backup and do some other things.   Anyway,  I ordered a serial board for about 9 bucks and when I opened the case,  no pci port.   It had one and that was for a video card.   So I ordered the serial to USB connector and the driver was bad, so I did track down the manufacturer and I think it will work.

However,  considering the  expense of the datalogger,  I  would not run weatherlink at the same time the IP logger is working.  IF that doesn't stop the problem, then... it is really time to call Davis directly, explain what has been done and maybe they might switch out his logger.  He will also need to get Davis to switch over his sent data on the old one to his new address.

I really think it is his weatherlink software running at the same time.  IF it is the logger, he needs to have Davis honor the agreement and send him a new one in exchange for the crappy one.

I have a IP one right now.  It goes directly into one of the ethernet ports on my modem, not through a router or switch, and I am not having any problems. However, if I have WL running, then yes, the data isn't uploaded.

One other thing...  if for some reason you lose power to your modem, the IP address changes that your IP logger uses, so if you are trying to find it with Wlink, you need to find what the new address is.  It shouldn't make any difference with the Davis site end , but with your home system, yup.
« Last Edit: December 22, 2011, 11:14:36 AM by Aardvark »
Davis VP2 Plus; 24h  FARS; Extra Temp Humid sensor (2); Extra Temp Station (2); Soil Moisture/Temp  https://www.weatherlink.com/embeddablePage/show/1c484adbfa914d1aa10a58ad53ccd563/summary;Weatherlink IP;USB; MAC Catalina
; Webcam;

Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
Re: communication errors
« Reply #16 on: December 22, 2011, 11:34:41 AM »


Weird.  HP Computer is on 24/7 for WL.  I fired up my IPAD and did some browsing about the same time stopped retrieving info from station.  Switched to 1 minute retrieval and no dice.  Got on my HP and fooling around online and poof, starts working again 10 minutes or so later for no reason?

Offline Aardvark

  • Forecaster
  • *****
  • Posts: 2146
Re: communication errors
« Reply #17 on: December 22, 2011, 12:36:16 PM »
ok.. I set up my WL to read from the station   this is what the log looks like reading the data directly from the station, using my IP Logger and WL5.9.3
 12/22/11 11:18a (Toubes) Unable to upload Data Upload Profile(s) 1 2 4  because of errors. See error messages below.
 12/22/11 11:18a (Toubes) Error reading data from the Station.
 12/22/11 11:18a (Toubes) Function to retrieve data through TCP/IP protocol from the device timed out.
 12/22/11 11:18a (Toubes) Function to retrieve data through TCP/IP protocol from the device timed out.
 12/22/11 11:14a (Toubes) Upload of Data Upload Profile(s) 1 2 5  partially completed. See error messages below.
 12/22/11 11:14a (FTP) Error (3) uploading file "Davis Logo.jpg" to location "public_html\vantageprodata\".
 12/22/11 11:14a Error (3) uploading file "Davis Logo.jpg" to location "public_html\vantageprodata\". WeatherLink will reset the FTP connection and try again.
 12/22/11 11:14a (Toubes) Error creating EMC image. Check Sensors.
 12/22/11 11:14a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\Weather_Summary_Vantage_Pro_Plus.htx
 12/22/11 11:14a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\phase.htx
 12/22/11 11:14a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\data.htx
 12/22/11 11:13a (Toubes) No new data to download.

Now this is what it looks like when reading via download

 12/22/11 11:24a (Toubes) Upload of Data Upload Profile(s) 1 2 5  partially completed. See error messages below.
 12/22/11 11:24a (FTP) Error (3) uploading file "Davis Logo.jpg" to location "public_html\vantageprodata\".
 12/22/11 11:24a Error (3) uploading file "Davis Logo.jpg" to location "public_html\vantageprodata\". WeatherLink will reset the FTP connection and try again.
 12/22/11 11:23a (Toubes) Error creating EMC image. Check Sensors.
 12/22/11 11:23a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\Weather_Summary_Vantage_Pro_Plus.htx
 12/22/11 11:23a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\phase.htx
 12/22/11 11:23a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\data.htx
 12/22/11 11:23a (Toubes) Function to retrieve data through TCP/IP protocol from the device timed out.

and this is through the IP address:

 12/22/11 11:34a (Toubes) Upload of Data Upload Profile(s) 1 2 4 5  partially completed. See error messages below.
 12/22/11 11:34a (FTP) Error (3) uploading file "Davis Logo.jpg" to location "public_html\vantageprodata\".
 12/22/11 11:34a Error (3) uploading file "Davis Logo.jpg" to location "public_html\vantageprodata\". WeatherLink will reset the FTP connection and try again.
 12/22/11 11:33a (Toubes) Error creating EMC image. Check Sensors.
 12/22/11 11:33a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\Weather_Summary_Vantage_Pro_Plus.htx
 12/22/11 11:33a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\phase.htx
 12/22/11 11:33a Could not open template file for reading: C:\Program Files\WeatherLink\Toubes\Templates\data.htx
 12/22/11 11:33a (Toubes) No new data to download.




I do have one suggestion... shut down your weatherlink.  Disconnect the ethernet cable from the datalogger and wait a few seconds.  Reconnect it. wait a minute and start up the weatherlink software and see what happens.
Davis VP2 Plus; 24h  FARS; Extra Temp Humid sensor (2); Extra Temp Station (2); Soil Moisture/Temp  https://www.weatherlink.com/embeddablePage/show/1c484adbfa914d1aa10a58ad53ccd563/summary;Weatherlink IP;USB; MAC Catalina
; Webcam;

Offline Wayne_R

  • Contributor
  • ***
  • Posts: 113
  • Work'n & Smok'n
    • Patio World
Re: communication errors
« Reply #18 on: December 23, 2011, 03:56:27 PM »
Seems to be working ok now.  Changed updates to 10 minutes from 15.  Still don't know whats happening, but if it starts going wacky again I will try some of the above remedies.

Thanks for all the advice.

Offline Aardvark

  • Forecaster
  • *****
  • Posts: 2146
Re: communication errors
« Reply #19 on: December 23, 2011, 04:18:09 PM »
one thought.. it could be the fault of your ISP..
Davis VP2 Plus; 24h  FARS; Extra Temp Humid sensor (2); Extra Temp Station (2); Soil Moisture/Temp  https://www.weatherlink.com/embeddablePage/show/1c484adbfa914d1aa10a58ad53ccd563/summary;Weatherlink IP;USB; MAC Catalina
; Webcam;