Author Topic: WeatherLink problems  (Read 4100 times)

0 Members and 1 Guest are viewing this topic.

Offline RonSC

  • Member
  • *
  • Posts: 11
WeatherLink problems
« on: January 24, 2011, 09:50:23 PM »
I have a Weather Envoy (WeatherLink 5.9.2) connected to my computer (Windows Vista)
with a serial/USB cable.

Yesterday when I clicked on the Browse tab, only the date and time appeared.  Any tab I
clicked on under Window resulted in a "WeatherLink has stopped working and Windows is searching for a solution".

Other than that, everything works normally.

I've sent an e-mail to Davis, but thought I'd run it by you folks as well.

Offline Cienega32

  • Forecaster
  • *****
  • Posts: 2571
    • East Mesa Weather
Re: WeatherLink problems
« Reply #1 on: January 28, 2011, 03:33:34 AM »
Check this thread for a similar problem I had: http://www.wxforum.net/index.php?topic=3168.0

The basic highlites:

- check if it crashes during uploads or strip chart or plot displays
- 'browse' the database (notepad looking icon)
- if it shows only date and time, check an entry for data (double-click or go to edit)
- if data there, close WL and delete the two DAT files - "DataSets.dat"  & "DataLists.dat"


Backup those two files first before you delete them or just rename them both. WeatherLink will rebuild them.

Pat ~ Davis VP2 6153-Weatherlink-Weather Display-StartWatch-VirtualVP-Win7 Pro-64bit
www.LasCruces-Weather.com   www.EastMesaWeather.com

Offline xykotik

  • DonkeyTailWX DW6891
  • Forecaster
  • *****
  • Posts: 696
  • I'll deal with it tomorrow
    • DonkeyTail Weather
Re: WeatherLink problems
« Reply #2 on: January 28, 2011, 10:43:26 AM »
Are you sending to CWOP and the time of lock-up (check download.log) corresponds to that profile?  If so, try WL 5.9.2a-BETA.  There is a thread around here somewhere.  It seems to help in that situation.


Facit solem suum oriri super bonos et malos et pluit super iustos et iniustos.

Springtime in Seattle...  March comes in like a lion and out like a wet lion.

Offline Cienega32

  • Forecaster
  • *****
  • Posts: 2571
    • East Mesa Weather
Re: WeatherLink problems
« Reply #3 on: January 28, 2011, 06:16:36 PM »
His problem occurs when he uses the "Browse" function. I'll wager that it also happens when he tries to use the Strip Chart or Plot functions as well.

Those three functions are dependent upon those two data files. They only consist of station hardware configurations and a template of what data to display and in what order for any of the three functions. WeatherLink rebuilds them on it's own if they're missing but won't do anything to them if the filename is found - regardless of filesize or content.

In other words, either or both could be absolutely empty and blank and WLink will try to use them. When it does, the software will crash. They're found in the station name sub-directory under the Weatherlink directory and both can be opened with a text editor/viewer. They both consists of nothing but text.

DataLists.dat
DataSets.dat
« Last Edit: January 28, 2011, 06:18:53 PM by Cienega32 »

Pat ~ Davis VP2 6153-Weatherlink-Weather Display-StartWatch-VirtualVP-Win7 Pro-64bit
www.LasCruces-Weather.com   www.EastMesaWeather.com

Offline Fytema1

  • Member
  • *
  • Posts: 1
Re: WeatherLink problems
« Reply #4 on: March 08, 2011, 01:49:54 PM »
Oh boy, I am so happy I stumbled upon this thread. thank you so much...
My Weatherlink 392 was crashing inexplicably and no-one seemed to be able to help me...
Until I found this! You made my day! Hooray...