Author Topic: WS-2000 Firmware Tips  (Read 4689 times)

0 Members and 1 Guest are viewing this topic.

Offline laajr

  • Member
  • *
  • Posts: 12
Re: WS-2000 Firmware Tips
« Reply #50 on: May 17, 2019, 02:54:02 PM »
Thanks

Offline ALEEF02

  • Member
  • *
  • Posts: 19
  • Hi! Check out my weather site!
    • LF Weather
Re: WS-2000 Firmware Tips
« Reply #51 on: May 17, 2019, 03:37:31 PM »
Version 1.4.4 has been removed from download because of error in file. Ambient knows about it and they are working to fix the file. There is only one source to download it which is Ambient's site:
https://www.ambientweather.com/amwewsfidoce.html

It will show up on that page when it becomes available.

There is a good chance that it will be replaced immediately with 1.4.5 or the like. Just saying in case you can't find 1.4.4 in the future you'll know why.

It is rather curious that every version released had up until 1.4.4 increased in size by a few KB. Then 1.4.4 comes out and it is a good bit smaller than several recent updates. These updates are not just changes...they contain a complete set of code. So either they really did some code cleanup or 1.4.4 is messed up because it is incomplete and that is why it fails to work.

1.0.9 - 1985 KB
1.2.0 - 1989 KB
1.2.5 - 2160 KB
1.2.6 - 2188 KB
1.2.7 - 2188 KB
1.3.5 - 2189 KB
1.3.8 - 2189 KB
1.4.0 - 2192 KB
1.4.1 - 2192 KB
1.4.2 - 2192 KB
1.4.4 - 1991 KB

That is peculiar. Perhaps it was smaller because of optimizations or maybe because of that error.

Offline ALEEF02

  • Member
  • *
  • Posts: 19
  • Hi! Check out my weather site!
    • LF Weather
Re: WS-2000 Firmware Tips
« Reply #52 on: May 17, 2019, 04:13:53 PM »
This note is on the Ambient Weather site right now at the download area
Quote
Version 1.4.4. Sorry for the delay in releasing this version. Your patience is appreciated while we fix a few things...

Offline laajr

  • Member
  • *
  • Posts: 12
Re: WS-2000 Firmware Tips
« Reply #53 on: May 18, 2019, 11:40:32 AM »
Ed said they would fix the bug on Monday....

Offline LEVRON

  • Member
  • *
  • Posts: 2
Re: WS-2000 Firmware Tips
« Reply #54 on: May 20, 2019, 08:45:57 PM »
New firmware (1.4.4) is up and running.
I added the PM2.5 and it shows on the ambientweather.net, they also added battery status.
 [ You are not allowed to view attachments ]
Here is a photo of the WS-2000 screen
 [ You are not allowed to view attachments ]

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #55 on: May 20, 2019, 09:02:10 PM »
Is that an Ambient PM2.5 sensor or an Ecowitt PM2.5 sensor?
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline LEVRON

  • Member
  • *
  • Posts: 2
Re: WS-2000 Firmware Tips
« Reply #56 on: May 20, 2019, 09:03:36 PM »
It Is an Ambient PM2.5 sensor, ordered last week got it today.

Offline havtrail

  • Contributor
  • ***
  • Posts: 131
    • Haverford Weather Station
Re: WS-2000 Firmware Tips
« Reply #57 on: May 20, 2019, 10:42:43 PM »
Another website using tiles...

Rich K.
Onset HOBO RX3003 Cellular
https://weather.havtrail.com
WU KPAHAVER17
NEWA pa_have

Offline ALEEF02

  • Member
  • *
  • Posts: 19
  • Hi! Check out my weather site!
    • LF Weather
Re: WS-2000 Firmware Tips
« Reply #58 on: May 20, 2019, 11:05:05 PM »
Is that an Ambient PM2.5 sensor or an Ecowitt PM2.5 sensor?

Are both compatible with the WS-2000's new update?

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #59 on: May 20, 2019, 11:17:45 PM »
Is that an Ambient PM2.5 sensor or an Ecowitt PM2.5 sensor?

Are both compatible with the WS-2000's new update?

We don't know if Ecowitt PM2.5 sensor will work with WS-2000 as nobody has confirmed this yet. I could test it if I upgraded my firmware. But I have a personal policy to not adopt new firmware right away for fear of bad firmware. After a couple weeks without incident reporting I'll then upgrade. I don't want to be the guinea pig.

The Ecowitt WH31 does not work with the WS-2000. So there is a good chance the PM2.5 won't either. And I think the Ecowitt soil sensor doesn't work either with the WS-2000.

WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline ALEEF02

  • Member
  • *
  • Posts: 19
  • Hi! Check out my weather site!
    • LF Weather
Re: WS-2000 Firmware Tips
« Reply #60 on: May 21, 2019, 08:50:05 PM »
Has anyone since heard anything bad about 1.4.4? I'm looking to install it tonight  \:D/

Offline Sir_MAK

  • Senior Member
  • **
  • Posts: 87
Re: WS-2000 Firmware Tips
« Reply #61 on: May 22, 2019, 06:45:42 AM »
Is that an Ambient PM2.5 sensor or an Ecowitt PM2.5 sensor?

Are both compatible with the WS-2000's new update?

We don't know if Ecowitt PM2.5 sensor will work with WS-2000 as nobody has confirmed this yet. I could test it if I upgraded my firmware. But I have a personal policy to not adopt new firmware right away for fear of bad firmware. After a couple weeks without incident reporting I'll then upgrade. I don't want to be the guinea pig.

The Ecowitt WH31 does not work with the WS-2000. So there is a good chance the PM2.5 won't either. And I think the Ecowitt soil sensor doesn't work either with the WS-2000.


I can confirm that neither the Ecowitt PM2.5 nor the Soil moister sensor works with the WS-2000 display with the new firmware.  Oh well.
  Both work fine in the GW-1000.
Ambient WS-2000, Central Ohio - WU WC
Ambient
WS-2902, Lake Erie   -    WU WC

Offline Mandrake

  • Senior Contributor
  • ****
  • Posts: 159
Re: WS-2000 Firmware Tips
« Reply #62 on: May 22, 2019, 07:06:09 AM »
I suppose the possible option for someone brave enough is to try is to flash the ecowitt firmware for the HP2551 to a Ambient WS-2000.

I cant see why it would not work and that should unlock the capability to see all sensors on your console, though of course you would have to trade the ambient.net for Ecowitt.net!

Obviously, anyone trying this would be doing so at their own risk!
Very Old Maplin/FO Weather station w/ Cumulus MX

Ecowitt HP2550A (IGUILDFO67)
Ecowitt GW-1000 (IGUILDFO68)
Ecowitt WH0291 Soil Moisture Sensor
Ecowitt WH041 PM2.5 AQM Sensor

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #63 on: May 22, 2019, 01:38:53 PM »
Version 1.4.4 has been removed from download because of error in file. Ambient knows about it and they are working to fix the file. There is only one source to download it which is Ambient's site:
https://www.ambientweather.com/amwewsfidoce.html

It will show up on that page when it becomes available.

There is a good chance that it will be replaced immediately with 1.4.5 or the like. Just saying in case you can't find 1.4.4 in the future you'll know why.

It is rather curious that every version released had up until 1.4.4 increased in size by a few KB. Then 1.4.4 comes out and it is a good bit smaller than several recent updates. These updates are not just changes...they contain a complete set of code. So either they really did some code cleanup or 1.4.4 is messed up because it is incomplete and that is why it fails to work.

1.0.9 - 1985 KB
1.2.0 - 1989 KB
1.2.5 - 2160 KB
1.2.6 - 2188 KB
1.2.7 - 2188 KB
1.3.5 - 2189 KB
1.3.8 - 2189 KB
1.4.0 - 2192 KB
1.4.1 - 2192 KB
1.4.2 - 2192 KB
1.4.4 - 1991 KB

The newly released 1.4.4 is much larger than the previously released one that gave error when attempting to flash.

Broken release:
1.4.4 - 1991 KB

New release:
1.4.4 - 2196 KB

As you can see it follows the trend to keep growing in size as new features are added.
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #64 on: May 22, 2019, 02:20:20 PM »
I suppose the possible option for someone brave enough is to try is to flash the ecowitt firmware for the HP2551 to a Ambient WS-2000.

I cant see why it would not work and that should unlock the capability to see all sensors on your console, though of course you would have to trade the ambient.net for Ecowitt.net!

Obviously, anyone trying this would be doing so at their own risk!

With an Ambientweather.net licensed Meteobridge or an Ambient WeatherBridge you don't have to trade Ecowitt.net for Ambientweather or vise versa. The GW1000 reports to Ecowitt.net and the Meteobride (WeatherBridge) reports to Ambientweather.net. So I get both.

I'm even now able to see my Ecowitt PM2.5 sensor on Ambientweather.net because of the Meteobridge.
 [ You are not allowed to view attachments ]
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline ALEEF02

  • Member
  • *
  • Posts: 19
  • Hi! Check out my weather site!
    • LF Weather
Re: WS-2000 Firmware Tips
« Reply #65 on: May 22, 2019, 08:59:45 PM »
There's a bug in 1.4.4 where the rain droplets icons are on, even though the rain rate is 0.00in/hr

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #66 on: May 22, 2019, 09:35:38 PM »
Good catch. That is an innocuous bug. Did you report it?
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline ALEEF02

  • Member
  • *
  • Posts: 19
  • Hi! Check out my weather site!
    • LF Weather
Re: WS-2000 Firmware Tips
« Reply #67 on: May 22, 2019, 10:07:42 PM »
Good catch. That is an innocuous bug. Did you report it?
Not yet, been running around all afternoon

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #68 on: May 23, 2019, 06:06:19 AM »
On second thought it did rain. Maybe it is just showing it was a rain day. It may be normal.
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline laajr

  • Member
  • *
  • Posts: 12
Re: WS-2000 Firmware Tips
« Reply #69 on: May 23, 2019, 07:07:04 PM »
Received a PM2.5 sensor from Ambient and am running 1.4.4. Seems to work well. Checking the alerts field on Ambientweather.net you can receive a SMS or email text on PM2.5 low battery. The numeric field should be set for <1 for a low battery (1= normal battery).

Thought I would pass this on as it wasn't obvious to me. I emailed Ambient and was told to use this value.

Offline Mapantz

  • Senior Contributor
  • ****
  • Posts: 296
    • Wareham Weather
Re: WS-2000 Firmware Tips
« Reply #70 on: May 24, 2019, 06:17:28 AM »
The rain drop graphic filling is associated with hourly rain, not the rain rate.


Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #71 on: May 24, 2019, 06:24:13 AM »
The rain drop graphic filling is associated with hourly rain, not the rain rate.

This makes sense since the WS-2000 didn't have rain rate when it first came out, it only had hourly rain.
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline ALEEF02

  • Member
  • *
  • Posts: 19
  • Hi! Check out my weather site!
    • LF Weather
Re: WS-2000 Firmware Tips
« Reply #72 on: May 24, 2019, 09:47:08 AM »
The rain drop graphic filling is associated with hourly rain, not the rain rate.

I'm not talking about the big rain drop, I'm taking about the little ones on top of it

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #73 on: May 24, 2019, 10:02:46 AM »
The rain drop graphic filling is associated with hourly rain, not the rain rate.

I'm not talking about the big rain drop, I'm taking about the little ones on top of it

Yes, and if hourly rain is not 0 then it is raining. Or rather is was just recently raining or could be still raining and that was the only way that the WS-2000 originally had to tell if it was raining because it didn't gain rain rate till just recently with a firmware update.

Now, that the WS-2000 has rain rate it does make sense for them to update the firmware so that the little rain drops are associated with rain rate instead of with hourly rain. That would be a good suggestion for Ambient Weather if someone wanted to make the case for it. Then go again and submit that rain rate be tied to the little rain drops. I do suggest that you do so in a positive constructive way. Because Ed is not to keen on complaints that are not valid. It is working as originally designed. This is merely a suggested improvement. So don't report to Ambient that its broken, because it isn't.
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline galfert

  • Forecaster
  • *****
  • Posts: 2700
Re: WS-2000 Firmware Tips
« Reply #74 on: June 03, 2019, 09:23:46 PM »
Possible Firmware Stability Issue with version 1.4.2 and 1.4.4

I waited a few weeks and decided to upgrade my WS-2000 to 1.4.4. I was still on 1.4.1. So I skipped 1.4.2. I found all kinds of stability problems with 1.4.4.

  • awnet app would constantly show and not show the WS-2000 under device list. It appears for a few seconds and then disappears.
  • awnet app in Device List when selecting WS-2000 will delay and show a pink circle spinning (hour glass)...times out sometimes...finally load WS-2000 configuration screen very delayed.
  • WU upload frequency was not reliable with delays of over 1 minute at times. Hardly ever a 16 second upload.
  • Ambientweather.net upload also was not reliable missing sometimes several minutes before an upload update.

I then felt that maybe the WiFi firmware may also need to be updated to keep up with the newest Revision Firmware. So I upgraded from 4.1.1 to 4.1.5 on the WiFi firmware. This was difficult to accomplish as it kept failing as the device was very unreliable as I think it kept internally rebooting or falling off the WiFi network (not sure which). After multiple attempts finally completed WiFi firmware upgrade to 4.1.5. Still same issues as before.

Then I decide to downgrade to Revision Firmware 1.4.2. But noticed the same behavior.

Then I decided to go down yet again to Revision Firmware 1.4.1. Ahhhh everything is fixed. WU uploads at 16 seconds, Ambientweather.net uploads at 1 minute, and awnet app never drops WS-2000 console from device list and loads up its configuration instantly.

I then tried to go back to 1.4.4 in case I got a bad flash or something. Nope didn't work. All these issues came back. So back down to 1.4.1 and all is fine again.

At this time I'm recommending staying with Revision Firmware 1.4.1. If you have a new PM2.5 then you'll need to live with these reliability issues to keep using the PM2.5 sensor. I've reported this to Ambient. Hopefully we see a new firmware soon.

UPDATE: New Firmware Version 1.4.5 just released...untested
« Last Edit: June 07, 2019, 10:52:28 AM by galfert »
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

 

anything