WXforum.net

Web Weather => Weather Website PHP/AJAX scripting => Custom Website Templates => Topic started by: wvdkuil on March 31, 2019, 08:49:11 AM

Title: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on March 31, 2019, 08:49:11 AM
Download:
https://leuven-template.eu/leuven_download2019.php?id=template
WiKi :
EN https://leuven-template.eu/dokuwiki28/doku.php?id=en:start 
NL https://leuven-template.eu/dokuwiki28/doku.php?id=nl:start
Known issues:
EN https://support.leuven-template.eu/problems28.php?lang=en
NL https://support.leuven-template.eu/problems28.php?lang=nl

Demo:  https://support.leuven-template.eu/userlist.php?lang=en
All sponsors are listed there. You can sort on weather-program or country and visit a users-site near you.

Remarks:
Edit August 2020:  The template is not yet suitable for Canada. There were no Canadian users in the past years, so I had no feedback about changes in the data-sources. The next release scheduled for January next year will probably also include Canadian scripts.

This template is huge. It uses your station-data but also the data from all kind of different sources.
And those data-sites changes their API's multiple times / year.
So if you want to install the template as an extra to your main site,  "just for fun of installing" remember to delete the weather28/ folder at the end. The scripts can become obsolete without updates. The bots will continue to run the scripts and all kind of errors will flood your error logs.

Support:
Donation-ware
If you run the template for production  please remember, this template is "donation-ware" (https://en.wikipedia.org/wiki/Donationware) not free-ware or share-ware.
You find the donation-button at the sponsors-page (https://support.leuven-template.eu/userlist.php?lang=en)

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: txweather.org on March 31, 2019, 09:17:39 AM
Super awesome Wim! Thanks!
Title: Re: Support for the "Leuven-Template" in 2019
Post by: KapitainOne on April 06, 2019, 05:56:41 PM
Thanks for making it available again Wim, I downloaded, installed and got most of it working.
Solar isn't reporting as I expected but strongly suspect the problem is on my end using weewx and the weewx-wd skin to create that testtags.php file!
My Saratoga test template has an issue with this also.
No worries, I can live with it as it stands
Bill

Title: Re: Support for the "Leuven-Template" in 2019
Post by: captainjackfan58 on May 15, 2019, 04:15:16 PM
Super awesome Wim! Thanks!

This is awesome and what I want. But I have an Acurite Atlas and only can send info to WU so I am ready as soon as I get the zip file with the goods in it to upload to ftp on hosting site. :-)
Title: Re: Support for the "Leuven-Template" in 2019
Post by: krekel on May 19, 2019, 04:27:59 AM
There is a problem with the WU history page.
https://www.weerstation-assen.nl/weather28a/index.php?p=wsWUstart&lang=nl&ipad
Has it to do with the WU changes?

Brgds,
Oebel
Title: Re: Support for the "Leuven-Template" in 2019
Post by: djroby19 on May 19, 2019, 02:03:48 PM
There is a problem with the WU history page.
https://www.weerstation-assen.nl/weather28a/index.php?p=wsWUstart&lang=nl&ipad
Has it to do with the WU changes?

Brgds,
Oebel

And a problem with Wunderground servers
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on May 19, 2019, 03:55:25 PM
ALL requests to the CSV data return
Quote
An error occurred while processing your request.
Reference #30.26bc3b17.1558295413.4ee19d6
Probably a temporary glitch since early this morning.
Lets see if it works on Monday
Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: Mtn_man on May 20, 2019, 11:04:11 AM
Data extracted from WU with the "weather report" tab, is now blank for 2019.  No error messages, just a blank table.
Data for 2010 through 2018 does still display, and nothing prior to 2010.

Looking on WU site, my data goes back to January 2008, and 2019 data is there.  Prior to this my data on WU went back to March 2005, which it appears they have deleted. 

WU History Text and WU History Graphs do not display data, but without script errors.
Title: Re: Support for the "Leuven-Template" in 2019
Post by: krekel on May 20, 2019, 11:09:29 AM
Just read this post from Ken True:

I received word from Victoria Gardner and they have turned off (permanently) the old CSV query capability on the website.

Unfortunately, the PWS WU/API does not provide the full equivalent capability (missing month and year queries), and only specific date queries.

So.. for now, all scripts that used the CSV query are dead  (WU-History, etc).


So, nothing to do about it I think.

Brgds,
Oebel
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on May 20, 2019, 11:34:58 AM
Just read this post from Ken True:

I received word from Victoria Gardner and they have turned off (permanently) the old CSV query capability on the website.

Unfortunately, the PWS WU/API does not provide the full equivalent capability (missing month and year queries), and only specific date queries.

So.. for now, all scripts that used the CSV query are dead  (WU-History, etc).


So, nothing to do about it I think.

Brgds,
Oebel
As all history scripts are affected, I need multiple days/weeks of recoding the scripts.
I am on vacation until June 3, with only an iPad. So nothing I can do or help with for now.

All users should make a copy of the WU-data which can be found in the cache/ folder.
We can not reload them so store those datasets on your PC also.

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: mldenison on May 20, 2019, 01:25:10 PM
Hi Wim,

Enjoy your vacation!

You'd helped me a few months ago on my question as to how to modify the main menu.  I've just started tackling that and have a few pages that don't work which I'd like to fix before reorganizing.

Right now, I'm trying to get the SPC Severe Weather and the SPC Sounding pages to load.  They're under the 'More Advisories' menu tab right now.

Both of them display nothing.  I looked in the php code for both and found that the http links don't work but do when they are https.  Changing them to https in the php code again returned nothing so I'm missing something it seems.  Any ideas - when you get back?

Also, the 'Nearby Buoys' (under Mesonet right now) did not work for the verbose buoy data.  I changed the URL$ to 'https://www.ndbc.noaa.gov/data/latest_obs/latest_obs.txt' from 'http://140.90.238.27/data/latest_obs/latest_obs.txt' in the ws_buoy_generate.php file which fixed the issue.

Here's the website link: http://www.m82a1.us/weather28/index.php?p=wsStartPage&lang=en (http://www.m82a1.us/weather28/index.php?p=wsStartPage&lang=en)

Thanks,
Mort
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wsNoordbergum on May 28, 2019, 08:00:16 AM
Just read this post from Ken True:

I received word from Victoria Gardner and they have turned off (permanently) the old CSV query capability on the website.

Unfortunately, the PWS WU/API does not provide the full equivalent capability (missing month and year queries), and only specific date quer

So.. for now, all scripts that used the CSV query are dead  (WU-History, etc).


So, nothing to do about it I think.

Brgds,
Oebel
As all history scripts are affected, I need multiple days/weeks of recoding the scripts.
I am on vacation until June 3, with only an iPad. So nothing I can do or help with for now.

All users should make a copy of the WU-data which can be found in the cache/ folder.
We can not reload them so store those datasets on your PC also.

Wim

Thanks in advance Wim!

With kind regards wsNoordbergum
Title: Re: Support for the "Leuven-Template" in 2019
Post by: plex on February 16, 2020, 05:17:17 AM
Hi

How can I correct the link button, to show correct forecasts?

As it is now - all cities link to my own city forecast.

https://www.vejrstationen.dk/weather28/index.php?p=wsStartPage&wp=MB&lang=en (https://www.vejrstationen.dk/weather28/index.php?p=wsStartPage&wp=MB&lang=en)

Thanks

 [ You are not allowed to view attachments ]

Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on February 16, 2020, 05:30:02 AM
Hi
How can I correct the link button, to show correct forecasts?
As it is now - all cities link to my own city forecast.
https://www.vejrstationen.dk/weather28/index.php?p=wsStartPage&wp=MB&lang=en (https://www.vejrstationen.dk/weather28/index.php?p=wsStartPage&wp=MB&lang=en)
Thanks
That dashboard component can only link if you allow multiple forecasts in your settings.
Code: [Select]
# Multiple selections on forecast pages
$SITE["multi_forecast"] = true;                 # true = Enable this facility  |  false = Do not display
$SITE["multi_fct_keys"] = "./_my_texts/eu_multi_fct.txt";
Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: plex on February 16, 2020, 06:17:46 AM
Hi
How can I correct the link button, to show correct forecasts?
As it is now - all cities link to my own city forecast.
https://www.vejrstationen.dk/weather28/index.php?p=wsStartPage&wp=MB&lang=en (https://www.vejrstationen.dk/weather28/index.php?p=wsStartPage&wp=MB&lang=en)
Thanks
That dashboard component can only link if you allow multiple forecasts in your settings.
Code: [Select]
# Multiple selections on forecast pages
$SITE["multi_forecast"] = true;                 # true = Enable this facility  |  false = Do not display
$SITE["multi_fct_keys"] = "./_my_texts/eu_multi_fct.txt";
Wim

 :oops:

Thanks Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: plex on February 16, 2020, 08:08:52 AM
One more question regarding the Weather Report / wsReports.

https://www.vejrstationen.dk/weather28/index.php?p=wsReports&lang=en#data-area
 (https://www.vejrstationen.dk/weather28/index.php?p=wsReports&lang=en#data-area)

Data from the 1st of February to 4th of February is missing. Also most data from past years is missing, and I know from earlier, that some users has lost data from WU. But it doesn't seem to be the problem, as historical data is visible on WU webpage.

https://www.wunderground.com/dashboard/pws/IMIDTJYL15/graph/2020-02-2/2020-02-2/daily (https://www.wunderground.com/dashboard/pws/IMIDTJYL15/graph/2020-02-2/2020-02-2/daily)

My installation of the template is fresh, so I assume past fixes regarding WU is included.

What could be the problem?

Thanks in advance
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on February 16, 2020, 08:49:13 AM
. . . shortened . . .
My installation of the template is fresh, so I assume past fixes regarding WU is included.
What could be the problem?
. . .
he problem, no new users since at least a year.
Almost all existing users implemented the update as attached.

As you can see yourself, you are the only post with an install in this topic.
Solution:

Wim

Title: Re: Support for the "Leuven-Template" in 2019
Post by: plex on February 16, 2020, 01:40:58 PM
. . . shortened . . .
My installation of the template is fresh, so I assume past fixes regarding WU is included.
What could be the problem?
. . .
he problem, no new users since at least a year.
Almost all existing users implemented the update as attached.

As you can see yourself, you are the only post with an install in this topic.
Solution:
  • You can install the KenTrue solution https://github.com/ktrue/WU-History and adapt the links
  • Or use my version as attached, a readme is in the download. This is the same solution as used in the PWS_Dashboard
  • Therefor you could also use the script PWS_DailyHistory.php 

Wim

Thanks Wim - I've implemented the attached fix - then time will tell [tup]

Title: Re: Support for the "Leuven-Template" in 2019
Post by: Torjan on February 25, 2020, 02:33:35 PM
Hi!
After my host moved me to a new server, some problem has appeared. It's one I don't figure out. The wind rose on my website is gone. error message is 404 not found. But it is there.
Appreciated if anyone could help.

http://foreneset.no/weather2/index.php

Torjan
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on February 25, 2020, 03:28:36 PM
Hi!
After my host moved me to a new server, some problem has appeared. It's one I don't figure out. The wind rose on my website is gone. error message is 404 not found. But it is there.
Appreciated if anyone could help.
http://foreneset.no/weather2/index.php
Torjan

The Meteobridge template-value for wind-direction is invalid.
Change line  211 in scriptsMB/tags.mb.txt from
Code: [Select]
|windActDsc|[wind0dir-act=endir.0:--]|!to
Code: [Select]
|windActDsc|[wind0dir-act=endir:--]|!   ##  2018-11-26
Press reload template in the services tab of your Meteobridge for this upload and the wind-direction will be abvailable and added to the name of the wind-rose a.s.o.

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: Torjan on February 25, 2020, 03:43:54 PM
Hi!
Tanks! That was it.
Title: Re: Support for the "Leuven-Template" in 2019
Post by: kirikiri on April 20, 2020, 06:46:41 AM
Hello Wim,


Now in the correct forum... :-) I have 3 questions: everything went OK for my website installation and the template until now but :

- is it possible to include a Google Analytics key somewhere ?
- is it possible to cancel the display of the console forecast ? I never believe in the erratic forecasts issued from there
- I have seen somewhere in the files a place where to place a "WU key", is that the password or an API key ?

Thanks in advance,

Daniel
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on April 20, 2020, 07:20:00 AM
Hello Wim,
- is it possible to include a Google Analytics key somewhere ?
Probably yes, but have never done so. Maybe another user knows where to find the "how to" guide
Quote
- is it possible to cancel the display of the console forecast ? I never believe in the erratic forecasts issued from there
You refer to the forecast in the header?
In ./scriptsMB/tags.mb.txt line 268 the Davis forecast is loaded by Meteobridge
Code: [Select]
fcstTxt|[forecast-text:Data will be reloaded in]|!You can change that in a fixed text explaining the counter at the right
Code: [Select]
fcstTxt|Data will be reloaded in|!Others insert a saying about the weather in the used field itself $ws['fcstTxt] , some even dynamically in the script where that line is displayed.

Or you can change the settings inside the script which displays the gauges in the header. Script ./gauges/gaugeFrame.php lines 7-16
Code: [Select]
$disp_lcd_line  = true;         # true or false if no display of the line with led / forecast /counter
#                               # following lcd settings are ignored if disp_lcd_line is set to false
$disp_lcd_place = 'bottom';     # 'bottom' = below gauges or 'top' = above gauges.
$disp_lcd_led   = true;         # true or false if no display of the LED
$disp_lcd_fct   = true;         # true or false if no display of the forecast line
$disp_lcd_count = true;         # true or false if no display of the counter.
#
$lcd_fct_width  = 500;          # width of the LCD with forcast text, if displayed
$lcd_height     = 15;           #
$lcd_line_loc   = 'center';     # 'center'  'left'  'right'

Quote
- I have seen somewhere in the files a place where to place a "WU key", is that the password or an API key ?
Thanks in advance, Daniel
The "WU key" is not supported inside the template scripts anymore. So you only have to add a line in ./_my_texts/wsUserSettings.php
Code: [Select]
$SITE["wuKey"] = false; This will remove the error about a missing wuKey.

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: kirikiri on April 22, 2020, 12:36:15 PM
Thanks Wim for the help. It is now OK for these points.

I still have 2 remaining things to solve:

- The wind page with Windy which is only showing a map without any wind directions of speeds, there is a flag where I am supposed to be with "NaNkm/h" written in a box. If I am clicking on others parameters nothing changes
- What to do delete the "Zambretti" forecast box ?
- Is there a possibility to have graphs generated on the page ? The "Station Graphics" is empty, my MB Nano is generating graphs and they are stored in the SD card.

I will take a look to the WU questions with the template because I have no history or graphs showing on the WU pages even after put the ID of my WU station.

Thank you in advance,


Daniel
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on April 23, 2020, 03:12:41 AM
. . .
- The wind page with Windy which is only showing a map without any wind directions of speeds, there is a flag where I am supposed to be with "NaNkm/h" written in a box. If I am clicking on others parameters nothing changes
Can not replicate, all seems to work wel when i test that page, see attached screenshot
Quote
- What to do delete the "Zambretti" forecast box ?
https://support.leuven-template.eu/  => link to WiKi => https://leuven-template.eu/dokuwiki28/doku.php?id=en:start
Tho bottom half of the WiKi first page has all kinds of interesting topics, the first one in the list is the one you need
==> https://leuven-template.eu/dokuwiki28/doku.php?id=en:startpage
That page describes how to add remove rearrange all possible components.
Quote
- Is there a possibility to have graphs generated on the page ? The "Station Graphics" is empty, my MB Nano is generating graphs and they are stored in the SD card.
AFAIK not possible
But if your Meteobridge can upload them, yes you can use them on your site 
Quote
I will take a look to the WU questions with the template because I have no history or graphs showing on the WU pages even after put the ID of my WU station.
If you want to install/test the Saratoga template and/or Meteotemplate also use the Saratoga = Ken True solution
If you want to use the Leuven-Template use my version to solve the "WU-CSV" problem
Check this answer:  https://www.wxforum.net/index.php?topic=36504.msg398885#msg398885
Quote
Thank you in advance,
Daniel
Succes, Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: kirikiri on April 23, 2020, 05:42:13 AM
Thank you very much Wim !

I've understand the Windy problem...use of a too restrictive browser (Brave), if I use Safari everything is perfect with Windy ! ;-)

For Zambretti forecast, I've followed the Wiki instructions...it is now OK, it' out of the page

I will now investigate your solution for WU ;-)


Regards,


Daniel
Title: Re: Support for the "Leuven-Template" in 2019
Post by: JackKr on June 29, 2020, 12:04:16 PM
Hello ,

I have an issue with two graphics on my website (wewetter.de). Both of them are directly on the frontpage/under the tab home and are not being shown, one is the weather symbol, that's under the thermometer and the other one is the graphic displaying the wind direction.




Do you have an idea what the issue could be and how to fix it?




Thank you in advance and have a nice day,

Jens
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on June 29, 2020, 01:01:18 PM
Hello ,I have an issue with two graphics on my website (wewetter.de). Both of them are directly on the frontpage/under the tab home and are not being shown,
one is the weather symbol, that's under the thermometer
I assume you refer to icon with the ? in it, just above the thermometer?
That is caused by a change of the Metar-website.
https://support.leuven-template.eu/problems28.php?lang=en (https://support.leuven-template.eu/problems28.php?lang=en)
=> 2019-02-04 NEW VERSION   no metar
Download (attached) zip of new version of weather28/metar/wsMetarTxt.php,
unzip, and replace current version AFTER you made a backup/copy of that script.
Quote
and the other one is the graphic displaying the wind direction.
. . .
There was a change in the Meteobridge tags some time ago.
Change line 211 of scriptsMB/tags.mb.txt from
Code: [Select]
|windActDsc|[wind0dir-act=endir.0:--]|! to
Code: [Select]
|windActDsc|[wind0dir-act=endir:--]|!   ##  2018-11-26
Then go to your Meteobridge tab with all the uploads and use "Reload template" to update the version in your Meteobridge.
Succes, Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: JackKr on June 29, 2020, 02:38:19 PM
Hello ,I have an issue with two graphics on my website (wewetter.de). Both of them are directly on the frontpage/under the tab home and are not being shown,
one is the weather symbol, that's under the thermometer
I assume you refer to icon with the ? in it, just above the thermometer?
That is caused by a change of the Metar-website.
https://support.leuven-template.eu/problems28.php?lang=en (https://support.leuven-template.eu/problems28.php?lang=en)
=> 2019-02-04 NEW VERSION   no metar
Download (attached) zip of new version of weather28/metar/wsMetarTxt.php,
unzip, and replace current version AFTER you made a backup/copy of that script.
Quote
and the other one is the graphic displaying the wind direction.
. . .
There was a change in the Meteobridge tags some time ago.
Change line 211 of scriptsMB/tags.mb.txt from
Code: [Select]
|windActDsc|[wind0dir-act=endir.0:--]|! to
Code: [Select]
|windActDsc|[wind0dir-act=endir:--]|!   ##  2018-11-26
Then go to your Meteobridge tab with all the uploads and use "Reload template" to update the version in your Meteobridge.
Succes, Wim


Thank you for the help, now it works!!

Regards,
Jens
Title: Re: Support for the "Leuven-Template" in 2020
Post by: wvdkuil on August 01, 2020, 06:01:44 AM
Looks like Yrno forecast is also changed.
Not sure if there is already a topic about.
The Leuven support forum is not readable for me anymore.
The xml has changed.
Well something to do I guess.

The yr.no forecasts contain a hidden warning to the script-programmers.
Quote
NB!!! Since we have no other options to contact our users of forecast.xml, we have decided to use this method to get your attention to some major changes with our API
In the first quarter next year, forecast.xml and forecast_hour_by_hour.xml will be discontinued in favour of a newer JSON API.
Vi encourage you already now to switch to the new API.
There are a lot of changes, and you can read all the technical details in our new developer portal https://developer.yr.no

They also show a message to read that warning in the data-fields on some forecasts during the day.
That is their only way to bring this to the script-authors attention, but it looks not nice for the visitors of the websites.

I read all the changes and have to decide if it is worth my time to adapt the yr.no leuven-scripts before end-of-this year when yr.no and met.no forecasts in the 1.9 version will by EOL.

The yr.no script will not be adapted as yr.no data will be replaced with data identical to met.no.
The yrno and metno forecast  will be identical.  You should remove the Yr.no forecast from the menu early 2021.
It is not clear yet, if we can continue to use the yr.no meteogram-image and the full page .pdf.

The met.no script needs 1 minor change, the version number in the URL should be changed from 1.9 to 2.0 and will remain identical when adding a "classic" keyword.
The resulting xml seems identical when testing now, but I will follow closely if that will change.
No other changes needed.

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: blainec on August 27, 2020, 01:13:51 PM
I am trying to setup this template but I am getting errors on the "configure" page and can not continue


Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on August 27, 2020, 02:22:47 PM
I am trying to setup this template but I am getting errors on the "configure" page and can not continue

Sorry, it seems an essential file can not be loaded as it was in the past.
Not that much new installs for Canadian users past years.
Will try to get the file in a different way.

Script weather??/configure/ca_AQHI_list.php  line 34 change from
Code: [Select]
$url            = dd.meteo.gc.ca/air_quality/doc/AQHI_XML_File_List.xml';to
Code: [Select]
$url            = 'https://dd.meteo.gc.ca/air_quality/doc/AQHI_XML_File_List.xml';
And / or move the attached file to the weather??/cache/ folder

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: blainec on August 27, 2020, 04:15:01 PM
That fixed the "configure" issue. Now I see more errors when I load the website.
You can see them here   https://weatheryyc.com/weather28

Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on August 27, 2020, 04:26:37 PM
That fixed the "configure" issue. Now I see more errors when I load the website.
You can see them here   https://weatheryyc.com/weather28
Probably a similar error as EC probably changed aa few things in the past years.

AFAIK there were no Canadian users, so I had no reports of errors whatsowever.
The EC forecast script in the Leuven-scripts is working Ok. But i have to test other specific Canadian settings.

As there is a large time-difference between our regions, it would be helpful if you could e-mail me your "_my_txts/wsUserSettings.php" so i can test it tomorrow when it is  day-time here in Belgium.

Wim

Attached one script already for the weather28/canada/  folder

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: blainec on August 27, 2020, 04:32:33 PM
I have sent the file
Title: Re: Support for the "Leuven-Template" in 2019
Post by: blainec on August 27, 2020, 04:39:48 PM
New file is getting us closer. :-)
Not getting forecast or Historical data

Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on August 27, 2020, 04:46:24 PM
New file is getting us closer. :-)
Not getting forecast or Historical data

You should use EC forecast once to replace cache file, it works Ok here

Your wxsim latest.csv is to old, data from Augusts 6.
Code: [Select]
Year ,Month ,Day ,Time ,WX Type 1 ,WX Type 2 ,Temperature ,Hi Temp ,Low Temp ,Rel.Hum. ,Dew Pt. ,Wet Bulb ,Wind Spd. ,Wind Dir. ,Tot.Prcp ,Snow Dpth ,S.L.P. ,Stn.Pres. ,Wind Chl ,Heat Ind ,Vly Tmp ,Hill Tmp ,T_Lvl 1 ,T_850 mb ,10-5 Thk ,LI ,Sky Cov ,SC L1 ,SC L2 ,SC L3 ,SC L4 ,SC L5 ,Vis Trans ,VIS ,Sun Alt ,Solar Rad ,UV Index ,Freezing Level (highest) ,Snow Level (= freezing level when no precip) ,Convection index (1=very unlikely...2=unlikely...3=sctd.possible...4=sctd.likely...5=numerous likely) ,Severe index (1=very unlikely...2=unlikely...3=sctd.possible...4=sctd.likely...5=numerous likely) ,1 min Gust ,10 min Gust ,1 hr Gust ,6 hr Gust ,FFDI ,FWI ,Average ,WBGT
  ,  ,  ,hrs (DST) , , ,deg C ,deg C ,deg C ,pct ,deg C ,deg C , km/hr ,deg ,mm ,cm ,mb (in.Hg x 33.864) , ,deg C ,deg C ,deg C ,deg C ,deg C ,deg C ,meters ,deg C ,pct ,pct ,pct ,pct ,pct ,pct ,pct ,km ,deg ,W/m^2 ,  ,meters ASL ,meters ASL ,  ,  , km/hr , km/hr , km/hr , km/hr ,  ,  ,  ,deg C
 2020  , 8  , 6  , 15  ,DNS.OVCST  ,PROB. DRZL , 29  , 18.3  , 17  , 26.1  , 7.6  , 16  , 15.4  , 256  , 0  , 0  , 995.3  , 879.8  , 29  , 29.3  , 29.5  , 28.5  , 24.4  , 26  , 5795.5  ,-8.1  , 100  , 100  , 0  , 0  , 0  , 0  , 19.4  , 28.9  , 52  , 158.9  , 2.2  , 4263  , 4263  , 0  , 0.36  , 25.6  , 32.1  , 38.2  , 45.4  , 16.9  , 35.7  , 26.3  , 20.8  ,2020-08-06_21:00_UTC
 2020  , 8  , 6  , 15.5  ,CLOUDY     ,PROB. DRZL , 29.2  , 30.3  , 28.7  , 26  , 7.6  , 16.1  , 15.7  , 256  , 0  , 0  , 995.5  , 880  , 29.2  , 29.5  , 29.8  , 28.6  , 23.7  , 25.4  , 5790.7  ,-7.2  , 85.4  , 83.3  , 0.1  , 3.2  , 0  , 9.6  , 38.3  , 28.7  , 49.1  , 298.7  , 3.1  , 4227  , 4227  , 1.85  , 1.9  , 22.9  , 28.5  , 33.7  , 39.9  , 17.4  , 36.9  , 27.1  , 21.7  ,2020-08-06_21:30_UTC
 2020  , 8  , 6  , 16  ,M.CLOUDY   ,PROB. DRZL , 29.6  , 30.7  , 29.1  , 25.5  , 7.7  , 16.3  , 16  , 256  , 0  , 0  , 995.9  , 880.4  , 29.6  , 29.9  , 30.2  , 29  , 23.5  , 25.3  , 5783.1  ,-6.8  , 74.9  , 66.7  , 0.2  , 6.5  , 0  , 19.2  , 54.2  , 28.6  , 45.7  , 395.7  , 3.4  , 4156  , 4156  , 2.55  , 2.36  , 23.7  , 29.6  , 35.2  , 41.8  , 18.1  , 38.1  , 28.1  , 22.5  ,2020-08-06_22:00_UTC
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on August 28, 2020, 03:49:07 AM
. . .  You should use EC forecast once to replace cache file, it works Ok here  . . .
Your site has problems with the EC forecast, the script is unable to get the data from EC
Quote
Module ec_fct_generate_html.php (42): No good data - ending script
I have no idea why the script is not working at your website while it is working OK at mine.

Both websites are using PHP7.22. The only difference is your site is using windows.

Attached the EC script with added debug code.  This will help pinpoint the problem.

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: blainec on August 28, 2020, 09:08:47 AM
I installed the script and now EC forecast shows.
Another issue is the radar maps. They are not working for my location

Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on August 28, 2020, 09:45:51 AM
I installed the script and now EC forecast shows.
I switched of the checking SSL_VERIFYHOST and SSL_VERIFYPEER  as that could be the problem.
Quote
Another issue is the radar maps. They are not working for my location
As I answered in the first mail before you started this installation, there were no Canadian users in the past years.
So there was no way I could find those http/https problems, changed data-API a.s.o.

Early next year, there will be a new release and I will do my best to add most of the specific code for Canadian users.
At this moment in time, I am unable to do that. Sorry.

Your current Saratoga template has all radars and is working without errors. So maybe you can use the links you are using there.

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: northamptonwx on September 04, 2020, 10:07:45 AM
Perhaps an easy one to answer: My webpage displays a red LED and says it is out of service every afternoon after 1pm. It goes green after 1am. I have hunted high and low for the cause. Everything else seems to work fine.

Great template by the way, many thanks for your work on it.
Title: Re: Support for the "Leuven-Template" in 2019
Post by: wvdkuil on September 04, 2020, 10:51:48 AM
Perhaps an easy one to answer: My webpage displays a red LED and says it is out of service every afternoon after 1pm. It goes green after 1am. I have hunted high and low for the cause. Everything else seems to work fine.

Great template by the way, many thanks for your work on it.

Thanks for using the template and for your nice words.

Your problem is new tob me. I have to check why the realtime file for the gauges is not correctly displaying the curren time
https://www.northamptonweather.org.uk/weather28/ws_realtime.php
It is now Friday Sept 4, 14:00 UTC but the file displays timeUTC: "2020,09,04,00,00,00"

That is based on an upload field in clientraw.txt Northampton_Weather-15:39:42_PM
The time is already in 24 hours format but it has an  extra _PM
I wil do some testing why the script gets confused and decides the time is invalid  and changes it to 01:00:00 London DSTime

Wim
Title: Re: Support for the "Leuven-Template" in 2019
Post by: saratogaWX on September 04, 2020, 12:00:15 PM
I've seen this before.  Check WD, Control Panel, Units/Other Settings, Precision/Time/Date/Cloud Height TAB

There are two check boxes:

Use AM/PM clock
Use 24 Hour clock

Make sure only ONE is ticked -- you likely have both ticked which causes the problem.
Title: Re: Support for the "Leuven-Template" in 2019
Post by: northamptonwx on September 04, 2020, 12:59:48 PM
I've seen this before.  Check WD, Control Panel, Units/Other Settings, Precision/Time/Date/Cloud Height TAB

There are two check boxes:

Use AM/PM clock
Use 24 Hour clock

Make sure only ONE is ticked -- you likely have both ticked which causes the problem.

Well done Ken! I knew it had to be something stupid like that.

Thanks for your help and prompt reply, and yours Wim, one for the WD gotcha files!

Kevin