Weather Station Hardware > LaCrosse Technologies/Hyundai

Inaccurate Barometer Reading

(1/2) > >>

Hi, I'm using WeeWx with a LaCrosse WS-2800 and getting the wrong barometer readings. All other readings appear to be accurate. Currently my WS-2800 shows a barometer reading of 29.68 Hg but WeeWx displays a reading of 39.51 Hg. I'm getting WeeWx barometer readings from 39-41. I've checked the WeeWx.Conf file and I believe I have all the settings correct for a US configuration. Has anyone also experienced this problem or have any suggestions for resolution? Thanks.

You are at very high elevation. Lots of weather stations do not work well at such high elevation. But the problem is being compounded by the likelihood that your WeeWX is interpreting your corrected sea level pressure as station pressure (atmospheric) and then adding its own correction factor to that....resulting in what seems like 11,447 feet of elevation. I suspect that your real elevation is probably half of that at somewhere around 5,700 feet. I say half because it seems to me like your station is doing a correction and then WeeWX is also trying to do the same correction for you really high elevation. And 5,700 ft seems reasonable for your town. To fix this you'll need to let WeeWX know that the pressure being passed from your station is not station pressure but rather that it is sea level pressure.

But know that I'm just speculating. I have no idea how your LaCrosse station works nor what exact data is being passed to WeeWX. I'm just speculating based on your location and the data you provided. Maybe that can be a good lead for you to follow.

Thanks for this response. I believe that WeeWx is getting accurate data from the LaCrosse weather station, leaving me to generally agree that WeeWx is somehow adjusting the data. BTW, I'm at 7690 feet. 

So, if WeeWx is the culprit, how do I calibrate WeeWx? Assuming that WeeWx is overestimating the barometer reading by, let's say, 10.5 Hg, do I run StdCalibrate with this command: barometer = barometer - 10.5?

I'm still concerned that my config file might be the reason for the error. Again, I've set everything in WeeWx.conf to US measurements - feet, HG, etc. Is there anything else in .conf that might be driving a wrong pressure reading? Thanks...

Your first step before you deal with WeeWX should be to get the correct barometric pressure to show on your display console. That obviously is low and needs correcting. You should reference your local METAR station KDRO:

Once you've calibrated your console you can then see what WeeWX is dong with that data. Seems like your station is passing Relative Pressure to WeeWX and not station pressure. Which is fine as WeeWX will accept any type of pressure you send it and calculate the missing values (like station pressure). You'll have to decide if you want to see Sea Level or Altimeter on your console as they will be very different at your elevation. Bear in mind that your console is not really designed for Altimeter and thus setting it to Sea Level pressure is probably the right choice. The METAR I referenced will show you both Sea Level and Altimeter values. Up to you to experiment and decide though. WeeWX will accept the pressure you pass from your console as Relative (Sea Level) or as Altimeter if you do the correct mapping in WeeWX. The the other values will be computed from that given your elevation that you also give WeeWX.

The METAR shows you Sea Level pressure in mb (millibar) which is the same thing as hPa (hecto Pascal). You'll likely need to convert this to inHg. Use this online converter:


Thanks for the post, and your suspicions are correct the issue appears to be how WeeWx uses the pressure value passed to it from my WS-2800 weather station. I figured out what seems to be the issue and a workaround. In short, I fear that WeeWx is not using pressure correctly for WS-2800 devices. Here are my learnings...

First, I tried to understand what pressure readings come from the WS-2800 device. I connected the usb device to HeavyWeather, which is a Windows app and which worked just fine before I went to WeeWx. HeavyWeather creates a currdata.lst record of current data, and in this file there are 2 types of pressures: ABSOLUTE and RELATIVE. My software showed me a relative pressure reading that matched the display on the weather station, but null values for absolute pressure:



Next. I reconnected the USB to my Pi computer and tried a couple of tests with the WeeWx.conf file. Based on Users Guide documentation, my guess was that WeeWx also tries to read two types of pressure: Station PRESSURE, which is supposedly the raw data from the device, and Sea-level Pressure (labeled BAROMETER), which the WeeWx doc claims to calibrate to the proper altitude. The config file also lets us use HARDWARE, SOFTWARE or PREF_HARDWARE settings. So here's my tests and the results:

First, I set both readings to HARDWARE and got no (i.e. null) readings in WeeWx for barometric pressure. This led me to believe that it wasn't reading the Station Pressure value correctly.
Next, I set both readings back to the default PREF_HARDWARE and set my my station ALTITUDE = 0 (i.e., Sea Level). I found that WeeWx now "calculates" barometric pressure to be the same value as the device setting. I.e., it no longer revises the station pressure to a new value.

So, by faking out the altitude, I'm now getting accurate barometric pressure settings in the WeeWx database and on my Wunderground site:, but I had to force WeeWx to think that my device is at sea level. It seems that WeeWx is using Station Pressure as Sea Level Pressure, which is an error, unless there is something in the config file that I'm missing or setting up incorrectly. This would lead me to believe that the mapping of data for WS-2800 devices may be in error.

Should I submit this as a possible issue to the WeeWx user group?


[0] Message Index

[#] Next page

Go to full version