Author Topic: wxwinddetail  (Read 400 times)

0 Members and 1 Guest are viewing this topic.

Offline dazza

  • Member
  • *
  • Posts: 43
wxwinddetail
« on: April 09, 2021, 04:56:59 AM »
hi i just found this nice data summy  ive got it on standalone template but im stuck one where it shude be - but it showing � but i set in the browser
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
but it dont  seem to work

 [ You are not allowed to view attachments ]

Online wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1793
    • My PWS at Leuven Belgium Europe
Re: wxwinddetail
« Reply #1 on: April 09, 2021, 05:20:55 AM »
hi i just found this nice data summy  ive got it on standalone template but im stuck one where it shude be - but it showing � but i set in the browser
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
but it dont  seem to work

 [ You are not allowed to view attachments ]

AFAIK there are no clairvoyant visitors on this forum  :grin:
These html/character set problems need a link to the website/page with the problem.
Then one can see what is happening inside the html and the exchange between browser and webserver.
F.i. If you put the color table in an iFrame or integrated it in the html itself, default character set a.s.o.

Wim
Support for Leuven-Template & Scripts  at this forum via https://support.leuven-template.eu/
Support for the PWS_Dashboard  pwsdashboard.com

Offline dazza

  • Member
  • *
  • Posts: 43
Re: wxwinddetail
« Reply #2 on: April 09, 2021, 05:53:24 AM »
hi sorry i forgot to put the link in lol
https://www.davisworthing.co.uk/new/wxwinddetail.php

Online wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1793
    • My PWS at Leuven Belgium Europe
Re: wxwinddetail
« Reply #3 on: April 09, 2021, 06:13:37 AM »
hi sorry i forgot to put the link in lol
https://www.davisworthing.co.uk/new/wxwinddetail.php

The data / table in the html already contains those invalid characters.
Probably you copied that table form another page which was not in utf-8.
When you want to do that another time:
Use a decent program editor, new document, set the new document to the original character set (f.i. 8859-1 ).
Copy the data from the original location.
Paste into the new document, change the character set to utf-8, and save.
or
Use your program editor to replace all strange characters  in the current html to a minus sign if that is what is needed.
Attached that part of that table with the - characters.

Wim
Support for Leuven-Template & Scripts  at this forum via https://support.leuven-template.eu/
Support for the PWS_Dashboard  pwsdashboard.com

Offline dazza

  • Member
  • *
  • Posts: 43
Re: wxwinddetail
« Reply #4 on: April 09, 2021, 06:33:32 AM »
No I never copied anything I actually downloaded it from the main person site as a package so I only when from the zip file dint copy anything?

Online wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1793
    • My PWS at Leuven Belgium Europe
Re: wxwinddetail
« Reply #5 on: April 09, 2021, 06:47:54 AM »
No I never copied anything I actually downloaded it from the main person site as a package so I only when from the zip file dint copy anything?
Sorry for my English: what I meant is:
When you download a piece of html or a script from someone else,
You should also check and change its character set to the one you use.

Nowadays most bscripts / widgets a.s.o. are utf-8 but not always.

So when moving it to your site, you need to first "convert" it to the same character set as the page on which you want to use it.
Then you can insert it in the page.

If you insert it without adjusting the character-set it will display those strange characters.

Wim
Support for Leuven-Template & Scripts  at this forum via https://support.leuven-template.eu/
Support for the PWS_Dashboard  pwsdashboard.com

Offline dazza

  • Member
  • *
  • Posts: 43
Re: wxwinddetail
« Reply #6 on: April 09, 2021, 07:07:23 AM »
That ok don't worry um I've never done this before is there like a tool tp do out or a on line conveter?

Online wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1793
    • My PWS at Leuven Belgium Europe
Re: wxwinddetail
« Reply #7 on: April 09, 2021, 07:11:33 AM »
That ok don't worry um I've never done this before is there like a tool tp do out or a on line conveter?

For windows use https://notepad-plus-plus.org/  . Do not use ms-word or notepad.exe as they kill utf-8 scripts.
For mac use https://www.barebones.com/products/bbedit/

The are geared to working with scripts in any programming language or html.

Wim
Support for Leuven-Template & Scripts  at this forum via https://support.leuven-template.eu/
Support for the PWS_Dashboard  pwsdashboard.com

Offline dazza

  • Member
  • *
  • Posts: 43
Re: wxwinddetail
« Reply #8 on: April 09, 2021, 07:14:09 AM »
Thank u I will try that and if it doesn't work I know where to come :grin:

Online wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1793
    • My PWS at Leuven Belgium Europe
Re: wxwinddetail
« Reply #9 on: April 09, 2021, 07:19:21 AM »
Thank u I will try that and if it doesn't work I know where to come :grin:

You're welcome
Support for Leuven-Template & Scripts  at this forum via https://support.leuven-template.eu/
Support for the PWS_Dashboard  pwsdashboard.com

Offline the beteljuice

  • the beteljuice
  • Senior Contributor
  • ****
  • Posts: 292
    • test site
Re: wxwinddetail
« Reply #10 on: April 09, 2021, 10:36:09 AM »
Hi dazza ....

For once i agree that that the source zip, the view=sce and the actual o/p are a little odd.

However; the desired symbol appears to be a slightly elongated dash (ndash) the codes you can use for it are here.
Imagine what you will KNOW tomorrow !