Author Topic: USB WeatherLink - USBXpress Driver  (Read 4928 times)

0 Members and 1 Guest are viewing this topic.

Offline 22Vines

  • Member
  • *
  • Posts: 3
USB WeatherLink - USBXpress Driver
« on: November 11, 2011, 04:11:07 PM »
Hi - trying to reload USB Weatherlink on Windows 7. Worked fine under Vista. Tried to load the 5.9.2 version and have downloaded the 5.9.3 version, neither will recognize the Vue console. Says "no Davis USB device connected. Attach just one Davis USB device and try again". Looking in the Weatherlink program under Directory/Support, I see some USBXpress named files however nothing is loaded in the Windows Device Manager area. Any ideas?  Davis didn't have any drivers to download. Seems they would be part of the updated version 5.9.3.

Thanks for the advice and help.

Offline 4wd

  • Forecaster
  • *****
  • Posts: 378
    • North York Moors weather
Re: USB WeatherLink - USBXpress Driver
« Reply #1 on: November 11, 2011, 04:47:53 PM »
Are you initially installing from a disc, then updating to the latest version?
What you can download won't be the full program, just an update.
Also (important) look in the program files and open your new version not the old one.
It is listed like a separate program.
If you're still opening the older version it might not recognise your station (a Vue?)

Otherwise the best plan might be to uninstall the whole thing and start over with the disc and then the update.
By co-incidence I was trying to do this on an XP netbook yesterday evening and had to start over.
The reason seemed to be that windows was downloading or installing updates in the background (I had just re-installed XP an hour earlier, should have been more patient!)

I discovered you have to open the older version before you can update with the latest download too.

Offline 22Vines

  • Member
  • *
  • Posts: 3
Re: USB WeatherLink - USBXpress Driver
« Reply #2 on: November 11, 2011, 04:58:43 PM »
Hi - Yup intially installed the program from disc, then downloaded update. Even did a uninstall and reinstall. Still not reading the Vue.