Author Topic: Problem with Acknowledgement <ACK>  (Read 563 times)

0 Members and 1 Guest are viewing this topic.

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Problem with Acknowledgement <ACK>
« on: April 18, 2022, 10:09:33 PM »
Situation:  I have a CABLED VP2 (with added UV and Solar sensors) that has been working fine for MANY YEARS.  It has a serial interface with a converter to USB - which has been working fine for many years.  It is connected to a computer running WL 6.0.3 software, that has been working fine for many years.  It uploads to my website http://www.thecoys.net/weather/Current_Vantage_Pro_Plus.htm.  That was OK until suddenly, "Data current at 3:07am 04/11/22 in the Central Time Zone", it stopped uploading. [Station name is ValleyForge]

The HOME station continues to display CURRENT data on 2 connected consoles, so clearly it is getting data.

Looking at the log file, I see repeated:
GetAcknowledge (ValleyForge) response: 0x83 (Should be 0x060)
Unable to upload Data (profile#) because of errors

Sometimes is is:
GetAcknowledge (ValleyForge) response: 0x0E (Should be 0x060
GetAcknowledge (ValleyForge) response: 0x87 (Should be 0x060)

I'm mystified.  What do I need to do to fix this?


Offline waiukuweather

  • Forecaster
  • *****
  • Posts: 1073
Re: Problem with Acknowledgement <ACK>
« Reply #1 on: April 18, 2022, 10:41:40 PM »
some sort of corruption in the data stream
have you tried a complete power down of the console, then remove the data logger for a few minutes...replace..power up console
set to get data. set time correct etc..then try again?

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #2 on: April 19, 2022, 10:13:23 AM »
I tried that, but perhaps I didn't leave the logger disconnected for a long enough time.  I'll try that again later today, and report back.

Offline johnd

  • Forecaster
  • *****
  • Posts: 4330
    • www.weatherstations.co.uk
Re: Problem with Acknowledgement <ACK>
« Reply #3 on: April 19, 2022, 11:17:30 AM »
This is definitely a long shot, but is there any chance that Windows did an auto-update and is no longer 100% compatible with the driver that the serial-to-USB adapter uses, especially if it's an old one? Can you still the virtual comport showing in Windows Device Manager for instance? IS there a newer driver available for the adapter?
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Cambridge UK

Sorry, but I have no time to help with individual issues by email. Please post your issue in the relevant forum section here & I will comment there if I have anything useful to add.

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #4 on: April 19, 2022, 01:48:34 PM »
This is definitely a long shot, but is there any chance that Windows did an auto-update and is no longer 100% compatible with the driver that the serial-to-USB adapter uses, especially if it's an old one? Can you still the virtual comport showing in Windows Device Manager for instance? IS there a newer driver available for the adapter?

I'm rather sure that Windows did not auto-update this computer.  Why?  Because it's running Windows XP, which is no longer supported.  (And the other two applications running are undisturbed)

And if there IS a newer driver available for the adapter, I would be reluctant to update that.

But thanks - this is a really knotty problem.

Offline johnd

  • Forecaster
  • *****
  • Posts: 4330
    • www.weatherstations.co.uk
Re: Problem with Acknowledgement <ACK>
« Reply #5 on: April 19, 2022, 04:40:33 PM »
I always find it difficult t parse some of these WL error messages. What is ValleyForge in this context? Presumably it's the wlk file on the hard drive? Is it possible that the April data file is corrupt and won't accept new data? Can you see any spurious data in Browse? Will it download data into a new station (purely as a test)?
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Cambridge UK

Sorry, but I have no time to help with individual issues by email. Please post your issue in the relevant forum section here & I will comment there if I have anything useful to add.

Offline waiukuweather

  • Forecaster
  • *****
  • Posts: 1073
Re: Problem with Acknowledgement <ACK>
« Reply #6 on: April 19, 2022, 04:46:03 PM »
in my humble opinion, people should not be using windows XP anymore
its used by hackers to launch DOS attacks etc

Offline waiukuweather

  • Forecaster
  • *****
  • Posts: 1073
Re: Problem with Acknowledgement <ACK>
« Reply #7 on: April 19, 2022, 05:16:22 PM »
i have had reports of Davis data loggers that just stop working correctly
and a replacement is needed
(this is with 20 years of experience behind me)
(maybe caused by a power surge)

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #8 on: April 19, 2022, 09:53:40 PM »
I tried that, but perhaps I didn't leave the logger disconnected for a long enough time.  I'll try that again later today, and report back.

Powered down completely, then disconnected logger  After over 1/2 hour, re-powered and then connected logger.

No apparent change.  Tomorrow I'll reboot the computer to see if that behavior has changed.
 

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #9 on: April 19, 2022, 09:54:27 PM »
in my humble opinion, people should not be using windows XP anymore
its used by hackers to launch DOS attacks etc

<ACK>

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 8619
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Problem with Acknowledgement <ACK>
« Reply #10 on: April 19, 2022, 11:41:54 PM »
I'd cast a suspicious eye to the serial-to-USB converter.  I've had one of those go wonky on me and had to replace it.  Since it's in the data path, double check the virtual COM port settings to match what the station logger is set to provide.  A new DB9-Serial-to-USB port adapter is cheap and a easy test that may resolve the issue fully.

BTW.. emails from wxforum.net are bouncing to your email address used in the forum (which is bouncing as it forwards to your gmail address).

« Last Edit: April 19, 2022, 11:44:47 PM by saratogaWX »
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline mcrossley

  • Forecaster
  • *****
  • Posts: 918
    • Wilmslow Astro
Re: Problem with Acknowledgement <ACK>
« Reply #11 on: April 20, 2022, 08:17:09 AM »
I would connect a terminal emulator to the serial port and try some simple commands and see what you get back.

Send a couple of <enter> first to wake the console up.

Then try sending "TEST" (no quotes) and you should get a response of TEST.

A command of VER should return your console firmware version.
Mark

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #12 on: April 20, 2022, 10:36:10 AM »
I'd cast a suspicious eye to the serial-to-USB converter.  I've had one of those go wonky on me and had to replace it.  Since it's in the data path, double check the virtual COM port settings to match what the station logger is set to provide.  A new DB9-Serial-to-USB port adapter is cheap and a easy test that may resolve the issue fully.

Yes, I just ordered one as the next thing to try.

BTW.. emails from wxforum.net are bouncing to your email address used in the forum (which is bouncing as it forwards to your gmail address).

Hmmmm.

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #13 on: April 21, 2022, 10:47:41 PM »
Oops - ordered the wrong adapter (wrong gender of DB9).  Trying again - Saturday delivery.

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #14 on: April 25, 2022, 10:52:42 PM »
Installed new adapter, and it works - and the same symptoms.

Testing the port says "Found a station" Vantage Pro.

Looking at the log file, I see repeated:
GetAcknowledge (ValleyForge) response: 0x83 (Should be 0x060)

Requesting a download of the station says:
"Station model number was not recognized.  The program expects a different station model.  The program will not operate with this station"

I have tried setup with Vantage Pro 2 and Vantage Pro Plus, with the same result.

I'm guessing the next troubleshooting step would be to try a new VP2 serial logger.  But I don't know where to get one.  Remember, this is a very old station (well before green dot).

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #15 on: May 22, 2022, 10:33:05 AM »
A new Serial Logger has apparently fixed this strange problem.

Offline waiukuweather

  • Forecaster
  • *****
  • Posts: 1073
Re: Problem with Acknowledgement <ACK>
« Reply #16 on: May 22, 2022, 03:56:52 PM »
I hate to say, what did I say, but this is not the first time this has happened, where a replacement data logger is the only solution

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6442
    • Lee's Summit, MO
Re: Problem with Acknowledgement <ACK>
« Reply #17 on: May 22, 2022, 04:08:54 PM »
I hate to say, what did I say, but this is not the first time this has happened, where a replacement data logger is the only solution

Yes, you did say that.  It was just prudent to check a bunch of other possibilities first.  Logger was an expensive solution.  (And then a poor distributor "sold" me one, but didn't actually have it available).