Author Topic: Unable to add additional graphs to Belchertown skin  (Read 320 times)

0 Members and 1 Guest are viewing this topic.

Offline yojuan

  • Member
  • *
  • Posts: 3
Unable to add additional graphs to Belchertown skin
« on: March 29, 2022, 12:11:09 PM »
New member but long time "observer" here!

As background, I built a DIY weather station (because why buy when you can build something for twice the price that's half as good?). Station and base units run on ESP32s, base sends MQTT messages every 20s to a Mosquitto instance running on a local Docker host. Using the MQTTSubscribe driver to feed WeeWx 4.6.2 also running on same Docker host. I'm a career software guy, so I'm comfortable with fairly complicated setups like this. The station works flawlessly, until I start messing with it that is.

Here's my issue: I use the Belchertown skin v1.2 on WeeWx and I'm trying to add graphs to the Homepage to track station voltage vs illuminance. My install didn't have a graphs.conf, so I copied graphs.conf.example from the github repo. I added the two graphs to my public_html/belchertown/graphs.conf under [homepage], but the graphs don't show up. I've restarted WeeWx etc, but it's almost like the new graphs.conf isn't picked up at all. Somewhat stumped right now, any suggestions?

Code: [Select]
    [[chart5]]
        title = Ambient Light
        type = spline
        [[[luminosity]]]
            color = "#BECC00"
            yAxis_tickinterval = 100.0

    [[chart6]]
        title = Station Battery
        type = spline
        [[[consBatteryVoltage]]]
            color = "#BECC00"
            yAxis_tickinterval = 0.1

Offline jim2905

  • Member
  • *
  • Posts: 1
Re: Unable to add additional graphs to Belchertown skin
« Reply #1 on: March 29, 2022, 08:40:55 PM »
Hi yojuan,

   I added a couple graphs to my Belchertown skin.  I just modified the graphs.conf.example in the /home/weewx/skins/Belchertown directory and restarted weewx.  I'm running a similar setup.

 [[chart5]]
        title = Radiation and UV Index
        [[[radiation]]]
            name = Radiation
            zIndex = 1
            color = "#ffc83f"
        [[[maxSolarRad]]]
            name = Theoretical Max Solar Radiation
            type = area
            color = "#f7f2b4"
            yAxis_label = "W/m2"
        [[[UV]]]
            yAxis = 1
            yaxis_min = 0
            yaxis_max = 14
        color = "#90ed7d"
        y_label = "UV"
        name = UV Index
        zIndex = 2

 [[chart6]]
        title = Wind Rose
        [[[windRose]]]
            beauford0 = "#1278c8"
            beauford1 = "#1fafdd"
            beauford2 = "#71bc3c"
            beauford3 = "#ffae00"
            beauford4 = "#ff7f00"
            beauford5 = "#ff4500"
            beauford6 = "#9f00c5"

    [[chart7]]
        title = Wind Speed Today
        time_length = today
        [[[haysChart]]]
             color = "#ff4500"
             yAxis_softMax = 25



Offline yojuan

  • Member
  • *
  • Posts: 3
Re: Unable to add additional graphs to Belchertown skin
« Reply #2 on: March 29, 2022, 09:43:49 PM »
Thanks, that's pretty much what I did, not sure what I'm doing wrong

Offline yojuan

  • Member
  • *
  • Posts: 3
Re: Unable to add additional graphs to Belchertown skin
« Reply #3 on: March 29, 2022, 09:47:02 PM »
Actually you just found the problem - I inadvertently copied the graphs.conf into my public_html/belchertown folder! Thanks for the help.