Author Topic: MRMS display issue - fixed, I think...  (Read 255 times)

0 Members and 1 Guest are viewing this topic.

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3882
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
MRMS display issue - fixed, I think...
« on: March 11, 2022, 04:47:24 PM »
I was recently getting strange behavior on the displayed weather radar (MRMS) Radar Site

The "Product Type" fields were blank and there was no current radar depicted on the map.

After some experimentation, I discovered that the
Code: [Select]
web_exec_mode=run&menu=menu_config.txt reference was the problem. I removed it (and discovered a missing ";" afterwards) and the depiction is now correct. (the missing ";" was causing the map to land in the center of the USA instead of where I wanted it)

My flyout-menu.xml line now looks like this:

Code: [Select]
<item caption="MRMS Radar" link="https://mrms.nssl.noaa.gov/qvs/product_viewer/index.php?&amp;amp;zoom=6&amp;amp;time_mode=update&amp;amp;clon=-84.365966796875&amp;amp;clat=45.100228796610224&amp;amp;base=0&amp;amp;overlays=1&amp;amp;mping_mode=0&amp;amp;product_type=crefls&amp;amp;product=CREF&amp;amp;qpe_pal_option=0&amp;amp;opacity=1&amp;amp;looping_active=off&amp;amp;num_frames=6&amp;amp;frame_step=200&amp;amp;seconds_step=600" target="_blank"/>
Not sure why it seemed to work originally with the missing semicolon issue. For reference, I originally had a problem and had to use HTML escape sequences in lieu of the "&" in the original URL. (Thanks to Ken for that fix).

Yes, I noticed that it was supposed to be MRMS, not MMRS. I fixed that in my flyout menu.

Greg H.






Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF