Author Topic: Uploading to Windy.com  (Read 324 times)

0 Members and 1 Guest are viewing this topic.

Offline rcnz

  • Member
  • *
  • Posts: 22
Uploading to Windy.com
« on: November 13, 2021, 07:12:43 PM »
Yesterday, I moved my VP2 Pro elsewhere in the house. I was trying to move from my WiFiLogger to the Meteo-Pi connection.

Couldn’t get the M-P going, so reverted to WiFiLogger.

In the process, my Data Export page needed fresh info for all the upload destinations. All but one now running fine.

Only Windy gave an “error”: see image.

The station is registered with Windy:

ID: f07ff447

Station ID: 0

Latitude: -36.81255341489234°

Longitude: 174.707288146019°

Elevation: 73 m

Any help most welcome!

Thanks
Davis Vantage Pro 2
WeeWX 4.7.0 | Meteo-Pi Ethernet Logger
AWEKAS
CWOP
PWS Weather
WeatherCloud*
Windy
WL
WU
* = awaiting fix

https://www.wunderground.com/dashboard/pws/IAUCKLAN159

Offline Brandy99

  • Baby weather nerd 🤓 WS-2000 🌬
  • Member
  • *
  • Posts: 9
Re: Uploading to Windy.com
« Reply #1 on: November 13, 2021, 08:13:39 PM »
Ok - hit me over the head, but asking I hope a helpful tech question. Did you copy and paste the key, or hand type it? 
If the first, after c/p, put your cursor into the key before first letter - hit the back key twice. That eliminates invisible coding you accidentally grabbed.
Then put your cursor at the end and hit the back key until you only erase the last char, and re-enter the last char. If any back data crawled into your paste, this will resolve without hand entering - it will correct the error.  This honestly applies to any c/p to any field. Some systems have coding to remove it and convert to char. Some do not.

Was the station removed, or did you simply stop sending data?  Is there a chance you’re sending duplicate?  Suggestion: try sending a much smaller upload.  It could be a time out behind the scenes.
WS-2000 🌬 station
KARPARIS7 on Ambient and WUnderground
GW0763 on NOAA CWOP
2-WH31E 🌡
PM25IN and PM25 AQ🍃
WH 31L⚡️
Already got my eyes on my next rig, WS5000

Offline mcrossley

  • Forecaster
  • *****
  • Posts: 911
    • Wilmslow Astro
Re: Uploading to Windy.com
« Reply #2 on: November 14, 2021, 05:43:36 AM »
Shouldn't the station id normally be "0", it is an index into the number of stations you have configured under your user?
That is my understanding of the protocol, not Meteo-Pi btw!
Mark

Offline rcnz

  • Member
  • *
  • Posts: 22
Re: Uploading to Windy.com
« Reply #3 on: November 14, 2021, 08:51:08 PM »
Thanks, both!

Each of you supplied a part of the fix.

 [tup]
Davis Vantage Pro 2
WeeWX 4.7.0 | Meteo-Pi Ethernet Logger
AWEKAS
CWOP
PWS Weather
WeatherCloud*
Windy
WL
WU
* = awaiting fix

https://www.wunderground.com/dashboard/pws/IAUCKLAN159