Author Topic: GW1000 Ver 1.7.3 - can't change rain gain value  (Read 286 times)

0 Members and 1 Guest are viewing this topic.

Offline Autofill

  • Senior Contributor
  • ****
  • Posts: 218
GW1000 Ver 1.7.3 - can't change rain gain value
« on: May 28, 2022, 12:20:15 AM »
Hi,

got a weird problem here. Today I decided to change the rain gain value on my WS69/GW1000 from 1.0 to 0.847 (for some testing purposes, thanks to @giusCB). Changed the value via the WSView Plus app, saved, said sucess.

Then rain came, and I noticed there was no rain reported.

Went back to the gain settings and its shown as 0.01 now.

No matter what I do, I cannot change this number back to any number, its stuck as 0.01. I press save everytime and the green "sucess" shows up everytime, but number does not change.

Any idea why and how? thanks for your time
Ecowitt WH2320-E
Ecowitt HP2551-C
Ecowitt GW1000
Ecowitt GW1100
Ecowitt WH69E
Ecowitt WH32B
Ecowitt WH57 (x3)
Ecowitt WH51 (x6)
Ecowitt WH41
Ecowitt WH41 (Honeywell-based USB/Supercap modified)
Ecowitt WH31 (x8)
Ecowitt WH55 (x4)
Ecowitt WH45
Ecowitt WN34S (x2)
Ecowitt WN35
Ecowitt Wittboy running on 12VDC  solar power

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 1641
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #1 on: May 28, 2022, 05:48:03 AM »
...
No matter what I do,
...
means what ??

- did you select "traditional rain gauge" ? - if you have "piezo" chosen, you cannot change anything (unless you have a WS90 connected)
- did you do a reset in the "rain total" page ? (note down your calibration values before !)
- did you reboot the GW1000 ?
- did you do factory reset if the reboot didn't change anything
WS2350 1.6.4, GW1000(3) 1.7.4, WH2650 WiFi (2) 1.7.4 (test/backup), GW1100 2.1.4, GW2000(3) 2.1.5, HP2551 1.6.4/1.8.0;
Ecowitt WS90(2), WS80, WH40, WH65, WH31(5), WH31-EP, WN30, WH32, WH32-EP, WH32B, WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 (5), WH45, WH55 (2)
MeteobridgePro(2)[test,prod 5.4 Jun 11 2022, 14754 - Blake-Larsen Sun Recorder - RPi4/weewx 4.8.0/CumulusMX 3190/MB RPi4(2671)
Barani Meteoshield Pro, MetSpec Rad02 - Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553), http://meshka.eu

Offline Autofill

  • Senior Contributor
  • ****
  • Posts: 218
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #2 on: May 28, 2022, 11:38:29 AM »
Thanks Gyvante!

Yes according to your list I did everything but the factory reset.

Before I actually do a factory reset (which is a bit of a pain) I just wanted to confirm if this was an issue with my device or perhaps a firmware bug (1.7.3). The reason why I bring this up is that I can change all the other values such as rainfall totals, and those save but for some reason the rain gain always goes back to the 0.01.
Ecowitt WH2320-E
Ecowitt HP2551-C
Ecowitt GW1000
Ecowitt GW1100
Ecowitt WH69E
Ecowitt WH32B
Ecowitt WH57 (x3)
Ecowitt WH51 (x6)
Ecowitt WH41
Ecowitt WH41 (Honeywell-based USB/Supercap modified)
Ecowitt WH31 (x8)
Ecowitt WH55 (x4)
Ecowitt WH45
Ecowitt WN34S (x2)
Ecowitt WN35
Ecowitt Wittboy running on 12VDC  solar power

Offline Rover1822

  • Forecaster
  • *****
  • Posts: 1122
    • Mini Wind and Solar Data project
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #3 on: May 28, 2022, 11:41:54 AM »
Rather than going to a decimal value, have you tried just "1" ?
Ambient:
  WS-2000
  PM 2.5(2)
  WH31B(2)
  WH40E
  WH31P
EcoWitt:
  GW1100
  GW1000(4)
  WH31(2)
  WH57
  WH51(12),
  WH40
  WH5360B
  WN34S
  WittBoy Ws90 + GW2000
Personal Sites: Weather Cam

Offline Autofill

  • Senior Contributor
  • ****
  • Posts: 218
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #4 on: May 28, 2022, 11:56:05 AM »
Just tried 1, then 10, 1000... does the same thing. I press save, it says success in green, value appears to be updated, go back to the main screen then go back to the rain total screen in the value is back to 0.01.

Can anybody else try this on their gw1000? Be warned that if it is a firmware wide issue that you won't be able to change  it back, unless a Factory reset fixes the problem. Which is going to be my next step.
Ecowitt WH2320-E
Ecowitt HP2551-C
Ecowitt GW1000
Ecowitt GW1100
Ecowitt WH69E
Ecowitt WH32B
Ecowitt WH57 (x3)
Ecowitt WH51 (x6)
Ecowitt WH41
Ecowitt WH41 (Honeywell-based USB/Supercap modified)
Ecowitt WH31 (x8)
Ecowitt WH55 (x4)
Ecowitt WH45
Ecowitt WN34S (x2)
Ecowitt WN35
Ecowitt Wittboy running on 12VDC  solar power

Offline Rover1822

  • Forecaster
  • *****
  • Posts: 1122
    • Mini Wind and Solar Data project
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #5 on: May 28, 2022, 12:35:34 PM »
I did this yesterday, same firmware, no prob.

see post https://www.wxforum.net/index.php?topic=43953.0
Ambient:
  WS-2000
  PM 2.5(2)
  WH31B(2)
  WH40E
  WH31P
EcoWitt:
  GW1100
  GW1000(4)
  WH31(2)
  WH57
  WH51(12),
  WH40
  WH5360B
  WN34S
  WittBoy Ws90 + GW2000
Personal Sites: Weather Cam

Offline Autofill

  • Senior Contributor
  • ****
  • Posts: 218
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #6 on: May 28, 2022, 03:38:28 PM »
Thanks all for your replies! Here's an update

I resorted to performing a factory reset. However, despite the rain gain being set to 1 after the factor resest, the moment I started change my values the problem returned, the value changed back to 0.01.

At this point I suspected the app was the issue, so I deleted the cache and storage files and uninstalled WSView Plus and then resinstalled it....tried it again and same issue!

When I reinstalled WSView Plus I noitced the older WSView app was still avaiable, so I downloaded that app. Would you believe me that everything works exactly as it should with the older WSVeiw app?

I changed all my settings in the older WSView app and then opened my WSView Plus app and the settings are all correct now.

Lesson learned. Use the older WSView app to change the settings, at least for me.

Could be a bug in the WSView Plus app for Android 10.

Ecowitt WH2320-E
Ecowitt HP2551-C
Ecowitt GW1000
Ecowitt GW1100
Ecowitt WH69E
Ecowitt WH32B
Ecowitt WH57 (x3)
Ecowitt WH51 (x6)
Ecowitt WH41
Ecowitt WH41 (Honeywell-based USB/Supercap modified)
Ecowitt WH31 (x8)
Ecowitt WH55 (x4)
Ecowitt WH45
Ecowitt WN34S (x2)
Ecowitt WN35
Ecowitt Wittboy running on 12VDC  solar power

Offline Gyvate

  • Forecaster
  • *****
  • Posts: 1641
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #7 on: May 28, 2022, 04:09:32 PM »
it works with me in the WS View Plus app V. 2.0.31 - with all my GWs (2000, 1100 and 1000).
It was still an issue in 1.7.0/WS View V 2.0.29 - from 1.7.1 to 1.7.2 also the WS View Plus had to be updated to V. 2.0.31 for the WS90 to calibrate properly in a WH2650.
Pretty odd. But as I said before - ever since 1.7.2 it all works fine with my GW1000/WH2650 and WS View Plus 2.0.31
I suspect it is rather a WS View Plus bug than a GW1000 FW bug - but you never know.
Did you try with another smartphone ?

The old WS View app doesn't have these piezo/traditional options - maybe that's why it worked as you went for the gain value only.

By the way - in the HP2550 console you cannot enter anything (yet) for the rain gain when piezo is chosen as preferred sensor.
Probably 1.8.1 will be handling this - at least Ecowitt support said so.
« Last Edit: May 28, 2022, 04:13:21 PM by Gyvate »
WS2350 1.6.4, GW1000(3) 1.7.4, WH2650 WiFi (2) 1.7.4 (test/backup), GW1100 2.1.4, GW2000(3) 2.1.5, HP2551 1.6.4/1.8.0;
Ecowitt WS90(2), WS80, WH40, WH65, WH31(5), WH31-EP, WN30, WH32, WH32-EP, WH32B, WH57 [Lightning] (1), WH41 [PM2.5] (2), WH51 (5), WH45, WH55 (2)
MeteobridgePro(2)[test,prod 5.4 Jun 11 2022, 14754 - Blake-Larsen Sun Recorder - RPi4/weewx 4.8.0/CumulusMX 3190/MB RPi4(2671)
Barani Meteoshield Pro, MetSpec Rad02 - Ecowitt 5763,34418;WU ISAARB3(WH4000SE), ISAARB22(HP2553), http://meshka.eu

Offline Rover1822

  • Forecaster
  • *****
  • Posts: 1122
    • Mini Wind and Solar Data project
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #8 on: May 28, 2022, 04:29:22 PM »
The issue I had with my GW1000, with the gain reset to 0.01 , only happened on one of the 3 I have at the house. Do I have I an explanation , Nope. Do I have anything to help the OP, not really. But since I have seen the changed setting, I'm not going to discount him or his efforts, as I can't explain mine. It is possible , some variable, something, prevented the change, we can only guess. i did use WSView + to fix mine. But, quite sure we can't assume his settings or whatever are the same as everyone's, and vice versa. As they become more complex, yeah, stuff like this can happen, without it being operator error (I know i love to use operator error).
Ambient:
  WS-2000
  PM 2.5(2)
  WH31B(2)
  WH40E
  WH31P
EcoWitt:
  GW1100
  GW1000(4)
  WH31(2)
  WH57
  WH51(12),
  WH40
  WH5360B
  WN34S
  WittBoy Ws90 + GW2000
Personal Sites: Weather Cam

Offline Autofill

  • Senior Contributor
  • ****
  • Posts: 218
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #9 on: May 28, 2022, 04:51:37 PM »
Thanks Gyvante and Rover.

I'll bring this up with Ecowitt, I think and see what they say. I would like to correct that my phone is acutually Android 9 and not Android 10. I have not tried with another smartphone yet, but can do so in a bit.

I'm definitly not immune to user errors but this is a pretty straightforward task, especially considering I sucessfully modified other entries with the other devices. Here's a video of what is happening on my alias youtube channel.

https://youtu.be/z2c5gick7ok

I'll report to Ecowitt and see what they say.



Ecowitt WH2320-E
Ecowitt HP2551-C
Ecowitt GW1000
Ecowitt GW1100
Ecowitt WH69E
Ecowitt WH32B
Ecowitt WH57 (x3)
Ecowitt WH51 (x6)
Ecowitt WH41
Ecowitt WH41 (Honeywell-based USB/Supercap modified)
Ecowitt WH31 (x8)
Ecowitt WH55 (x4)
Ecowitt WH45
Ecowitt WN34S (x2)
Ecowitt WN35
Ecowitt Wittboy running on 12VDC  solar power

Offline AntHraX

  • Member
  • *
  • Posts: 5
Re: GW1000 Ver 1.7.3 - can't change rain gain value
« Reply #10 on: May 28, 2022, 06:48:48 PM »
hi, i have the same issue with a gw1000 and wsview plus.   ](*,)
to fix the problem i have had to use the old wsview app. [tup]
this seems to be a wsview plus bug.  :?:

cheers.