Author Topic: wxStory 3.0  (Read 1789 times)

Jasiu and 6 Guests are viewing this topic.

Offline sacreyweather

  • Forecaster
  • *****
  • Posts: 1819
    • Maumelle Weather
Re: wxStory 3.0
« Reply #50 on: Today at 11:31:51 AM »
527 files cleared from cache.  Issue persists.
wsdata_bis.php, wsdata_grr.php showed up after I tested the page.  Plus a couple of matching wsimg files.

Hi 92merc,

I can see the images for Bismarck at this time on your webpage. You may want to try clearing your browser cache and see if that resolves the issue.

Hope this helps,

John
GR2AE, GR3, Cumulus

Offline 92merc

  • BismarckWeather.net
  • Forecaster
  • *****
  • Posts: 1115
  • BismarckWeather.net
    • BismarckWeather.net
Re: wxStory 3.0
« Reply #51 on: Today at 12:03:38 PM »
Looks to be a Firefox issue.  New FF 102 doesn't like it.  Chrome and Edge are fine.
https://www.BismarckWeather.net
Davis VP2, Cumulus, WeatherDisplay, Blitzortung, Saratoga Scripts, NOAA Stream via PI

Offline jmcmurry

  • Jim McMurry
  • Forecaster
  • *****
  • Posts: 522
  • Davis Vantage Pro 2 Plus Wireless.
    • Juneau County Weather
Re: wxStory 3.0
« Reply #52 on: Today at 12:44:34 PM »
Same here, bad in FF but OK in Chrome.  Maybe there's a FF expert out there that can point us to something in about:config that may have changed.

But why is it picking on Bismarck?
« Last Edit: Today at 12:51:05 PM by jmcmurry »

Forum Search and Google Can be Your Best Friends

Offline jmcmurry

  • Jim McMurry
  • Forecaster
  • *****
  • Posts: 522
  • Davis Vantage Pro 2 Plus Wireless.
    • Juneau County Weather
Re: wxStory 3.0
« Reply #53 on: Today at 07:06:07 PM »
hunter362, lets try this:

In your script settings change to $ws_mapfolder   = './images2/ then create that folder on the server and put WS_map.png in it.  That way we've got everything "fresh".  We can write our story images to wscache so there should be no reason that we can't write to this folder.

- Jim
« Last Edit: Today at 07:12:30 PM by jmcmurry »

Forum Search and Google Can be Your Best Friends

Online Jasiu

  • Forecaster
  • *****
  • Posts: 872
    • LexMAWeather
Re: wxStory 3.0
« Reply #54 on: Today at 08:46:35 PM »
Looks to be a Firefox issue.  New FF 102 doesn't like it.  Chrome and Edge are fine.

Yup, I just updated FF on my MacBook and now I see the problem.

Below are what I get if I inspect the image in Safari and then in Firefox.

 [ You are not allowed to view attachments ]  [ You are not allowed to view attachments ]

So for some reason firefox thinks it can't load it. I'll see if I can figure out anything.
« Last Edit: Today at 08:48:25 PM by Jasiu »

Online Jasiu

  • Forecaster
  • *****
  • Posts: 872
    • LexMAWeather
Re: wxStory 3.0
« Reply #55 on: Today at 08:56:22 PM »
This may have something to do with it...

The file on the NWS site is:

  Tab2FileL.png?020f87cf059e08a23be281de8ae0790c

Somehow that gets transformed into wsimg_bis_Tab2FileL.png-6ce9d44e0ebc8de245e961dc1b8.e3b as the file name loaded into the cache. Firefox is probably barfing at the ".e3b" suffix.  If I try to load

  https://www.bismarckweather.net/wscache/wsimg_bis_Tab2FileL.png-6ce9d44e0ebc8de245e961dc1b8.e3b

I get this error:

Quote
Content Encoding Error

An error occurred during a connection to www.bismarckweather.net.

    Please contact the website owners to inform them of this problem.

I don't use this script but I'll download it to see why/how the parameter after the "?" in the URL is handled.


Offline jmcmurry

  • Jim McMurry
  • Forecaster
  • *****
  • Posts: 522
  • Davis Vantage Pro 2 Plus Wireless.
    • Juneau County Weather
Re: wxStory 3.0
« Reply #56 on: Today at 09:44:37 PM »
It's a cache somewhere that needed to expire.  Bismarck now works fine for me on both my servers with FF.   ](*,)


Forum Search and Google Can be Your Best Friends