Author Topic: No GPS after ST-Link Utility Flash to Firmware 6.3  (Read 809 times)

0 Members and 1 Guest are viewing this topic.

Offline gwwilk

  • Southeast Lincoln Weather
  • Forecaster
  • *****
  • Posts: 2552
    • SouthEast Lincoln, NE Weather
No GPS after ST-Link Utility Flash to Firmware 6.3
« on: January 21, 2014, 03:49:41 PM »
Just in case anybody else tries to do this in relative darkness, I removed my ST-Module from the controller board in order to attach it to my computer via USB port.  After successfully flashing it to firmware 6.3 I reattached the module to the controller board and was confronted with all sorts of weirdness including a suddenly absent GPS signal (my onboard GPS has never worked, but the external had worked just fine.)  No amount of booting, etc. worked.  I even removed the ST-Module again and reattached it...I THOUGHT! ](*,)

I finally disassembled the controller board from its case and discovered that I hadn't actually firmly seated the ST-Module on the controller board while working in the relative darkness of my loft last evening! Voila, a GPS signal is again found.  Now if I could only figure out how to easily achieve a proper ground of the controller from the loft. :-(
Regards, Jerry Wilkins