Author Topic: Microsoft DNS Upload issues Apr 2020  (Read 747 times)

0 Members and 1 Guest are viewing this topic.

Offline tsink

  • Member
  • *
  • Posts: 8
    • Meso West FW6615
Microsoft DNS Upload issues Apr 2020
« on: April 09, 2020, 05:39:51 PM »
I anyone else having issues after Microsoft fubarred their DNS a few days ago? I noticed my uploads were not going through at all. So, I had to to repoint my DNS to Google's 8.8.8.8  things started to work..seemingly. I thought this resolved the upload issue but every time an upload would occur it would upload 513 files. This was yesterday. today uploads are still occurring but each time it will upload all 513 files.....any suggestions?

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 8434
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Microsoft DNS Upload issues Apr 2020
« Reply #1 on: April 09, 2020, 06:23:01 PM »
I'm a bit confused.  The home DNS setting (from Microsoft DNS to Google DNS) would only change what IP address was returned when your upload host name was queried -- the upload program determines which files to upload, with the 'where' determined by the DNS lookup.

So, to help, I'll need a bit more info.  What host are you uploading to?  What weather software program are you using?
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline Mattk

  • Forecaster
  • *****
  • Posts: 1629
Re: Microsoft DNS Upload issues Apr 2020
« Reply #2 on: April 09, 2020, 06:48:57 PM »
Yes what station, what logger, uploading to where?

Offline tsink

  • Member
  • *
  • Posts: 8
    • Meso West FW6615
Re: Microsoft DNS Upload issues Apr 2020
« Reply #3 on: April 09, 2020, 07:08:46 PM »
I normally do not use a specific DNS server. I let my internet provider resolve the web addresses. that is up until 2 days ago. at that point I could not type in a web address and have it go through. I kept getting "site is unavailable". Once I went in and told my  computer to use the Google DNS server 8.8.8.8 then when I typed in the web address name the site would come up.

This is when I noticed that my weather system had been downloading the files to my computer  but was failing to upload them to the places it would automatically.  I'm using Weatherlink 6.0.5 and upload to
https://www.weatherlink.com/bulletin/459c482c-99aa-4772-bfc1-72ff12316893
https://www.wunderground.com/dashboard/pws/KPAROME9
http://www.findu.com/cgi-bin/wxpage.cgi?call=fw6615&tz=0&last=72
https://mesowest.utah.edu/cgi-bin/droman/meso_base_dyn.cgi?stn=F6615

I have it set to a 5 minute download and every time it cycles it will download 513 files from the station to the computer then try push same that amount to the other websites

Personal Weather Station IDKPAROME9  or  FW6615
https://www.wunderground.com/dashboard/pws/KPAROME9

Offline galfert

  • Global Moderator
  • Forecaster
  • *****
  • Posts: 6822
Re: Microsoft DNS Upload issues Apr 2020
« Reply #4 on: April 09, 2020, 07:25:17 PM »
Your default DNS servers are not from Microsoft, they get assigned by your ISP and they belong to your ISP. It is common knowledge that ISP DNS servers are less reliable and they are slower.
Ecowitt GW1000 | Meteobridge on Raspberry Pi
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline tsink

  • Member
  • *
  • Posts: 8
    • Meso West FW6615
Re: Microsoft DNS Upload issues Apr 2020
« Reply #5 on: April 09, 2020, 07:32:54 PM »
not that common as it's new to me. But I'm not an IT person. Anyways, is the pointing to the Google DNS OK? & then what is going on with the uploads? Do you have an idea to help?

Offline galfert

  • Global Moderator
  • Forecaster
  • *****
  • Posts: 6822
Re: Microsoft DNS Upload issues Apr 2020
« Reply #6 on: April 09, 2020, 09:29:03 PM »
Well that didn't come out right. I meant that it was common knowledge among techies...as I was trying to say that changing away from ISP DNS is a very common thing to do among techies.

Yes I use Google DNS also (8.8.8.8 and 8.8.4.4). There are also some other DNS that are equally favored by techies...like Cloudflare 1.1.1.1 and 1.0.0.1. And there are even others. But I'd say those are the two most popular. Google was first to address the crappy ISP DNS issue and came before Cloudflare's offering.

I'm noticing that even with Google DNS that the Internet is not what it used to since this whole Covid-19 issue started with the stay at home and Internet usage has skyrocketed. Changing DNS from the ISP DNS always helps. The fact that you noticed an improvement is proof right there.
Ecowitt GW1000 | Meteobridge on Raspberry Pi
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 8434
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Microsoft DNS Upload issues Apr 2020
« Reply #7 on: April 10, 2020, 11:25:41 AM »
Thanks for the extra information, tsink.  Here is what I understand from your descriptions above:

1) There was an issue with the default DNS servers your ISP gave your router, and you solved that by using Google's 8.8.8.8 DNS server instead.  That allowed you to have website access again.
2) You're using WeatherLink 6.0.5 software, and it appears to be loading a full archive 512 records from your Davis station every time an update cycle starts.
3) You are submitting your weather data to WeatherLink.com, Wunderground.com and CWOP sites.  (The mesowest site actually gets your data from the CWOP/findu site). 

I don't know, based on your description, if you are just uploading to WeatherLink network and having them pass the data to Wunderground and CWOP or if you've set WeatherLink software to do those uploads separately.

So now that your DNS issue seems to be solved, is your remaining issue about WeatherLink software downloading the full archive from your stations logger at each update cycle?
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline tsink

  • Member
  • *
  • Posts: 8
    • Meso West FW6615
Re: Microsoft DNS Upload issues Apr 2020
« Reply #8 on: April 10, 2020, 12:02:20 PM »
I upload to Weatherlink and they pass the data. Correct! The remaining issue is the excessive uploading of the 513 files....thanks for your help!

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 8434
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Microsoft DNS Upload issues Apr 2020
« Reply #9 on: April 10, 2020, 01:03:38 PM »
Ok, by 'files', do you mean the dialog box in WeatherLink 6.0.5 that pops up saying 'Downloading Data from Station' and it there indicates 512 'files' downloaded?

A couple more questions:
1) What OS is WeatherLink software running on?  (Windows version? Mac version?)
2) Is the interface from the OS to the weather station using Serial, USB or WeatherLinkIP
3) Are you using a WeatherLink logger in the console?
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline vreihen

  • El Niņo chaser
  • Forecaster
  • *****
  • Posts: 1158
  • K2BIG
Re: Microsoft DNS Upload issues Apr 2020
« Reply #10 on: April 10, 2020, 01:21:03 PM »
Would this thread be better served in the Davis section, since it is obviously not a forum bug?????
WU Gold Stars for everyone! :lol:

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 8434
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Microsoft DNS Upload issues Apr 2020
« Reply #11 on: April 10, 2020, 01:24:27 PM »
Yes.. Thanks, I've moved it to the WeatherLink section  #-o  :oops:
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline tsink

  • Member
  • *
  • Posts: 8
    • Meso West FW6615
Re: Microsoft DNS Upload issues Apr 2020
« Reply #12 on: April 10, 2020, 03:43:25 PM »
HI, I'm using a VantageVUE weather unit with USB Data Logger E18030P88 on a PC using Microsoft 2007. It has been funcitioning correctly from Jan 2020 until a few days ago.

Offline johnd

  • Forecaster
  • *****
  • Posts: 4230
    • www.weatherstations.co.uk
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Cambridge UK

Sorry, but I have no time to help with individual issues by email. Please post your issue in the relevant forum section here & I will comment there if I have anything useful to add.

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 8434
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Microsoft DNS Upload issues Apr 2020
« Reply #14 on: April 10, 2020, 05:00:48 PM »
Also make sure that your PCs time and the console time are the same (or within a couple of minutes).

Did you do any updates to your PC a few days ago?
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline tsink

  • Member
  • *
  • Posts: 8
    • Meso West FW6615
Re: Microsoft DNS Upload issues Apr 2020
« Reply #15 on: April 10, 2020, 05:17:05 PM »
THANKS! That worked! somehow a bad file dated 7/0/2020 was in there with some very bad data. I deleted it, rebooted the Vantage VUE console and wala...thank you!