Author Topic: 1wire hobbyboards communications issues  (Read 1137 times)

0 Members and 1 Guest are viewing this topic.

Offline david s

  • Member
  • *
  • Posts: 3
1wire hobbyboards communications issues
« on: October 31, 2014, 12:24:16 AM »
Having problems getting my 1 wire system back up and working on a new PC.
Latest onewire software from Maximim and java installed on Windows 7 32 and 64 bit machines. Also tried on a 64bit Vista machine.

Connect the blue USB dongle DS9490 and load onewireviewer. Shows up as one device DS1990A in the device list. Think it has always done this.
Connect another hobbyboards device such as the lightning detector and the DS9490 device disappears and no devices are listed. I've been playing with the lightning as it's not bus powered from memory, but a few other devices I have also have the problem however I'm unsure of the working state of them.

Thought it was a issue with the USB dongle, so I purchased another new one but get identical issues with a brand new dongle.

Tried using an older version of onewireviewer but it comes with with a Java security possibly due to its age.

Would love to get my lightning sensor back up and running again.

Thanks.

Offline Silversword

  • --Stan Y.
  • Forecaster
  • *****
  • Posts: 530
    • Up Country Maui Weather
Re: 1wire hobbyboards communications issues
« Reply #1 on: October 31, 2014, 01:16:42 AM »
Hi David,

Do you have the drivers in the right location.  In my understanding they should reside in windows/system32/.  I have seven that has something like ibxxxxx.dll in this location.  It seems to be working for me.

Just a thought.

Hope that this might help.

Regards,

--Stan Y.
   Maui, Hawaii
Stan Y. - KH6HHG - Maui, Hawaii --- Blitzortung ID: 993 --- FlightRadar24 ID: F-PHOG1
Weather Display 10.37s Build 120
WDL 6.05
MS Windows 7 Pro
Dell Optiplex GX280-Intel Pentium 4 CPU 3.00GHz, 4 GB RAM
Davis Vantage Pro 2+ Wireless
1-Wire Lighting
Webcam: Axis 211

Offline david s

  • Member
  • *
  • Posts: 3
Re: 1wire hobbyboards communications issues
« Reply #2 on: November 06, 2014, 02:55:41 AM »
Thanks for the reply.

I checked the onewire download and all the .dll files are in windows/system32 folder.
Driver shows as WinUSB one-wire in windows and the device shows up corrrectly in onewireviewer.

Reading the onewire install notes they've recently rewritten the code, and the old version of onewireviewer no longer works due to an expired certificate.

Its rather frustrating as I'd love to get it back working again.