Weather Software > RaspberryPI Weather Software

Streaming to Multiple Icecast Servers with RTL SDR and Darkice

<< < (10/11) > >>

nincehelser:

--- Quote from: tim273 on October 20, 2019, 09:06:44 AM ---There's three different passwords in icecast.xml:


--- Code: ---<authentication>
        <!-- Sources log in with username 'source' -->
        <source-password>source</source-password>
        <!-- Relays log in username 'relay' -->
        <relay-password>relay</relay-password>

        <!-- Admin logs in with the username given below -->
        <admin-user>admin</admin-user>
        <admin-password>admin</admin-password>
    </authentication>

--- End code ---

I believe it's the source password, but I made them all the same on my server.  Also, once you change the passwords, restart icecast first and the darkice second.

--- End quote ---

That's what I've done, but no joy.

In the icecast error log, I get this:

--- Code: ---[2019-10-20  08:38:40] INFO connection/_handle_source_request Source logging in at mountpoint "/weather/radio" from 127.0.0.1
[2019-10-20  08:38:40] INFO connection/_handle_source_request Source (/weather/radio) attempted to login with invalid or missing password
--- End code ---

I'm stumped.  What version of raspian did you build on?  Maybe I should try on that and see if I have the same problem. 

Thanks!

dupreezd:
nincehelser, did you get this resolved? I have been running a Raspberry NOAA weather radio since last year build on the instructions provide by Tim Urberg. This went very smoothly. After that I build three more, also with no issues. The last one was in April 2019.
Last week the SD card failed in my Raspberry. I got a new SD, followed the procedure and ended up with the same error as you.
Double check passwords, username, server name in darkice.cfg and icecast.xml. Luckily I took snapshots of my builds, so I know the data entries are correct.

As a last resort, I did a complete rebuild not changing any of the default hackme passwords, same result.

I am not a Raspberry expert, so I am clueless how to find this problem. Maybe Tim can have a look and see what is going on.

Mine is build on Raspbian Stretch release 9.11

Thanks

dupreezd:
nincehelser, I managed to get hold of a SD card from one of the units I build. I cloned it, edited the required fields and are back on line.  :grin:

If you are still interested in running a Raspberry, I can send you a cloned SD card to get you going.
At 15GB the img file is way to big to email and I do not have access to a FTP server. Even then it is going to take a long time to upload and download again.

If you are interested, please send me an Email.

Dries

ke9lz:
Has anyone been able to make this work from scratch using the latest Raspberry software?  I have been trying to get this running and have not been successful.  I have followed the instructions to a tee and no success.

Steve

92merc:
It's been close to a year since I did my last one.  The only issue I've run into is I can't make the service start up properly.  After a reboot, I have to give it a minute to settle down, then restart the service.

But that's the only I had run into.  I have an older PI2 that I dabble with from time to time.  Production is a PI3.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version