Author Topic: PWS offine: IUTRECHT299 is cancelled by Wunderground?  (Read 300 times)

0 Members and 1 Guest are viewing this topic.

Offline Glamers

  • Member
  • *
  • Posts: 9
PWS offine: IUTRECHT299 is cancelled by Wunderground?
« on: November 30, 2022, 02:53:17 AM »
Hi Forum!

On October 11 2022, 6:38 PM CET, Wundergound stops reporting my WPS-data, stating my PWS is offline. My station (IUTRECHT299) however, continued to operate until this very day.
Although I repeatedly tried to get feedback from Wunderground, they remain totally unresponsive.
These are my supporttickets:
   Request Number 03498067 [ ref:_00DA0L1VM._5002K16vxCO:ref ]
   Request Number 03591144 [ ref:_00DA0L1VM._5002K16yvh0:ref ]
As I wanted to be absolutely sure the error was not on my side, I ran WhireShark to analyse the traffic between my PWS and Wunderground:

==================================================================================================================================================
line   Date & Time         Source      Destination   ProtocolLength   Info
2   2022-11-25 12:51:51,515915   192.168.178.100   54.159.105.134   TCP   60   8605 → 80 [SYN] Seq=0 Win=5840 Len=0 MSS=1460
3   2022-11-25 12:51:51,861039   54.159.105.134   192.168.178.100   TCP   60   80 → 8605 [SYN, ACK] Seq=0 Ack=1 Win=62727 Len=0 MSS=1460
4   2022-11-25 12:51:51,864209   192.168.178.100   54.159.105.134   TCP   60   8605 → 80 [ACK] Seq=1 Ack=1 Win=5840 Len=0
5   2022-11-25 12:51:52,043831   192.168.178.100   54.159.105.134   HTTP   571   GET /weatherstation/updateweatherstation.php?
                                    ID=IUTRECHT299&
                                    PASSWORD=<hidden>&
                                    tempf=53.1&
                                    humidity=85&
                                    dewptf=48.7&
                                    windchillf=53.1&
                                    winddir=251&
                                    windspeedmph=5.82&
                                    windgustmph=7.38&
                                    rainin=0.00&
                                    dailyrainin=0.31&
                                    weeklyrainin=0.31&
                                    monthlyrainin=0.31&
                                    yearlyrainin=0.31&
                                    solarradiation=82.05&
                                    UV=1&indoortempf=61.5&
                                    indoorhumidity=72&
                                    baromin=30.12&
                                    lowbatt=2&
                                    dateutc=2022-11-25%2012:52:33&
                                    softwaretype=Weather%20logger%20V2.1.9&
                                    action=updateraw&
                                    realtime=1&
                                    rtfreq=5 HTTP/1.0
6   2022-11-25 12:51:52,143199   54.159.105.134   192.168.178.100   TCP   60   80 → 8605 [ACK] Seq=1 Ack=518 Win=62210 Len=0
7   2022-11-25 12:51:52,144097   54.159.105.134   192.168.178.100   HTTP   328   HTTP/1.1 404 Not Found  (text/html)
8   2022-11-25 12:51:52,144097   54.159.105.134   192.168.178.100   TCP   60   80 → 8605 [FIN, ACK] Seq=275 Ack=518 Win=62210 Len=0
9   2022-11-25 12:51:52,166801   192.168.178.100   54.159.105.134   TCP   60   8605 → 80 [ACK] Seq=518 Ack=275 Win=5840 Len=0
10   2022-11-25 12:51:52,168162   192.168.178.100   54.159.105.134   TCP   60   8605 → 80 [FIN, ACK] Seq=518 Ack=276 Win=5840 Len=0
11   2022-11-25 12:51:52,267657   54.159.105.134   192.168.178.100   TCP   60   80 → 8605 [ACK] Seq=276 Ack=519 Win=62209 Len=0

==================================================================================================================================================

Apart from TCP handshakes, it can be seen on line 5 that my station (source 192.168.178.100) sends a HTTP "GET" and further information to destination 54.159.105.134 (rtupdate.wunderground.com). Wundergound (source 54.159.105.134) replies on line 7 with a "HTTP/1.1 404 Not Found".

What can be made of that?? Did Wunderground update its serversoftware? Did it move to another address? Or am I just cancelled?

My station hardware is FOSHK WH2600, Renkforce version. Firmware: Weather Logger V 2.1.9. It allows me to change the address it is sending its information to. I can change "server type" from PHP (current) to JSP or ASP. Other configuration options are non-existent. The station cooperated flawlessly with Wundergound since 2015, most of the time flying a "Golden Star". From that I conclude the protocol on my side is not on error.

What to do? Did anyone have the same problem? How to have a (two-way) communication with Wunderground?
I hate it when a good contraption cannot function because a remote party starts to neglect it....

Please help me out?

Kind regards,
Gus Lamers
the Netherlands


Offline jwreynoldson

  • Senior Member
  • **
  • Posts: 54
Re: PWS offine: IUTRECHT299 is cancelled by Wunderground?
« Reply #1 on: January 02, 2023, 12:18:22 AM »
This may or may not be relevant:
On Oct 5th at about 7:30am AEDST (UTC: 4th Oct, 8:30pm) my station went down, hard.

I traced the problem to a change in the server addresses resolved by DNS for weatherstation.wunderground.com

If your station uses any hard coded IP addresses to report, or if your DNS server is still resolving to the wrong IP address to report to, it will be offline.

Options:
1. wait to see if the DNS issue resolves as changes propagate.
2. Check with station supplier to assure hard coded IP addresses are not used. (If so may need a firmware update)

I had swapped to a hard coded address a couple of years ago on my home-coded station due to a DNS bug I couldn't fix, and it came back to bite me.  Fortunately the bug seems to have miraculously resolved, so I am switching back to DNS IP resolution (when I can get up the pole!)

John R.

Offline Glamers

  • Member
  • *
  • Posts: 9
Re: PWS offine: IUTRECHT299 is cancelled by Wunderground?
« Reply #2 on: January 03, 2023, 05:23:51 AM »
Thanks for your reaction, John.

As for a long time no reaction showed up here, I reposted under the "hardware line": https://www.wxforum.net/index.php?topic=44714.0

As you can see my problem is solved.

topic closed.

Gus