Author Topic: pwsWD WDapi  (Read 915 times)

0 Members and 1 Guest are viewing this topic.

Offline BfdWx

  • WxElement panel
  • Senior Contributor
  • *****
  • Posts: 255
    • Branford Weather
pwsWD WDapi
« on: November 26, 2023, 03:57:31 PM »
I recently changed from a Tempest device to a full blown VP2 w/ solar and UV. For some reason the WDapi is not uploading the UV reading, the solar is ok along with all other data points. I changed the appropriate devices etc. in the easyweather setup and I don't think there is a problem there. My WDapi is simply missing the UV data. I emailed Brian and he found a setting or two that needed correction which I did but to no avail! Does anybody have issues loading the UV data to the pwsWD web page or any suggestions? My page can be located here https://branfordweather.com/pwsWD/index.php

Thank you!

Online wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1990
    • My PWS at Leuven Belgium Europe
Re: pwsWD WDapi
« Reply #1 on: November 27, 2023, 03:03:42 AM »
The uploaded file by WD contains day or night a "--" value  for UV (field #39).
But the max UV (field #53) has a normal float from 0.0 at night to values such as "0.7" or "1.2" during day-time

WD gets the UV station datas and calculates UV max and put its in the WD-api upload.
But it does not move  the current UV  to the WD-api string.

Question: Do you have a link to your clientraw.txt?
Then we can see if the UV value there is also empty.

Wim

Code: (WD-api night time) [Select]
    [0] => 27/11/2023
    [1] => 02:55:32
    [2] => 10.7
    [3] => 89
    [4] => 8.9
    [5] => 0.873
    [6] => 1.790
    [7] => 360
    [8] => 0.01
    [9] => 3.0
    [10] => 1000.5
    [11] => 360
    [12] => 1
    [13] => --
    [14] => 998.4
    [15] => 92.2
    [16] => 1201.0
    [17] => 9.9
    [18] => 19.9
    [19] => 35
    [20] => 10.7
    [21] => 11.7
    [22] => 12.5
    [23] => 02:18
    [24] => 10.7
    [25] => 00:00
    [26] => 5.490
    [27] => 00:10
    [28] => 9.846
    [29] => 00:09
    [30] => 1002.6
    [31] => 00:01
    [32] => 998.3
    [33] => 01:52
    [34] => 10.37S
    [35] => 150
    [36] => 6.176
    [37] => --
    [38] => --
    [39] => --
    [40] => --
    [41] => 0.0
    [42] => 298
    [43] => 2.8
    [44] => --
    [45] => 0
    [46] => --
    [47] => 298
    [48] => --
    [49] => --
    [50] => 09:30:00
    [51] => --
    [52] => --
    [53] => 0.0
    [54] => 94
    [55] => 01:34
    [56] => 88
    [57] => 02:38
    [58] => 11.4
    [59] => 02:11
    [60] => 8.9
    [61] => 02:55
    [62] => 11.8
    [63] => 88
    [64] => 11.7
    [65] => 19.9
    [66] => 35
    [67] => -100.0
    [68] => -100.0
    [69] => -100.0
    [70] => -100
    [71] => -100
    [72] => -100

Offline BfdWx

  • WxElement panel
  • Senior Contributor
  • *****
  • Posts: 255
    • Branford Weather
Re: pwsWD WDapi
« Reply #2 on: November 27, 2023, 08:57:55 AM »
Hi Wim,

I think I have found the issue. My old weather station was a WeatherFlow and I was using that for solar/uv. Even though I have unchecked those and setup the VP2 to load the data it seems to be "remembering" the WF device. To test this I downloaded an unregistered version of WD and it uploaded the WDapi including the UV with no issues. I have an email into Brian to figure out how to have WD completely wipe out the WF settings.

And yes, clientraw does do the uv upload but that's another story lol, somehow the wind readings are messed up in the clientraw!

Thanks for looking!

Offline BfdWx

  • WxElement panel
  • Senior Contributor
  • *****
  • Posts: 255
    • Branford Weather
Re: pwsWD WDapi
« Reply #3 on: November 28, 2023, 09:38:08 AM »
The issue has been fixed. The WeatherFlow data was blocking my VP2, an edit of the wdisplayftp.ini file solved the issue.

Offline Vasco

  • Forecaster
  • *****
  • Posts: 350
    • PWS
Re: pwsWD WDapi
« Reply #4 on: November 28, 2023, 02:27:10 PM »
And yes, clientraw does do the uv upload but that's another story lol, somehow the wind readings are messed up in the clientraw!

Glad you got the API upload fixed (I think you mean wdisplayftp.reg?), but I'm intrigued by the clientraw comment. Are the winds messed up in clientraw or in pwsWD?
« Last Edit: November 28, 2023, 02:29:33 PM by Vasco »
Ecowitt GW1102 (with GW2000) + Weather Display in Windows 10

Offline BfdWx

  • WxElement panel
  • Senior Contributor
  • *****
  • Posts: 255
    • Branford Weather
Re: pwsWD WDapi
« Reply #5 on: November 28, 2023, 06:42:45 PM »
I think it was also related to the reg files, all is well with that too although I don't use it.

 

anything