Author Topic: WS-2902A will not connect to dual-band wifi  (Read 492 times)

0 Members and 1 Guest are viewing this topic.

Offline suntiger66

  • Member
  • *
  • Posts: 6
WS-2902A will not connect to dual-band wifi
« on: December 01, 2019, 09:22:49 PM »
As others have discussed, I have a WS-2902A that refuses to connect to a dual-band modem/router, an Arris DG3450. I have read many of the forum discussions regarding similar issues and tried as many options as I could, emailed Ambient, and now am asking for some help. The WS-2902A has worked fine for two years until last week when my ISP rolled out a new router. I cannot connect the WS-2902A to that device. The process goes fine up to the point when awnet is setting up wifi credentials. I get the screen that says when the connection is successful, the wifi icon will show on the console and the phone will be returned to its wifi network. That part works, my phone is reconnected to my network, but the WS-2902A is left unconnected.

I've tried connecting with an iPhone, an Android phone, and an iPad. I've done factory resets to the console, removed batteries, power cycled the router, all the normal things. (I have another WS-290A at another location, so I'm familiar with performing the connection process.) I have two phones, two computers, a printer, FireStick, and an iPad on the network and all connected without issue. Concentrating on the iPhone, I've turned off cellular data and "forgot" the 5G network so it only uses 2.4G. The only thing I cannot do is disable 5G at the router because the ISP does not release the admin pwd to customers. I know it's unusual, but I had some heated discussions with them to no avail.

A response to an email to Ambient simply told me to do all the things I've been doing. I asked them if they would advise new hardware, such as the WS-2000 or the ObsererIP, but they didn't offer up any suggestions. He also said he'd never heard of an ISP not giving the admin pwd. Neither had I. First time for everything, I guess.

I hate to admit this, but I do not know the WS-2902A firmware level. I was lax in keeping up with it and I don't know how to check the level without connecting through awnet.

My conclusion so far is that the WS-2902A is not compatible with an Arris DG3450 provided by Astrea Connect and I don't mind going the WS-2000 route if I was sure it would work. I know the WS-2000 uses direct entry of wifi credentials, so that might help. Also requires a WH32B.

I'm new here; have read many interesting posts over the years and just signed up. It's a very good source of information and I hope I'm forgiven for starting off my forum presence with a problem!

Offline galfert

  • Global Moderator
  • Forecaster
  • *****
  • Posts: 3524
Re: WS-2902A will not connect to dual-band wifi
« Reply #1 on: December 01, 2019, 10:26:24 PM »
Welcome to the forum.

I too had never heard of an ISP that doesn't give you the password to the router. Regardless even if they did I would still recommend not using their modem as a router. Buy your own router and use the ISP modem/router as just a modem. This is accomplished by telling the ISP to put the modem into bridge mode. Then you can connect your own router and control your own network. Get a decent router and you'll have much to gain like better WiFi, more network features, better security.

But moving on. If you have a real WS-2902A and not a WS-2902 then you have two ways to get it connected. I would recommend the MiFi way.

Moving on further I highly recommend getting the WS-2000-C display console with the WH32B. So much more to gain.
https://www.wxforum.net/index.php?topic=36379.0

Lastly do not get an ObserverIP. That is just not a good product. If you need an easy way to get data to other software then a better solution is the Ecowitt GW1000 which is compatible with all the Ambient stuff. Only difference between it and an Ambient console is that it uploads to Ecowitt.net instead of Ambientweather.net, which is why if you have both consoles then you get the benefits of uploading to both.
« Last Edit: December 01, 2019, 10:28:50 PM by galfert »
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline suntiger66

  • Member
  • *
  • Posts: 6
Re: WS-2902A will not connect to dual-band wifi
« Reply #2 on: December 02, 2019, 12:11:24 AM »
Thank you for the reply. It was most helpful. Getting my own router is definitely a viable option, one that I'll put on the shelf for the time being. I agree with you, the WS-2000 and WH32B is the best way to go and then use the WS-2902A as a second console. That's what I'll do and get my own router if I encounter problems.

The ISP is a small outfit in Upper Michigan and our best option for cable internet and TV. I know the tech who services the area and I called him about the password. He said that it's company policy not to give it out. Why? He didn't know. I think for a beer I could probably get it, but it's not worth risking his job for a weather station.

Thanks again for your help. On to new adventures.


Offline Bushman

  • Forecaster
  • *****
  • Posts: 7375
    • Eagle Bay Weather
Re: WS-2902A will not connect to dual-band wifi
« Reply #3 on: December 02, 2019, 12:27:23 AM »
You've tried the normal UID/pwd combo for an Arris?  How about doing a reset of the router?
Need low cost IP monitoring?  http://wirelesstag.net/wta.aspx?link=NisJxz6FhUa4V67/cwCRWA or PM me for 50% off Wirelesstags!!

Offline whitebluesky

  • Member
  • *
  • Posts: 8
Re: WS-2902A will not connect to dual-band wifi
« Reply #4 on: December 02, 2019, 05:04:08 AM »
(Disclaimer: the following are just thoughts, I am not sufficiently familiar with WIFI to know if this will work. In particular, I don't know if the registration uses only WIFI name (SSID) and password, or if the MAC address also comes into play.)

What about trying a WIFI repeater that either works only on 2.4 GHz in the first place or can be configured to do so? Then you'd position the repeater and your WS-2902A relative to the Arris such that the WS-2902A can only "see" the 2.4 GHz from the repeater but not the 5 GHz from the Arris and do the configuration of the WS-2902A. If it works you would then move the WS-2902A back into the range of the Arris and remove the repeater. Ideally you would be able simply borrow the repeater for this purpose from someone.

Another thought along similar lines would be to find someone with a WIFI router in which you can arbitrarily set the WIFI name (SSID) and password and which you can configure to 2.4 GHz only. Then enter your Arris's WIFI name and password into that router and set up the WS-2902A using that router (of course your Arris's 5 GHz must be out of reach). Once that works move back to your Arris.

A final thought: I believe that - other things being equal - 2.4 GHz should have a longer range than 5 GHz. Hence, you might be able to find a spot where reception of 2.4 GHz but not of 5 GHz is available from your Arris.
« Last Edit: December 02, 2019, 05:37:56 AM by whitebluesky »

Offline galfert

  • Global Moderator
  • Forecaster
  • *****
  • Posts: 3524
Re: WS-2902A will not connect to dual-band wifi
« Reply #5 on: December 02, 2019, 07:07:46 AM »
Great idea. Yes that is a good solution. The MAC address of the WiFi access point does not matter. The interm WiFi can be a another smart phone with hotspot feature (not the one being used to connect the WS-2902A). I wouldn't go the repeater way though as that requires the modem to be powered on.

Are you using the awnet app? Because with the MiFi way the 5 GHz should not matter. That said I've seen some routers just not be compatible with the WS-2902A. Maybe they are stuck with wide channels on the 2.4 GHz band or something.

The other thing that could be a problem is is the SSID used or the Password key has characters that the WS-2902A just does not like. I'm not certain about this but it is a hunch.
WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline suntiger66

  • Member
  • *
  • Posts: 6
Re: WS-2902A will not connect to dual-band wifi
« Reply #6 on: December 02, 2019, 01:09:06 PM »
Thank you all for your responses. Allow me answer some of your questions.

Yes, I am using awnet and have tried it with an iPhone, Android phone, and an iPad. I never have an issue connecting to the MiFi gateway.

I'm in a fairly remote area of the Upper Peninsula and trying to find someone with a router I can play with is not an option.

The password key is all numeric and the SSID is five letters with no special characters.

I have power cycled the router, but if I do a factory reset I won't be able to set it up again because I don't have the admin pwd.

True, the range of 5G is less than 2.4G, so that's a good idea, to try out-ranging the 5G. I tried, but even leaving the cabin and walking some distance away, farther than my 25' extension cord could reach, I still didn't lose 5G.

I'm intrigued by the wifi extender idea because it would provide a different 2.4GHz SSID which should look "normal" to the WS-2902A. As I understand it, a repeater and an extender are essentially the same thing except that one is hardwired LAN and the other is wireless. In both cases the modem needs power for internet connectivity, which in my case, it will always have. This looks like an inexpensive thing to try before ordering a WS-2000. Give me a few days and I'll let you know.


Offline whitebluesky

  • Member
  • *
  • Posts: 8
Re: WS-2902A will not connect to dual-band wifi
« Reply #7 on: December 02, 2019, 03:06:45 PM »
I can configure my smartphone as a hotspot and freely choose SSID and password. I'm not sure, though, whether I can set it to only operate at 2.4 GHz. And of course you then need to somehow connect the smartphone to the internet by some other means (you said you were remote...).

I only checked some local German brand repeaters. At least some of them allow to choose whether they provide their own SSID or reuse the one from the router.

Regarding playing with the WIFI range - maybe it's feasible to weaken (for trying to outrange) or block (for trying with a repeater/extender and same SSID) the signal by covering the router with some metal shield (pot, bucket,...) and maybe grounding the shield. Please note that I have no idea whether that can potentially damage the router.

Offline StephenR0

  • Senior Member
  • **
  • Posts: 65
Re: WS-2902A will not connect to dual-band wifi
« Reply #8 on: December 02, 2019, 03:41:34 PM »
One thing that I've noticed is that some routers and access points come with a channel width setting of 'auto' for the 2.4Ghz band.  In the past, I've had to set this explicitly to 20Mhz.  Some devices can't handle 40Mhz.  It sounds like you might have trouble getting to this setting, but maybe your ISP can set it for you.  Just a thought.
« Last Edit: December 02, 2019, 03:43:15 PM by StephenR0 »

Offline nincehelser

  • Forecaster
  • *****
  • Posts: 3308
Re: WS-2902A will not connect to dual-band wifi
« Reply #9 on: December 02, 2019, 04:02:08 PM »
When you're talking to the ISP, are you sure you're both talking about the same "admin" password?

You want the password to change the WiFi config, such as making separate 2.4 and 5GHz network SSIDs.  Many devices will not work properly in mixed mode.  Making separate networks is usually the fix for that.

Your ISP may be thinking of their management password for the cable side. 

If you say you need to change the WiFi names, what is their response?

Offline galfert

  • Global Moderator
  • Forecaster
  • *****
  • Posts: 3524
Re: WS-2902A will not connect to dual-band wifi
« Reply #10 on: December 02, 2019, 04:47:43 PM »
I just talked to the ISP company. Wowzers! Yup they don't give out the password to customers. They say that they don't get very many requests for it and often they just do whatever you need done for you remotely. ...BUT...... :grin: ....I was able to talk my way into getting the password. Helps to throw out the IT guy credential I guess in this case.  Check your PM for the password to the modem/router that they gave me.

Let me know if it worked (to log in).


WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline suntiger66

  • Member
  • *
  • Posts: 6
Re: WS-2902A will not connect to dual-band wifi
« Reply #11 on: December 02, 2019, 06:15:37 PM »
Wow, some weight thrown there! Thanks for that! I was able to log into the router, turned off 5G, but still can't connect the station. That seems to eliminate 5G from the equation and there is just some anomaly between the station and router. In any case, I'm going to leave 5G disabled for now.

I did make some progress. I created a personal hotspot with my phone and was able to attach the WS-2902A to my phone. I was then able to update the firmware to 4.1.8. While connected, I was back on AW and WU, just like before. Of course that was just temporary, but it was nice to see! While in there I verified that the device bandwidth for 2.4G was set to 20.

I also heard back from Ed at Ambient who said I should send the station back for a full refund. Nice gesture, but I think I can get this thing connected. Next step will be a wifi extender.

Offline galfert

  • Global Moderator
  • Forecaster
  • *****
  • Posts: 3524
Re: WS-2902A will not connect to dual-band wifi
« Reply #12 on: December 02, 2019, 07:35:10 PM »
Past one hurdle only to be confronted with another.


WS-2000 & WS-2902A | Ecowitt GW1000 | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Windy: pws-f075acbe
Weather Underground Issue Tracking
Tele-Pole

Offline suntiger66

  • Member
  • *
  • Posts: 6
Re: WS-2902A will not connect to dual-band wifi
« Reply #13 on: December 02, 2019, 07:58:25 PM »
True, but after all the hurdles are gone comes the feeling of accomplishment.

Offline suntiger66

  • Member
  • *
  • Posts: 6
Re: WS-2902A will not connect to dual-band wifi
« Reply #14 on: December 05, 2019, 04:57:46 PM »
Success on the last hurdle! I installed a Netgear N300 WiFi Range Extender Model EX2700 and the WS-2902A connected to it with no problem. Thanks to all of you for your suggestions.

 

anything