Author Topic: API - missing May 20 to June 20  (Read 164 times)

0 Members and 1 Guest are viewing this topic.

Offline dport

  • Senior Contributor
  • ****
  • Posts: 196
API - missing May 20 to June 20
« on: August 07, 2019, 09:50:06 AM »
Realize there have been a lot of posts here about missing data, but for some reason I am missing a full month when I pull data from the WU API (may 20 to June 20).  When I log into the WU website, the data is there.  Any idea why the API seems to be messed up but not the WU website?

Offline wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1445
    • My PWS at Leuven Belgium Europe
Re: API - missing May 20 to June 20
« Reply #1 on: August 07, 2019, 10:25:49 AM »
Realize there have been a lot of posts here about missing data, but for some reason I am missing a full month when I pull data from the WU API (may 20 to June 20).  When I log into the WU website, the data is there.  Any idea why the API seems to be messed up but not the WU website?
This is your "new and improved" dashboard for the month of June:
https://www.wunderground.com/dashboard/pws/KPAMEDIA25/table/2019-06-7/2019-06-7/monthly
Your data for June is there, and the TWC-api (also known as WU-api) works correct
https://api.weather.com/v2/pws/history/daily?stationId=KPAMEDIA25&format=json&units=m&startDate=20190601&endDate=20190630&numericPrecision=decimal&apiKey=__api_key__
This API only works with a maximum of 31 days

What are you using for "when I pull data from the WU API "  ?
The missing data is a problem with the .csv retrieval  but that is not  an official WU-api
https://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=KPAMEDIA25&graphspan=year&year&format=1
This one is missing May 22 - June 19
Code: [Select]
2019-5-21,22.6,18.4,14.3,12.8,8.0,3.9,67,53,38,1021,1010,21,3,31,0.00
2019-6-20,29.7,25.3,20.9,24.9,21.9,20.1,96,89,71,1006,999,16,1,26,5.64
And also all data after July 25.
But that is a known problem and yes, multiple stations are missing one or more periods. We all have to wait and see if they will upgrade the .csv retrieval or abandon it.

Wim
Support for Leuven-Template & Scripts  at this forum
Support for the PWS_Dashboard (HWS-template) for WD a.o.  http://pwsdashboard.weather-template.com/
Script sponsors https://support.leuven-template.eu/userlistScripts.php
Template sponsors https://support.leuven-template.eu/userlist.php

Offline dport

  • Senior Contributor
  • ****
  • Posts: 196
Re: API - missing May 20 to June 20
« Reply #2 on: August 07, 2019, 10:51:50 AM »
Realize there have been a lot of posts here about missing data, but for some reason I am missing a full month when I pull data from the WU API (may 20 to June 20).  When I log into the WU website, the data is there.  Any idea why the API seems to be messed up but not the WU website?
This is your "new and improved" dashboard for the month of June:
https://www.wunderground.com/dashboard/pws/KPAMEDIA25/table/2019-06-7/2019-06-7/monthly
Your data for June is there, and the TWC-api (also known as WU-api) works correct
https://api.weather.com/v2/pws/history/daily?stationId=KPAMEDIA25&format=json&units=m&startDate=20190601&endDate=20190630&numericPrecision=decimal&apiKey=__api_key__
This API only works with a maximum of 31 days

What are you using for "when I pull data from the WU API "  ?
The missing data is a problem with the .csv retrieval  but that is not  an official WU-api
https://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=KPAMEDIA25&graphspan=year&year&format=1
This one is missing May 22 - June 19
Code: [Select]
2019-5-21,22.6,18.4,14.3,12.8,8.0,3.9,67,53,38,1021,1010,21,3,31,0.00
2019-6-20,29.7,25.3,20.9,24.9,21.9,20.1,96,89,71,1006,999,16,1,26,5.64
And also all data after July 25.
But that is a known problem and yes, multiple stations are missing one or more periods. We all have to wait and see if they will upgrade the .csv retrieval or abandon it.

Wim

Hmm.  I must be using the wrong API key.  I'm actually using your template on my local server (thanks so much!).  Attached is where I am pulling the API key from:

 [ You are not allowed to view attachments ]

Offline wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1445
    • My PWS at Leuven Belgium Europe
Re: API - missing May 20 to June 20
« Reply #3 on: August 07, 2019, 01:24:58 PM »

Hmm.  I must be using the wrong API key.  I'm actually using your template on my local server (thanks so much!).  Attached is where I am pulling the API key from:
The PWS_Dashboard (aka HWS-Template WD34) uses
1. the WU/TWC-api (https://api.weather.com/v2/) for the forecast only.
2. the WXDailyHistory link s(https://www.wunderground.com/weatherstation/WXDailyHistory) for the graphs

As long as WU/IBM is still working on improving their systems we have to wait until it is clear if the will abandon or postpone the WXDailyHistory link.

Wim

Support for Leuven-Template & Scripts  at this forum
Support for the PWS_Dashboard (HWS-template) for WD a.o.  http://pwsdashboard.weather-template.com/
Script sponsors https://support.leuven-template.eu/userlistScripts.php
Template sponsors https://support.leuven-template.eu/userlist.php

Offline dport

  • Senior Contributor
  • ****
  • Posts: 196
Re: API - missing May 20 to June 20
« Reply #4 on: August 07, 2019, 03:01:04 PM »

Hmm.  I must be using the wrong API key.  I'm actually using your template on my local server (thanks so much!).  Attached is where I am pulling the API key from:
The PWS_Dashboard (aka HWS-Template WD34) uses
1. the WU/TWC-api (https://api.weather.com/v2/) for the forecast only.
2. the WXDailyHistory link s(https://www.wunderground.com/weatherstation/WXDailyHistory) for the graphs

As long as WU/IBM is still working on improving their systems we have to wait until it is clear if the will abandon or postpone the WXDailyHistory link.

Wim

Ok I understand now.  I was worried I was doing something wrong.  I'll wait to see how this pans out.  Thank you!

 

anything