Author Topic: Website not displaying correctly........  (Read 226 times)

0 Members and 1 Guest are viewing this topic.

Offline DW7240

  • Senior Contributor
  • ****
  • Posts: 189
    • The Vicarage Weather Feed
Website not displaying correctly........
« on: February 10, 2019, 12:46:51 PM »
Hi,

Any chance somebody could look at my website, for no reason it seems to be only displaying the top 1/4 of the site, there's no menubar / flyout menu, the site is of non use, are there errors which are stopping the site from functioning properly.  The issue is the same across all devices.

Any help would be appreciated !!

Thanks in advance.

Nick. dw7240.com

P.S. I also noticed that dw7240.com should go to dw7240.com/Base-Canada/index.php but this is not the case, has Godaddy server got an issue and has anuone else got a similar problem ?



Online PaulMy

  • Forecaster
  • *****
  • Posts: 4280
    • KomokaWeather
Re: Website not displaying correctly........
« Reply #1 on: February 10, 2019, 12:52:29 PM »
I clicked on the link and got strange behaviour, including being a grand prize winner, so stopped it immediately. 

My internet with Rogers was down this morning but back up now, and have seen no issue with GoDaddy.

Good luck,
Paul
Davis Vantage Pro 2 Plus 24-FARS Wireless
Envoy/USB DataLogger/Cumulus v.1.9.4   -   Vue Console/WiFiLogger
Komoka, ON  Canada
www.komokaweather.ca   www.komokaweather.com   www.komokaweather.com/weather28/   www.komokaweather.com/pws/index.php
Blitzortung Station #1076 www.lightningmaps.org/blitzortung7/america/index.php?bo_page=statistics&bo_show=network&lang=en&bo_station_id=969

Offline DW7240

  • Senior Contributor
  • ****
  • Posts: 189
    • The Vicarage Weather Feed
Re: Website not displaying correctly........
« Reply #2 on: February 10, 2019, 02:18:15 PM »
Hi Paul,

What link did you use ?

Thanks.

Nick.


Online PaulMy

  • Forecaster
  • *****
  • Posts: 4280
    • KomokaWeather
Re: Website not displaying correctly........
« Reply #3 on: February 10, 2019, 03:17:39 PM »
Hi,
I had used the globe under your user name, so just tried it again and now it comes up blank.

Paul
Davis Vantage Pro 2 Plus 24-FARS Wireless
Envoy/USB DataLogger/Cumulus v.1.9.4   -   Vue Console/WiFiLogger
Komoka, ON  Canada
www.komokaweather.ca   www.komokaweather.com   www.komokaweather.com/weather28/   www.komokaweather.com/pws/index.php
Blitzortung Station #1076 www.lightningmaps.org/blitzortung7/america/index.php?bo_page=statistics&bo_show=network&lang=en&bo_station_id=969

Offline DW7240

  • Senior Contributor
  • ****
  • Posts: 189
    • The Vicarage Weather Feed
Re: Website not displaying correctly........
« Reply #4 on: February 10, 2019, 06:00:33 PM »
Hi paul,

Can you see what you get when you enter the full URL......dw7240.com/Base-Canada/index.php

Thanks Paul

Nick.


Online PaulMy

  • Forecaster
  • *****
  • Posts: 4280
    • KomokaWeather
Re: Website not displaying correctly........
« Reply #5 on: February 10, 2019, 06:57:53 PM »
Hi,
I get your webcam page and cities' times at the top, and the audio link and that works.

Paul
Davis Vantage Pro 2 Plus 24-FARS Wireless
Envoy/USB DataLogger/Cumulus v.1.9.4   -   Vue Console/WiFiLogger
Komoka, ON  Canada
www.komokaweather.ca   www.komokaweather.com   www.komokaweather.com/weather28/   www.komokaweather.com/pws/index.php
Blitzortung Station #1076 www.lightningmaps.org/blitzortung7/america/index.php?bo_page=statistics&bo_show=network&lang=en&bo_station_id=969

Offline DW7240

  • Senior Contributor
  • ****
  • Posts: 189
    • The Vicarage Weather Feed
Re: Website not displaying correctly........
« Reply #6 on: February 10, 2019, 07:11:18 PM »
Hi Paul,

You get what I get, maybe someone else can take a look and see what's going on.

Thanks Paul for looking.

Nick.


Online ConligWX

  • Forecaster
  • *****
  • Posts: 361
  • #conligwx
    • conligwx.org
Re: Website not displaying correctly........
« Reply #7 on: February 10, 2019, 07:18:46 PM »
start looking at the apache error logs. usually it will show what is wrong with the site.

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6989
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Website not displaying correctly........
« Reply #8 on: February 10, 2019, 09:34:07 PM »
I'm suspecting a syntax error in your .htaccess file - even .txt or .html files that should display, return an empty page so it's bigger than a PHP issue.. it's an Apache server issue.  Again, likely a syntax error in .htaccess

Requests for anything return 403-Forbidden
« Last Edit: February 10, 2019, 09:36:07 PM by saratogaWX »
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline DW7240

  • Senior Contributor
  • ****
  • Posts: 189
    • The Vicarage Weather Feed
Re: Website not displaying correctly........
« Reply #9 on: February 10, 2019, 10:09:52 PM »
Hi Ken,

Thanks for looking, when I go onto the site I get the top of the index page including the webcam, then nothing under that, I have loaded in the ajax-dashboard.php separately to see if it shows the main part of the site, and it indeed shows as it should, on its own. Other pages like Top.php show ok, as does the footer.php.  Only time I get a blank page is when I try to load dw7240.com without the /Base-Canada/index.php tagged on the end,  the domain has forwarding so dw7240.com is all that's required.  This issue only started today, is it possible my site has been hacked ?

Any further advice would be great,

Thanks again Ken.

Nick.


Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6989
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Website not displaying correctly........
« Reply #10 on: February 10, 2019, 10:40:55 PM »
One issue is your very-out-of-date PHP 5.3.24 -- you should be on PHP5.6 or PHP7.2 to be current.  They stopped supporting 5.3 several years ago.

Also, lots of HTML validation errata on the home page (<style> stuff after </head>, extra <head> after </head>, etc).

Doing a view-source of http://dw7240.com/Base-Canada/index.php shows it 'ends' just after emitting
Code: [Select]
</center>
</div><!-- end page wrapper -->
<!-- end of header -->
<!-- cURL : yes -->
<!-- all areas with alerts got -->
<!-- EC Alerts last fetch on Sunday at 10:23 pm EST -->
so some script include() after that is failing/has a syntax error inside it that causes page generation to stop.

Looking at a view-source on wxsitemap.php (a page likely unchanged) shows the same symptom.

I can see top.php loads, and header.php loads, but menubar.php does not seem to load.  Trying the load of menubar.php gets a 500 Server Error, so that's where the problem is on your site currently.  Not likely your site is hacked at this time (no clear indications of that), but there is a problem in menubar.php that is preventing your site from fully loading/rendering.
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6989
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Website not displaying correctly........
« Reply #11 on: February 10, 2019, 10:45:17 PM »
Ahh.. think I've found the problem.  It's in usaextremes.php (included by menubar.php) that is failing with
Quote
<b>Parse error</b>:  syntax error, unexpected T_VARIABLE in <b>/home/content/64/11561464/html/Base-Canada/usaextremes.php</b> on line <b>40</b><br />
Maybe you left off a semicolon on the prior line???
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline DW7240

  • Senior Contributor
  • ****
  • Posts: 189
    • The Vicarage Weather Feed
Re: Website not displaying correctly........
« Reply #12 on: February 10, 2019, 11:00:36 PM »
Hi Ken,

Your a master....so I've got the dw7240.com forwarding to dw7240/Base-Canada/index.php working again, and yes that was an issue with .htaccess file, not sure why, but both .htaccess files - there's one in the Base-Canada folder and one in the root, these seemed to be swapped, which is kind of weird because I have not touched them in any way for years, but my site was recently moved by Godaddy to another server, wonder if they done that ?

Secondly, you were right about the menubar.php file, it trys to load the usaextremes.php which is correct but there's an issue with the usaextremes, not sure what, so I deleted the extremes php files and not the site works fine, just as before.  Incredibly that one file would make such a mess of things, I was thinking of the obvious files like ajax dashboard, index.php, etc etc, those that make the basis of the site, never thinking that an outside file could have so much influence in how the site would load.

So thank you Ken, you really have made my day, I was thinking oh god, four years of work spent in one day, now I'm a happy bunny again, lol.

Thanks again - now to get those usaextremes files sorted out and figuring what's up with them.

Nick. dw7240.com


Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6989
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Website not displaying correctly........
« Reply #13 on: February 10, 2019, 11:07:37 PM »
Glad to have been of assistance :)

The nice thing about the template set is having one place to change the appearance/data presented on ALL pages in the site since
every wx...php page loads Settings.php (Settings-weather.php, Settings-language.php), common.php, top.php, flyout-menu.php, header.php, menubar.php and footer.php along with the tags (and -defs file) for the weather software data.

The 'Achilles Heel' is a PHP syntax problem in any one of those (or an XML error in flyout-menu.xml) can 'take down' your site until the problem is fixed.  That's where looking at the Apache error_log for your site is very helpful to see exactly where the problem lies.  One syntax error causes all remaining scripts to be aborted. (as was the case in the syntax error in usaextremes.php aborting menubar.php and all other following scripts).
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline DW7240

  • Senior Contributor
  • ****
  • Posts: 189
    • The Vicarage Weather Feed
Re: Website not displaying correctly........
« Reply #14 on: February 10, 2019, 11:13:25 PM »
Hi Again Ken,

Looks like you beat me, lol, it was indeed a ; left off the end of the line that contains the updated NOAA site URL, all good again........Thank you very much !!!

Nick. dw7240.com


Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6989
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: Website not displaying correctly........
« Reply #15 on: February 10, 2019, 11:15:07 PM »
Dang officious PHP.. always insisting on spotless syntax   :roll:  :lol:  :lol:
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP