Author Topic: WeatherLink 6.0.3 software glitch?  (Read 267 times)

0 Members and 1 Guest are viewing this topic.

Offline Reg1992

  • Member
  • *
  • Posts: 8
WeatherLink 6.0.3 software glitch?
« on: February 02, 2019, 04:27:38 AM »
I've maintained my Davis Instruments Vantage Pro 2 weather station at my current location since December 2014, and have been using WeatherLink the whole time. I do data downloads manually, usually once or twice a day. Tonight, at 11:36 PM PST (February 1st), I did my usual download, which went smoothly. All of the data for the day is correctly represented in the plot. However, when I went to the NOAA Month Summary for what was supposed to be February 2019 - instead, the month summary for January 2019 came up. I then went to the "Browse the station data" window, and it does not show any data past 12:00 AM February 1st, 2019. Beyond that is a string of [Could not get record 2095402] errors. This is really odd in that the data for February 1st (through the download I did at 11:36 PM) does show up in the plot and yearly rainfall windows (0.01" fell here on the 1st).

I tried to do another data download, and it keeps trying to download 513 pages (100%) when it should obviously be only a few pages (maybe 1%) at this point. The date and time are correct on the console, it still shows the current data with no problems, and the date and time are the same on my PC. I went into my WeatherLink folder and found a strange .wlk file named 2119-12.wlk (when it should instead be 2019-02.wlk). I exited WeatherLink, deleted that file, restarted, and attempted to download the data again. Still 513 pages (100%). I'm afraid to download the 513 pages in fear that it will overwrite my recent data or mess other stuff up somehow. I did some Googleing and found this forum, several threads from users with similar problems that were instructed to delete the files "DataLists.dat" and "DataSets.dat". So I did that, restarted, etc. Still 513 pages (100%).



I made sure there were no connectivity issues with the USB or data logger. This seems to be a software glitch related to the date rolling over from 01/31/19 to 02/01/19, but I'm at a loss for how to fix it. I'd like to fix this very soon before recent data becomes overwritten due to full data packets. I live in Southern California and we're due for a major storm this weekend, which I want fully documented in my data.

Some images:


Data I downloaded from February 1st still shown in Plot and Yearly Rainfall but nowhere else:


Another thing - I opened the Log to see if I could find anything helpful in there. At 11:36 PM, when I did my download, this bizarre text shows up in the log for that time. I have never seen it before, it has never happened in the log up to this point, I have no idea what it means, and I found nothing on the internet about it:
« Last Edit: February 02, 2019, 04:36:44 AM by Reg1992 »

Offline johnd

  • Forecaster
  • *****
  • Posts: 2962
    • www.weatherstations.co.uk
Re: WeatherLink 6.0.3 software glitch?
« Reply #1 on: February 02, 2019, 04:37:56 AM »
This type of issue is not that uncommon - usually due to PC or hard disk issues. Just delete the 2119-12.wlk file (or rename it to eg 2119-12.wlk.old if you're feeling cautious) and try the download again. And see eg

https://www.manula.com/manuals/pws/davis-kb/1/en/topic/errors-with-archive-downloads

https://www.manula.com/manuals/pws/davis-kb/1/en/topic/detailed-troubleshooting
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Littleport, Ely, Cambs UK

Offline Reg1992

  • Member
  • *
  • Posts: 8
Re: WeatherLink 6.0.3 software glitch?
« Reply #2 on: February 02, 2019, 04:53:54 AM »
This type of issue is not that uncommon - usually due to PC or hard disk issues. Just delete the 2119-12.wlk file (or rename it to eg 2119-12.wlk.old if you're feeling cautious) and try the download again. And see eg
I did delete that file - still 513 pages. Also I ran a CHKDSK a month ago which came up clean. This computer is currently on its second hard drive (first one failed in January 2017).

Offline johnd

  • Forecaster
  • *****
  • Posts: 2962
    • www.weatherstations.co.uk
Re: WeatherLink 6.0.3 software glitch?
« Reply #3 on: February 02, 2019, 05:10:55 AM »
OK, well, you need to check through all the other suggestions in our knowledgebase links I posted. The issue will be one of the causes/fixes listed there.
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Littleport, Ely, Cambs UK

Offline Reg1992

  • Member
  • *
  • Posts: 8
Re: WeatherLink 6.0.3 software glitch?
« Reply #4 on: February 02, 2019, 05:22:59 AM »
Okay - I opened a different station in WeatherLink that I had briefly used in August 2015 as a test for whatever reason. I downloaded the 513 pages onto it, and it's all the current data since January 31st. All of the data is accurate with no anomalies. I went back to my current weather station and it still wants to download 513 pages to it, even though a lot of the data it is trying to download is already in the database plot (for 01/31 and 02/01).

Should I try and download it anyway? Will it overwrite previous data?

Offline Reg1992

  • Member
  • *
  • Posts: 8
Re: WeatherLink 6.0.3 software glitch?
« Reply #5 on: February 02, 2019, 07:36:13 AM »
Alright, I took a gamble and downloaded the data. It generally went fine and now all of the data is current. Although in the plot, two different sets of data now show for February 1st for some reason, although it doesn't seem to affect any of my records or summaries. The "Browse station data" window also shows the previous error data [Could not get record xxxxxxx] for February 1st alongside the actual data for that period that I just downloaded.



I'm still curious to know what the "GetACK: hComm" error I found in the log means. Otherwise, all seems to be normal again. Thank you johnd for your prompt help :)
« Last Edit: February 02, 2019, 07:42:49 AM by Reg1992 »

Offline ocala

  • Forecaster
  • *****
  • Posts: 3541
    • http://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=KFLBELLE2
Re: WeatherLink 6.0.3 software glitch?
« Reply #6 on: February 02, 2019, 07:46:12 AM »
Weatherlink will hum along just fine then out of the blue weird stuff happens. Then it goes back to working as it should. Have never figured out why. Been a user since 03.
Now I download everything once a week and shut it back down. So far no issues.

Offline Bushman

  • Forecaster
  • *****
  • Posts: 7123
    • Eagle Bay Weather
Re: WeatherLink 6.0.3 software glitch?
« Reply #7 on: February 03, 2019, 12:38:45 PM »
Jruys' WLKReaderWriter will let you look and edit the WLK files.

Offline johnd

  • Forecaster
  • *****
  • Posts: 2962
    • www.weatherstations.co.uk
Re: WeatherLink 6.0.3 software glitch?
« Reply #8 on: February 03, 2019, 02:04:59 PM »
Jruys' WLKReaderWriter will let you look and edit the WLK files.

It will indeed. But if as I suspect this is just caused by one or two records with spurious datetime stamps then these can be deleted from within WL.
Prodata Weather Systems
Prodata's dedicated Davis EnviroMonitor website
UK Davis Premier Dealer - All Davis stations, accessories and spares
Littleport, Ely, Cambs UK