Author Topic: wxwugraphs stopped working after switching to https  (Read 233 times)

0 Members and 1 Guest are viewing this topic.

Offline CamarilloWX

  • CamarilloWX
  • Contributor
  • ***
  • Posts: 106
    • Camarillo Weather
wxwugraphs stopped working after switching to https
« on: February 01, 2019, 02:53:27 AM »
Hi All,

My wxwugraphs page stopped working after switching the site from http to https.  I currently have a .htaccess file redirecting http to https so you can't see the working version now.  I temporarily removed the .htaccess file to confirm the problem and wxwugraphs works when connecting with http.  The issue can be seen at https://www.camarilloweather.com/wxwugraphs.php.  Any ideas on why wxwugraphs doesn't work with https and what I can do to fix it?

Thanks,

Eric
« Last Edit: February 01, 2019, 02:56:16 AM by CamarilloWX »
Eric

Online wvdkuil

  • Wim van der kuil
  • Forecaster
  • *****
  • Posts: 1353
    • My PWS at Leuven Belgium Europe
Re: wxwugraphs stopped working after switching to https
« Reply #1 on: February 01, 2019, 04:07:09 AM »
Hi All,

My wxwugraphs page stopped working after switching the site from http to https.  I currently have a .htaccess file redirecting http to https so you can't see the working version now.  I temporarily removed the .htaccess file to confirm the problem and wxwugraphs works when connecting with http.  The issue can be seen at https://www.camarilloweather.com/wxwugraphs.php.  Any ideas on why wxwugraphs doesn't work with https and what I can do to fix it?

Thanks,

Eric
You have to go into the scrips and change all http references to scripts from http to https.
These are the first two error messages.
Code: [Select]
wxwugraphs.php:1 Mixed Content: The page at 'https://www.camarilloweather.com/wxwugraphs.php' was loaded over HTTPS,
but requested an insecure script 'http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js'.
 This request has been blocked; the content must be served over HTTPS.

jq-core-widget-tabs.min.js:15 Uncaught ReferenceError: jQuery is not defined   at jq-core-widget-tabs.min.js:15
Support for Leuven-Template & Scripts  at this forum
Support for the HWS-template for WD a.o.  http://wd34.weather-template.com/
Script sponsors https://support.leuven-template.eu/userlistScripts.php
Template sponsors https://support.leuven-template.eu/userlist.php

Offline CamarilloWX

  • CamarilloWX
  • Contributor
  • ***
  • Posts: 106
    • Camarillo Weather
Re: wxwugraphs stopped working after switching to https
« Reply #2 on: February 02, 2019, 12:37:11 AM »
You have to go into the scrips and change all http references to scripts from http to https.
These are the first two error messages.
Code: [Select]
wxwugraphs.php:1 Mixed Content: The page at 'https://www.camarilloweather.com/wxwugraphs.php' was loaded over HTTPS,
but requested an insecure script 'http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js'.
 This request has been blocked; the content must be served over HTTPS.

jq-core-widget-tabs.min.js:15 Uncaught ReferenceError: jQuery is not defined   at jq-core-widget-tabs.min.js:15

Thanks, that fixed the issue.  I didn't think to look for mixed content because my browser was showing a padlock.  The offending entry was in WUG-settings.php.
Eric