Author Topic: Atlas 06059 temp way off  (Read 202 times)

0 Members and 1 Guest are viewing this topic.

Offline ShadowCat66

  • Member
  • *
  • Posts: 1
Atlas 06059 temp way off
« on: December 31, 2018, 03:32:01 PM »
Hello one and all. I received the Atlas for Christmas. Out of the box, the touch screen did not work. They sent me a new one and I set up the system. Initially I received a temp reading of 158 and tried to calabrate with no luck. I read on another board that the Iion batteries would cause this and to switch to alkaline batteries. Now it says it is -40 and I can't find a way around it. Thoughts?
« Last Edit: December 31, 2018, 03:34:13 PM by ShadowCat66 »

Offline HalifaxWeatherStation

  • Member
  • *
  • Posts: 4
  • Acurite Atlas
    • Acurite Atlas @ WU
Re: Atlas 06059 temp way off
« Reply #1 on: December 31, 2018, 06:57:34 PM »
Sounds like you need a hardware replacement. To state the obvious, that's not normal.

Offline DoctorKnow

  • Forecaster
  • *****
  • Posts: 1403
Re: Atlas 06059 temp way off
« Reply #2 on: December 31, 2018, 07:31:32 PM »
You could try taking out the batteries, moving the A B C switch next to them, and put the batteries back in. If still not working, check that the cable that runs from the temp/hygro sensor inside the radiation shield is plugged in... (it plugs in inside the radiation shield, so you may can see it in there).


 

anything