Author Topic: Does anyone at WU care??? Reported Please Try later error after update 5.8.2  (Read 3485 times)

0 Members and 2 Guests are viewing this topic.

Offline jetspeedz

  • Member
  • *
  • Posts: 5
Since WU updated the Android app from 5.8.2 to 5.9x and every iteration of 5.9.x it has not worked since. Multiple people reported this including myself multiple times and not a single response from the WU team.

They essentially released the app without fully testing it on Lollipop and older android OS.

I'm shocked not only they don't respond but they don't seem to care as they have release 4 versions since 5.8.2 and it has not been fixed. Not all devices can upgrade to the latest OS.

Offline up10ad

  • USA Weather Finder
  • WxElement panel
  • Forecaster
  • *****
  • Posts: 574
  • Station will be back up someday...
    • Forecaster without a site
Not offering this as an excuse for the WU app issues, but Lollipop is a 4 year old version that isn't supported any longer. Version upgrade lag/unavailability is a major issue for Android and causes significant developer issues.
Rick (K6DYC)
Have you joined USAWeatherFinder.com yet?

Offline jetspeedz

  • Member
  • *
  • Posts: 5
It's just over 3 years old April 21, 2015 if you consider the last version, but I get it, the reality is not all phones will update to the latest OS, if limited by the hardware mfg like BB for example or the phones limitation itself or mobile carrier. Not everyone jumps to rush to get the newest shiny phone. If we did that with our cars can you just imagine. There needs to be some level of support from these app developers. I can run 5.8.2 fine but the new versions just crash, all it would take is for the developer to pay a little more attention and test on the most recent OS from each release, we are not talking about dozens, just a handful v5,6,7,8. Lazy, maybe but you can't hide behind the security cloak as your excuse when just one version ago the app worked and it has not been overhauled, this is a bug more than anything that can and should be resolved if they cared.

Worst part is they don't even respond to support or feedback.

Offline nincehelser

  • Forecaster
  • *****
  • Posts: 2908
    • nincehelser.com
Try reaching them on their Trello board.  That seems their main support vehicle as they rebuild the site.

https://trello.com/b/hqC0tb0u/weather-underground

Offline jetspeedz

  • Member
  • *
  • Posts: 5
thanks will do, i wasn't sure what site they frequented. I searched for the app and error and this site came up

Offline rormeister

  • Contributor
  • ***
  • Posts: 103
Try reaching them on their Trello board.  That seems their main support vehicle as they rebuild the site.

https://trello.com/b/hqC0tb0u/weather-underground

That used to work, but they pretty much abandoned any actions back in mid July. YMMV.

Offline Bushman

  • Forecaster
  • *****
  • Posts: 7175
    • Eagle Bay Weather
Do they care?  No, not really.  :)

Offline jetspeedz

  • Member
  • *
  • Posts: 5
Try reaching them on their Trello board.  That seems their main support vehicle as they rebuild the site.

https://trello.com/b/hqC0tb0u/weather-underground

That used to work, but they pretty much abandoned any actions back in mid July. YMMV.

I've posted and no response they don't care

Offline Mattk

  • Forecaster
  • *****
  • Posts: 1154
It appear to me a lot of people still think WU is the ants pants as most queries re not uploading to WU etc is targeted first at why device XYZ has failed to upload to WU when in most cases it's simply a WU failure.

Offline Reldel

  • Member
  • *
  • Posts: 4
WU App on Android has failed to update my weather station data since early October.  If I change my physical location the app fails to observe GPS location and has essentially been "stuck" for nearly two months.  I have uninstalled and left it off my phone for varying periods but reinstalling does not correct.  It appears I will have 68 degree temperature all winter at my house according to WU.  Hope they do use it to calculate global warming. 

Offline theslydog

  • Member
  • *
  • Posts: 27
Since WU updated the Android app from 5.8.2 to 5.9x and every iteration of 5.9.x it has not worked since.

I have to go into settings, apps and force quit the app then it will reopen.

Offline marmot

  • Member
  • *
  • Posts: 11
Since WU updated the Android app from 5.8.2 to 5.9x and every iteration of 5.9.x it has not worked since. Multiple people reported this including myself multiple times and not a single response from the WU team.

They essentially released the app without fully testing it on Lollipop and older android OS.


Glad to know I'm not alone.  My version would work but gave the "Try again later" error until I cleared the cache. 
I made the mistake of removing and reinstalling to try and fix it last night and now it just starts to the Sunset Between the Two Blue Mountains cartoon error screen with absolutely no user interactable controls. 

Not offering this as an excuse for the WU app issues, but Lollipop is a 4 year old version that isn't supported any longer. Version upgrade lag/unavailability is a major issue for Android and causes significant developer issues.

Sorry, but that is ridiculous. 
I installed 18-22 (lost track) other weather apps on my Amazon Fire with rooted Lollipop 5.1 (no upgrade available) and they all worked flawlessly (except for a few that won't rotate to landscape mode which is likely intentional).

The support life of an OS version is 10 years, not 4.


I think the new owners would rather push users to their other app and have laid off developers for this app or moved them to other projects. 


I have to go into settings, apps and force quit the app then it will reopen.

That's what I did since November (although it generally worked for weeks without doing that) until making the mistake of a reinstall.  So if you have a legacy copy installed, don't let it update. If it already has updated, and you are only getting the 'Try again later" error, do what theslydog suggests and just force quit and restart.  Reinstalling ends up with a non-working copy.

Wish I had backed up an older version to an APK file so I could revert my version... Hmmm, going to look for an older version APK now.  5.8.2 or earlier.

BTW, the version info I am finding says that all WU apps up to 5.9.4 are compatible with KitKat 4.4.
« Last Edit: February 01, 2019, 11:19:03 AM by marmot »

Offline marmot

  • Member
  • *
  • Posts: 11

Wish I had backed up an older version to an APK file so I could revert my version... Hmmm, going to look for an older version APK now.  5.8.2 or earlier.

BTW, the version info I am finding says that all WU apps up to 5.9.4 are compatible with KitKat 4.4.

Finally got around to manual installs.  See my results here.

Just reprint the last conclusion:   

If you are on Android 5.1 or earlier, version 5.8.2 never gets the error, stay on 5.8.2
Use manual apk install to move backwards if you already have the issue.

If a newer version ever fixes the issue; I'll post an update.

Offline Weatheroger

  • Senior Member
  • **
  • Posts: 58
using Android 7.1.1 without issues.

Offline marmot

  • Member
  • *
  • Posts: 11
using Android 7.1.1 without issues.

Yes, that is newer than 5.1. 
Not every device can upgrade to 7.1.1.

Offline farcus

  • Member
  • *
  • Posts: 20

Wish I had backed up an older version to an APK file so I could revert my version... Hmmm, going to look for an older version APK now.  5.8.2 or earlier.

BTW, the version info I am finding says that all WU apps up to 5.9.4 are compatible with KitKat 4.4.

Finally got around to manual installs.  See my results here.

Just reprint the last conclusion:   

If you are on Android 5.1 or earlier, version 5.8.2 never gets the error, stay on 5.8.2
Use manual apk install to move backwards if you already have the issue.

If a newer version ever fixes the issue; I'll post an update.

I have an older tablet running 5.1 and had the same problems described here.
Installed 5.8.2 apk and app then worked fine.
Let android update app to 5.9.4 and still works fine . . .
So it seems you just need to get past that screen after initially installing and then get setup - after that it should be fine to upgrade to a newer version of the app.

Offline marmot

  • Member
  • *
  • Posts: 11
Let android update app to 5.9.4 and still works fine . . .
So it seems you just need to get past that screen after initially installing and then get setup - after that it should be fine to upgrade to a newer version of the app.

Pretty sure I mentioned that it was working on 5.9.4 but it started getting the "Try Later Error" every start and wouldn't show any weather data without a forced stop/clear cache (see the title of this forum thread).  It also wouldn't forget a bad station (called the Wellston weather station the Lambert Airport station), so to attempt to fix the issues, I tried a "clear data" under settings->apps.  That's when the sunrise between two mountains error screen appeared.  Even an uninstall wouldn't fix it because some of the data remained.  Had to use a file manager and completely delete any folder and data file related to WU before I could get back to a working 5.9.4.  Most users wouldn't even know how to do that safely.

5.8.2 doesn't have any of these issues and so it's best not to upgrade to 5.9.x until some later version where the patch notes actually mention the issue has been dealt with.

Anyway, I already tried to go from 5.8.2 to the latest on the Play Store yesterday, did a "clear data" and right back to the sunset/mountain screen even after uninstall.  The error remains.

TL;DR If you are on Android 5.1 or earlier; don't upgrade past 5.8.2.
« Last Edit: April 22, 2019, 01:37:11 AM by marmot »

Offline farcus

  • Member
  • *
  • Posts: 20

Anyway, I already tried to go from 5.8.2 to the latest on the Play Store yesterday, did a "clear data" and right back to the sunset/mountain screen even after uninstall.  The error remains.

TL;DR If you are on Android 5.1 or earlier; don't upgrade past 5.8.2.

the problem there is that you cleared data after updating to 5.9.4
As I said . . . I can reproduce your problems when trying to install 5.9.4 on android 5.1
solution . . .Install 5.8.2 . . .  set everything up the way I want it. . . then update to 5.9.4 . . . everything works perfectly(ish)

Offline farcus

  • Member
  • *
  • Posts: 20
The support life of an OS version is 10 years, not 4.

Google supports android updates for two - three years. . . and a further year on top of that for security updates (for pixel, nexus and android one devices).
https://support.google.com/nexus/answer/4457705?hl=en
Other hardware manufacturers that use modified versions of android (Samsung, Sony, Huawei etc . . .) have much shorter OS update lifecycles - particularly Samsung, which is usually less than a year for their mid-range and cheaper devices.
« Last Edit: April 22, 2019, 02:10:38 AM by farcus »

Offline marmot

  • Member
  • *
  • Posts: 11
The support life of an OS version is 10 years, not 4.

Google supports android updates for two - three years. . . and a further year on top of that for security updates (for pixel, nexus and android one devices).
https://support.google.com/nexus/answer/4457705?hl=en
Other hardware manufacturers that use modified versions of android (Samsung, Sony, Huawei etc . . .) have much shorter OS update lifecycles - particularly Samsung, which is usually less than a year for their mid-range and cheaper devices.

You need to support that information about Samsung with some data.  They give out security updates for up to 3-4 years. https://security.samsungmobile.com/workScope.smsb  People repeat what you say, but don't list any actual models that were not supported after 1 year. 
Apple updated the 5 year old iPhone 5 to iOS 12. https://www.statista.com/chart/5824/ios-iphone-compatibility/
Windows 7 security patching won't end till Jan 2020, 10.5 years after it's release date. https://home.bt.com/tech-gadgets/computing/windows-7/windows-7-support-end-11364081315419
Some phone companies are still selling Samsung Android 6 phones to new customers.  Tracphone is selling the Samsung Galaxy J3 Luna Pro. https://shop.tracfone.com/shop/en/tracfonestore/phones/tf-samsung-galaxy-luna-pro-reconditioned

There is still a large base of Android 4, 5 and 6 tablets and phones that can receive in-app advertisements (such as the navigators in cars and trucks). 
It makes absolutely no marketing sense for Weather Underground to break their app for Android older than 6 because they make their money on banner advertisements in the app...

Offline farcus

  • Member
  • *
  • Posts: 20

You need to support that information about Samsung with some data.  They give out security updates for up to 3-4 years. https://security.samsungmobile.com/workScope.smsb  People repeat what you say, but don't list any actual models that were not supported after 1 year. 
Apple updated the 5 year old iPhone 5 to iOS 12. https://www.statista.com/chart/5824/ios-iphone-compatibility/
Windows 7 security patching won't end till Jan 2020, 10.5 years after it's release date. https://home.bt.com/tech-gadgets/computing/windows-7/windows-7-support-end-11364081315419
Some phone companies are still selling Samsung Android 6 phones to new customers.  Tracphone is selling the Samsung Galaxy J3 Luna Pro. https://shop.tracfone.com/shop/en/tracfonestore/phones/tf-samsung-galaxy-luna-pro-reconditioned


if you read my post (that you quoted) you'll see I differentiate between OS updates and security patches . . . as is the norm - at least for Android. As for IOS or Windows, I have no idea - I don't use either . . . but then, this is a thread about an Android app.

Offline marmot

  • Member
  • *
  • Posts: 11
but then, this is a thread about an Android app.

And my comment "The support life of an OS version is 10 years, not 4" was about all OS's, not just Android.

The life of the OS is pretty irrelevant to this conversation as this thread is about an app that has economic benefits to gain by being installed as widely as possible on as many versions of Android as possible.

Weather Underground  wants to have their in-app advertisements seen by the most eyeballs, then they need to continue support for older devices.

Offline marmot

  • Member
  • *
  • Posts: 11
the problem there is that you cleared data after updating to 5.9.4
As I said . . . I can reproduce your problems when trying to install 5.9.4 on android 5.1
solution . . .Install 5.8.2 . . .  set everything up the way I want it. . . then update to 5.9.4 . . . everything works perfectly(ish)

For a short while, then it will break again with the "Try Again Later" error or the weather station getting the wrong name error (becomes the local airport, which you mentioned here: https://www.wxforum.net/index.php?topic=36556.msg375672#msg375672) or the weather station default going back to a station you told it to forget. Try going back to 5.8.2 and see if your error about station near you becoming the local airport station doesn't go away.

That solution is only good for a day or two and I've already done it 3 times now.

If you are on Android 5.1 or earlier; don't upgrade past 5.8.2.
« Last Edit: Yesterday at 09:31:21 AM by marmot »

Offline farcus

  • Member
  • *
  • Posts: 20

For a short while, then it will break again with the "Try Again Later" error or the weather station getting the wrong name error (becomes the local airport, which you mentioned here: https://www.wxforum.net/index.php?topic=36556.msg375672#msg375672) or the weather station default going back to a station you told it to forget. Try going back to 5.8.2 and see if your error about station near you becoming the local airport station doesn't go away.


actually, I should update that thread.
There is no connection between that thread and this - as it is in relation to my phone running android pie (with WU 5.9.4).
I no longer see the error (incorrect location) on my phone so presumably WU have done some backend work that has corrected the issue.

Offline WeathermanIII

  • Member
  • *
  • Posts: 3
  • You don't need a weatherman. To know...
    • Marshall's Mini Mart
I signed up for Trello but when I tried to reach https://trello.com/b/hqC0tb0u/weather-underground I got "Board not found. This board may be private. If someone gave you this link, they may need to invite you to one of their boards or teams."
You don't need a weatherman. To know which way the wind blows.

 

anything