Author Topic: Acurite 3 in 1 wont reconnect.  (Read 148 times)

0 Members and 1 Guest are viewing this topic.

Offline SuperStorm

  • Member
  • *
  • Posts: 3
Acurite 3 in 1 wont reconnect.
« on: October 09, 2018, 10:30:17 PM »
   I have a 3 in 1 and I took it down to clean it, replace the batteries (normal maitnence). The issue is is that the sensor is putting out a signal from what I can tell but the display resist to connect no matter what I do. Can someone please assist me, the unit is only 2 years old. I got it at Homedepot on clearence for 8 dollars when its ussually like 80 dollars so if I have to buy a new weather station its not really a big deal.

Online nincehelser

  • Forecaster
  • *****
  • Posts: 2520
    • nincehelser.com
Re: Acurite 3 in 1 wont reconnect.
« Reply #1 on: October 09, 2018, 10:47:24 PM »
   I have a 3 in 1 and I took it down to clean it, replace the batteries (normal maitnence). The issue is is that the sensor is putting out a signal from what I can tell but the display resist to connect no matter what I do. Can someone please assist me, the unit is only 2 years old. I got it at Homedepot on clearence for 8 dollars when its ussually like 80 dollars so if I have to buy a new weather station its not really a big deal.

Any chance you might have flipped the A/B/C switch in the sensor while cleaning it?

Offline SuperStorm

  • Member
  • *
  • Posts: 3
Re: Acurite 3 in 1 wont reconnect.
« Reply #2 on: October 09, 2018, 10:50:32 PM »
Both units were on channel A so I switched both to B. I wish the issue was that simple, but no.

Offline SuperStorm

  • Member
  • *
  • Posts: 3
Re: Acurite 3 in 1 wont reconnect.
« Reply #3 on: October 11, 2018, 02:51:57 PM »
My unit just now reconnected. It must have gotten scared because if it didnt work I would have bought an atlas lol :grin:

 

anything