Author Topic: Atlas Battery Pack not working  (Read 468 times)

0 Members and 1 Guest are viewing this topic.

Offline SkellyCA

  • Senior Member
  • **
  • Posts: 62
Atlas Battery Pack not working
« on: October 03, 2018, 07:52:39 PM »
I bought the external Battery park for the Atlas and it isn't working. I'm not sure if it's the battery pack or the connection in the Atas. Atlas works fine with batteries directly installed. I used brand new energizers in both. I voltage for the battery pack seems to read 2.8v

I bought the Atlas on Amazon and the battery pack at Acurite.

I guess I should call Acurite and see if they want to replace the battery pack first?

If it's not the battery pack, would they replace the Atlas or do I need to contact Amazon for that?
If you're not living on the edge, you're taking up to much room.

Offline nincehelser

  • Forecaster
  • *****
  • Posts: 2526
    • nincehelser.com
Re: Atlas Battery Pack not working
« Reply #1 on: October 03, 2018, 08:07:16 PM »
I bought the external Battery park for the Atlas and it isn't working. I'm not sure if it's the battery pack or the connection in the Atas. Atlas works fine with batteries directly installed. I used brand new energizers in both. I voltage for the battery pack seems to read 2.8v

I bought the Atlas on Amazon and the battery pack at Acurite.

I guess I should call Acurite and see if they want to replace the battery pack first?

If it's not the battery pack, would they replace the Atlas or do I need to contact Amazon for that?

Sounds like a plan.  I would expect they would take care of the whole thing if it is necessary.

Offline SkellyCA

  • Senior Member
  • **
  • Posts: 62
Re: Atlas Battery Pack not working
« Reply #2 on: October 04, 2018, 06:49:41 PM »
I contacted chat today. They asked what kind of batteries I used. I said new energizer alkalines. Then they asked if that light near the battery compartment was blinking. I said nope.

So they are sending me a new battery pack.

I don't think it's the battery pack, although I hope it is(easiest to fix), I think it's the connection that the battery pack cable plugs in to. If you ever get a chance, look in that hole that the battery pack cable plugs in to on the Atlas. To me it looks to deep to make a good connection.
If you're not living on the edge, you're taking up to much room.

Offline nincehelser

  • Forecaster
  • *****
  • Posts: 2526
    • nincehelser.com
Re: Atlas Battery Pack not working
« Reply #3 on: October 05, 2018, 12:46:32 AM »
I don't think it's the battery pack, although I hope it is(easiest to fix), I think it's the connection that the battery pack cable plugs in to. If you ever get a chance, look in that hole that the battery pack cable plugs in to on the Atlas. To me it looks to deep to make a good connection.

I've never used the battery pack.  Just the AC adapter that uses the same connection in the battery compartment.

I tested that configuration for several months with no problems.

Offline SkellyCA

  • Senior Member
  • **
  • Posts: 62
Re: Atlas Battery Pack not working
« Reply #4 on: October 05, 2018, 09:30:22 AM »
Good. That gives me hope that it could be the battery pack. That's the easy fix. I'd really hate to have to pack up the Atlas and send it back.

If I had an ac outlet near the unit, I would have went that way. Battery pack was the next best thing since the unit is 3/4 of the way up a 20' pole. Anemometer is at the top.
If you're not living on the edge, you're taking up to much room.

Offline DoctorKnow

  • Forecaster
  • *****
  • Posts: 1335
Re: Atlas Battery Pack not working
« Reply #5 on: October 05, 2018, 09:44:01 AM »
I suggest installing the Atlas at 4 - 6 ft above ground, but I know in areas with obstructions to the sun, that this is not possible for a lot of applications. I really like the wind extension kits. 


Offline SkellyCA

  • Senior Member
  • **
  • Posts: 62
Re: Atlas Battery Pack not working
« Reply #6 on: October 05, 2018, 10:29:01 AM »
I suggest installing the Atlas at 4 - 6 ft above ground, but I know in areas with obstructions to the sun, that this is not possible for a lot of applications. I really like the wind extension kits.

That's not possible in my yard, to much shade.
If you're not living on the edge, you're taking up to much room.

Offline SkellyCA

  • Senior Member
  • **
  • Posts: 62
Re: Atlas Battery Pack not working
« Reply #7 on: October 11, 2018, 07:27:39 PM »
Update:

New battery pack came today. I plugged it in and that led that was supposed to flash or whatever did nothing!

So I went in the house and reset the display. Then I re-added the Atlas and it found it and added it. So it works good now but I was worried when that light didn't do anything.

So now I'm a happy camper with my Atlas.  :grin:
If you're not living on the edge, you're taking up to much room.

 

anything