Author Topic: Station Stickers No Data  (Read 576 times)

0 Members and 1 Guest are viewing this topic.

Offline Whitbyweather

  • Senior Member
  • **
  • Posts: 54
    • Whitby Weather
Station Stickers No Data
« on: August 31, 2018, 05:42:16 AM »
Hi,
The station stickers are showing no data and have been down for 48 hours. I have tried emailing but no reply and no action. Anyone else having the same problem? :-|

Offline galfert

  • Forecaster
  • *****
  • Posts: 569
Re: Station Stickers No Data
« Reply #1 on: August 31, 2018, 06:59:56 AM »
Yup. Just look at some signatures around here. No Data.
Trust me they know. They are working on it. But don't wait up for a quick fix.
WS-2902A | ObserverIP | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Tele-Pole flag pole is here (not installed yet)

Offline Whitbyweather

  • Senior Member
  • **
  • Posts: 54
    • Whitby Weather
Re: Station Stickers No Data
« Reply #2 on: August 31, 2018, 07:24:51 AM »
Many thanks for the heads up, will try to be patient! :-)

Offline havtrail

  • Senior Member
  • **
  • Posts: 54
    • Haverford Weather Station
Re: Station Stickers No Data
« Reply #3 on: August 31, 2018, 09:27:33 AM »
If you mean the WU "weather sticker" widgets, I am using the Flash-based one (the first one they show under their "Widgets" tab), and it has been working constantly over the past two days. See the website linked below.

Rich K.
« Last Edit: August 31, 2018, 09:29:37 AM by havtrail »
Onset HOBO RX3003 Cellular
http://weather.havtrail.com
WU KPAHAVER17

Offline WheelinDealin

  • Member
  • *
  • Posts: 21
Re: Station Stickers No Data
« Reply #4 on: September 03, 2018, 04:16:33 PM »
I feel stupid. For the life of me I can not figure out how to attach weather stickers to my posts here. I tried everything and nothing works. Please advise. Thank you.

Offline galfert

  • Forecaster
  • *****
  • Posts: 569
Re: Station Stickers No Data
« Reply #5 on: September 03, 2018, 04:54:43 PM »
If you mean the WU "weather sticker" widgets, I am using the Flash-based one (the first one they show under their "Widgets" tab), and it has been working constantly over the past two days. See the website linked below.

Rich K.

The Flash one works only sort of. Flash is no longer fully supported in Chrome so it doesn't run without clicking on it. The other stickers that don't use Flash and are more popular do not work. Look at yours...they both say, "No Data."
https://www.wunderground.com/personal-weather-station/widgets?ID=KPAHAVER17

So the Stickers (Widgets) are broken and WU knows about it. Who knows when they will fix them.

Same deal with the Gold Stars not work. I think and this is only my theory is that WU did some small thing like turn off Stickers (Widgets) to improve system performance, at least till they move to a new platform to support the demand. They also cut out all MADIS stations from reporting. Could again be an attempt to gain system performance. Remember it was bad folks...it was really bad. So these I think are just quick hopefully temporary performance fixes.
« Last Edit: September 03, 2018, 04:58:16 PM by galfert »
WS-2902A | ObserverIP | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Tele-Pole flag pole is here (not installed yet)

Offline galfert

  • Forecaster
  • *****
  • Posts: 569
Re: Station Stickers No Data
« Reply #6 on: September 03, 2018, 05:48:38 PM »
I feel stupid. For the life of me I can not figure out how to attach weather stickers to my posts here. I tried everything and nothing works. Please advise. Thank you.

Go to your WU Widgets (stickers) page (replace STATIONID with your station's ID):
https://www.wunderground.com/personal-weather-station/widgets?ID=STATIONID

Copy the code for the one you from that page.

Then you need to modify to be in this form (replace STATIONID with your station's ID):
Code: [Select]
[url=http://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=STATIONID/][img]http://banners.wunderground.com/cgi-bin/banner/ban/wxBanner?bannertype=pws250_both&weatherstationcount=STATIONID[/img][/url]
That was only an example for the WU with Both Metric and English Units. But you can use that format to fit the sticker version you prefer to use.

Not much point in WU stickers because they are not working at the moment (shows No Data). Except for the Flash one but then it doesn't automatically run in Chrome...so that one is pointless too.

« Last Edit: September 03, 2018, 05:53:36 PM by galfert »
WS-2902A | ObserverIP | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Tele-Pole flag pole is here (not installed yet)

Offline havtrail

  • Senior Member
  • **
  • Posts: 54
    • Haverford Weather Station
Re: Station Stickers No Data
« Reply #7 on: September 03, 2018, 08:36:00 PM »
If you mean the WU "weather sticker" widgets, I am using the Flash-based one (the first one they show under their "Widgets" tab), and it has been working constantly over the past two days. See the website linked below.

Rich K.

The Flash one works only sort of. Flash is no longer fully supported in Chrome so it doesn't run without clicking on it. The other stickers that don't use Flash and are more popular do not work. Look at yours...they both say, "No Data."
https://www.wunderground.com/personal-weather-station/widgets?ID=KPAHAVER17

So the Stickers (Widgets) are broken and WU knows about it. Who knows when they will fix them.

Same deal with the Gold Stars not work. I think and this is only my theory is that WU did some small thing like turn off Stickers (Widgets) to improve system performance, at least till they move to a new platform to support the demand. They also cut out all MADIS stations from reporting. Could again be an attempt to gain system performance. Remember it was bad folks...it was really bad. So these I think are just quick hopefully temporary performance fixes.

Actually the Flash-based sticker works. I have had it running under Chrome/Win7Pro, Chrome/Win10, Firefox/Win10 and IE/Win10. You have to have the Flash software and your browser needs to be set to permit its use. (I'm not a fan of Flash, but the Flash-based WU widget is the best one, providing the most information.) It starts up for me without having to click on it, and it auto-updates.

The public kiosk display I have been working with uses Chrome (with "kiosk mode") and Win7Pro. The Flash-based sticker would update for hours or several days, and then stop. The issue in this case seemed to be the computer and the network it is on. My solution was to program my webpage that incorporates the Flash sticker to refresh itself. Thus the entire page is refreshed, in my case every minute. I added this code in the <head> section of the HTML:

<!-- refresh page every 60 seconds -->
<meta http-equiv="refresh" content="60" />

You may also need to modify the sticker code from "freq=60" to just "freq=" to stop the sticker itself from trying to update itself.

This has been working very well. Basically, I am calling the webpage and the sticker from scratch every minute. I have modified the webpage linked below my signature to also do this, in case anyone wants to see it.

Rich K.
Onset HOBO RX3003 Cellular
http://weather.havtrail.com
WU KPAHAVER17

Offline havtrail

  • Senior Member
  • **
  • Posts: 54
    • Haverford Weather Station
Re: Station Stickers No Data
« Reply #8 on: September 03, 2018, 08:43:23 PM »
By the way, I also learned that you can change the size of the displayed WU sticker. I increased the size of the Flash-based one to make the numbers more prominent and readable on the kiosk from a distance. I just noted the height and width dimensions in the WU-supplied code, and increased them proportionately to maintain the "aspect ratio" of the sticker.

Rich K.
Onset HOBO RX3003 Cellular
http://weather.havtrail.com
WU KPAHAVER17

Offline galfert

  • Forecaster
  • *****
  • Posts: 569
Re: Station Stickers No Data
« Reply #9 on: September 03, 2018, 09:40:36 PM »
Just because you enabled Flash to run by changing your browser default setting doesn't make that widget run for other people automatically. So the appeal for most people to add the Flash widget to their personal weather website might be a bit low.

I suppose in a kiosk weather system to enable Flash to run automatically in the browser is okay. But for regular computer use I think I'll go with Google's advice and keep Flash disabled. This is a change that Google made to Chrome a while back. It is a resource hog and a potential security exploit, not to mention it was often abused by websites to their ads and also automatic audio playback.

« Last Edit: September 03, 2018, 09:44:08 PM by galfert »
WS-2902A | ObserverIP | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Tele-Pole flag pole is here (not installed yet)

Offline havtrail

  • Senior Member
  • **
  • Posts: 54
    • Haverford Weather Station
Re: Station Stickers No Data
« Reply #10 on: September 04, 2018, 12:00:34 PM »
Yes, your first sentence is true. My township put the Flash-based sticker on its website. Everybody saw it and thought it looked great, but I couldn't see it at all because my Firefox browser did not have Flash enabled. All I saw was an empty space where the sticker should have been. If anyone looks at the WU widgets page and sees no example display of this first sticker, that is why they don't see one. I had that problem at first, too - totally confusing!

If I am remembering right, it is also possible to have Chrome permit the use of Flash on the selected webpage only, so you are not throwing the doors wide open. I asked WU to convert this sticker to a non-Flash design on July 25 under "WU - Let us know your issues." That would be the best possible solution, especially now that the other, less informative stickers have been disabled.

I'd be totally at a loss for a good public display without this sticker.

Rich K.
Onset HOBO RX3003 Cellular
http://weather.havtrail.com
WU KPAHAVER17

Offline galfert

  • Forecaster
  • *****
  • Posts: 569
Re: Station Stickers No Data
« Reply #11 on: September 04, 2018, 12:26:21 PM »
Okay thanks for the tip with Flash on Chrome. I looked at it further and yes the default setting is not disabled but to "ask first" and then remember the setting per site as you mentioned. Still a bit of a hindrance to deal with. But I suppose it is better than nothing at this point.

Oddly enough the other regular widgets seem to be working today. I still wouldn't count of them as it is too soon as to their reliability of staying up.


 
WS-2902A | ObserverIP | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Tele-Pole flag pole is here (not installed yet)

Offline Whitbyweather

  • Senior Member
  • **
  • Posts: 54
    • Whitby Weather
Re: Station Stickers No Data
« Reply #12 on: September 06, 2018, 11:49:21 AM »
Sent loads of emails, pleading for at least some aknowledgement but still no stickers for me. just some old fashioned good manners would be good and letting us know what is happening!

Offline galfert

  • Forecaster
  • *****
  • Posts: 569
Re: Station Stickers No Data
« Reply #13 on: September 06, 2018, 02:18:59 PM »
Whitbyweather,
I noticed that you are using Wunderground software module for Weatherlink. You may want to take a look a this thread. I don't know if changing software will help your WU sticker issue. But I thought it could be useful information for you. INORTHYO14 is your station right?

https://www.wxforum.net/index.php?topic=35034.0

WS-2902A | ObserverIP | WeatherBridge (Meteobridge)
WU: KFLWINTE111  |  PWSweather: KFLWINTE111
CWOP: FW3708  |  AWEKAS: 14814
Tele-Pole flag pole is here (not installed yet)

Offline Whitbyweather

  • Senior Member
  • **
  • Posts: 54
    • Whitby Weather
Re: Station Stickers No Data
« Reply #14 on: September 07, 2018, 08:09:58 AM »
Thank you very much for the link, I will take a look!  :-)