Author Topic: What PHP Version Is Required  (Read 374 times)

0 Members and 1 Guest are viewing this topic.

Offline DaculaWeather

  • It's a Jeep thing... you wouldn't understand.
  • WxElement panel
  • Forecaster
  • *****
  • Posts: 3159
  • SCCA EM #156
    • North Georgia and US Weather
What PHP Version Is Required
« on: May 11, 2018, 02:41:24 PM »
I'm having a battle with a hosting company. Everything has been working fine for years until today when I discovered that IXWebhosting sold my account to Site5. They migrated me overnight and I woke up to 4 domains not working.

After battling with them all day, I still have PHP errors. What version of PHP is needed for the current version of advforecast_dropdown.php (that's my name for it, it's version 5.04). PHP is currently 5.5.38

Thanks guys...

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6747
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: What PHP Version Is Required
« Reply #1 on: May 11, 2018, 03:32:47 PM »
PHP 5.5 will work, but PHP 5.6 or PHP 7.2 are the current releases (fully supported).  PHP 5.5 went off support in late 2016.

See http://php.net/supported-versions.php for version info.

What PHP errors are you seeing (from error_log )?
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline DaculaWeather

  • It's a Jeep thing... you wouldn't understand.
  • WxElement panel
  • Forecaster
  • *****
  • Posts: 3159
  • SCCA EM #156
    • North Georgia and US Weather
Re: What PHP Version Is Required
« Reply #2 on: May 11, 2018, 03:47:51 PM »
This
 [ You are not allowed to view attachments ]

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6747
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: What PHP Version Is Required
« Reply #3 on: May 11, 2018, 05:55:00 PM »
Ahh... that's a PHP setup error.. your hoster has not enabled curl functions in PHP.. Call their tech support to get that fixed.

Many of the Saratoga scripts that access external websites for data now use cURL functions (to allow http/https support).  Standard PHP installations do have curl available.. someone just forgot when they did the PHP upgrade at your hoster.
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline DaculaWeather

  • It's a Jeep thing... you wouldn't understand.
  • WxElement panel
  • Forecaster
  • *****
  • Posts: 3159
  • SCCA EM #156
    • North Georgia and US Weather
Re: What PHP Version Is Required
« Reply #4 on: May 11, 2018, 06:10:20 PM »
Yes, because one of my other domains that was migrated uses the same identical script and it works.

 

anything