Author Topic: Slow Website  (Read 549 times)

0 Members and 1 Guest are viewing this topic.

Offline Farmtalk

  • Fitzweather
  • Forecaster
  • *****
  • Posts: 4716
    • Fitzweather
Slow Website
« on: April 24, 2018, 02:06:44 PM »
I was curious to see if folks on here might have any suggestions on speeding up the load time of a website. My website is fairly minimalistic, and yet it sometimes takes upwards of 15 seconds to load. I do not have a cron job for the advisories on the home page, but I only use two counties, so I don't think that would be the cause of it.

Any suggestions would be greatly appreciated.

The domain is http://www.fitzweather.org
Weather Software-> GREarth, GRAnalyst 2.xx, MRLevel3, GRLevel 3 2.xx, Bufkit, GRLevel2, WXSim, and Radarscope.
Weather Station-> Ambient Weather WS-1090 Fine Offset
Weather Station Software-> Weather Display 10.37S, Cumulus 1.94
CoCoRaHS ID->  WV-KN-27
Administrator-> www.fitzweather.org

Online PaulMy

  • Forecaster
  • *****
  • Posts: 4151
    • KomokaWeather
Re: Slow Website
« Reply #1 on: April 24, 2018, 03:32:40 PM »
Hi Joseph,
This will not help you but it took 39 seconds to load the page for me.  Much of that can be something on my system here as my own page took me 59 seconds where usually it has been about 10 sec www.komokaweather.ca

Enjoy,
Paul

Davis Vantage Pro 2 Plus 24-FARS Wireless
Envoy/USB DataLogger/Cumulus v.1.9.4   -   Vue Console/WiFiLogger
Komoka, ON  Canada
www.komokaweather.ca   www.komokaweather.com   www.komokaweather.com/weather28/   www.komokaweather.com/pws/index.php
Blitzortung Station #1076 www.lightningmaps.org/blitzortung7/america/index.php?bo_page=statistics&bo_show=network&lang=en&bo_station_id=969

Online Otis

  • (aka Paul)
  • Forecaster
  • *****
  • Posts: 518
    • Lake Huron Weather
Re: Slow Website
« Reply #2 on: April 24, 2018, 04:04:57 PM »
You could try reducing the file size of your banner.  Right now it is about 128k, I got it down to about 49k.
Most likely will not make much of a difference but worth a try.

Davis Vantage Pro2, Serial Data Logger
WD 10.37S-(b60), VWS V15.00p03, Weatherlink 6.0.3,  Fling 2.35, Broadwave 2.0, Win 7 Pro 64Bit
KMICHEBO10 - CW3699 - Cheboygan, MI

Offline ValentineWeather

  • Forecaster
  • *****
  • Posts: 5471
Re: Slow Website
« Reply #3 on: April 24, 2018, 06:44:42 PM »
The get-USNO-sunmoon.php API address has been hanging my site.  Another thread was started about issues with API. Its been doing it off and on for couple years now its just worse this week.
 
I'm not running any cron job so yesterday removed the sun/moon page and renamed get-USNO-sunmoon-temp.php so it doesn't try and fetch data allowing site to load quickly.
You still get the basic sun and moon settings built into Saratoga script for front page.
Site now loads fast ... 8-)
Randy

Offline waiukuweather

  • Forecaster
  • *****
  • Posts: 624
Re: Slow Website
« Reply #4 on: April 24, 2018, 08:41:49 PM »
I would say it is hanging on exactly that
as soon as that times out, it all loads fast

Offline Farmtalk

  • Fitzweather
  • Forecaster
  • *****
  • Posts: 4716
    • Fitzweather
Re: Slow Website
« Reply #5 on: April 25, 2018, 06:48:02 AM »
I have made my banner size smaller, and I got rid of the UNSO-sunmoon-temp.php story from my server.

That seems to have fixed the issue!

Thanks for the help everybody.  8-)
Weather Software-> GREarth, GRAnalyst 2.xx, MRLevel3, GRLevel 3 2.xx, Bufkit, GRLevel2, WXSim, and Radarscope.
Weather Station-> Ambient Weather WS-1090 Fine Offset
Weather Station Software-> Weather Display 10.37S, Cumulus 1.94
CoCoRaHS ID->  WV-KN-27
Administrator-> www.fitzweather.org

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 3221
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Slow Website
« Reply #6 on: April 25, 2018, 09:08:56 AM »
I find WebPageTest to be useful for these kind of situations. When the USNO was causing the problem, I could see 30+ seconds of lag, then everything loaded in rapid succession afterwards. (apparently after a time out)

I have since disabled USNO, since this issue seems to recur and severely affects page loading. Whatever small error exists in the estimate for sunrise/set doesn't matter to me, vs this issue.

I just re-ran it and found that a Facebook js was causing a loading issue. I was able to comment it out. (it wasn't showing anyways)

I also made the CoCoRaHS logo local to my web server instead of pulling it from CoCoRaHS. Between the two things, I shaved off about 3 seconds in load time.

Greg H.


Blitzortung Stations #706 and #1682
CoCoRaHS: MI-PI-1
CWOP: CW4114 and KE8DAF-13
WU: KMIROGER7
Amateur Radio Callsign: KE8DAF

 

anything