Author Topic: WU - Let us know your issues  (Read 54448 times)

0 Members and 1 Guest are viewing this topic.

Offline orchidman

  • Member
  • *
  • Posts: 38
Re: WU - Let us know your issues
« Reply #750 on: July 16, 2018, 01:43:06 PM »
Hi, I'm having an odd problem with our WU PWS page (https://www.wunderground.com/personal-weather-station/dashboard?ID=KPAHAVER17) over the weekend. Our station has disappeared from the Radar Map and the Current Conditions for it have been static the whole time, yet the Weather History Graphs farther down on the PWS page are updating fine.

I am having the same problem.  KOKOKLAH58
Gary
Oklahoma City, OK
Davis Advantage Pro2, WL, VWS, WU KOKOKLAH58

Offline BigOkie

  • Forecaster
  • *****
  • Posts: 1330
  • Tulsa, OK
    • KOKTULSA13
Re: WU - Let us know your issues
« Reply #751 on: July 16, 2018, 02:40:09 PM »
I'm seeing an issue on my statoin for the last several days where the high temp in the summary is usually several degrees difference than my station.  Confusing.  Attachments included.  Today for example WU reports my high as 97 but my station sofar reports as 91.

KOKTULSA13



Current setup: Davis Vantage Pro 2 Plus Wireless
Weather radios:
Reecom R-1650
Sangean CL-100
Uniden Home Patrol I

Offline LizMarr

  • Liz M.
  • Member
  • *
  • Posts: 17
    • Marr family weather
Re: WU - Let us know your issues
« Reply #752 on: July 16, 2018, 03:02:33 PM »
Hi, I'm having an odd problem with our WU PWS page (https://www.wunderground.com/personal-weather-station/dashboard?ID=KPAHAVER17) over the weekend. Our station has disappeared from the Radar Map and the Current Conditions for it have been static the whole time, yet the Weather History Graphs farther down on the PWS page are updating fine.

Have you tried a different web browser? Seriously, sometimes updates with the browser will "break" something, and often the cache gets locked so that certain parts of the page use old data.


Offline havtrail

  • Senior Member
  • **
  • Posts: 51
    • Haverford Weather Station
Re: WU - Let us know your issues
« Reply #753 on: July 16, 2018, 03:40:45 PM »
Hi, I'm having an odd problem with our WU PWS page (https://www.wunderground.com/personal-weather-station/dashboard?ID=KPAHAVER17) over the weekend. Our station has disappeared from the Radar Map and the Current Conditions for it have been static the whole time, yet the Weather History Graphs farther down on the PWS page are updating fine.

Have you tried a different web browser? Seriously, sometimes updates with the browser will "break" something, and often the cache gets locked so that certain parts of the page use old data.

Yes, I have accessed it using 3 different browsers, 3 different PCs, logged in and not logged in, etc. All no good.
Onset HOBO RX3003 Cellular
http://weather.havtrail.com
WU KPAHAVER17

Offline Intheswamp

  • Early on one frosty morn'...
  • Forecaster
  • *****
  • Posts: 1366
  • Sure...I know enough to be dangerous, now.
    • Beeweather
Re: WU - Let us know your issues
« Reply #754 on: July 16, 2018, 06:08:08 PM »
"Houston...we have a problem."

Davis VP2, v3.12
Cumulus v1.9.4  Build 1079
Today's weather beats no weather at all!
www.beeweather.com

Offline bagocina

  • Member
  • *
  • Posts: 4
    • eMeteo.sk
Re: WU - Let us know your issues
« Reply #755 on: July 18, 2018, 04:47:08 PM »
Hi, I'm having an odd problem with our WU PWS page (https://www.wunderground.com/personal-weather-station/dashboard?ID=KPAHAVER17) over the weekend. Our station has disappeared from the Radar Map and the Current Conditions for it have been static the whole time, yet the Weather History Graphs farther down on the PWS page are updating fine.

The station is a HOBO RX3003 cellular unit which uploads to HOBOlink, which then feeds the data to WU. It's been reactivated and running since mid-April, with no webcam involved. A test of the feed on the HOBOlink site came back "successful," and it's clear from the updating graphs on WU that WU is getting data. But the Radar Map and the Current Conditions are not updating, and the station's related "weather sticker" widgets are present but data-less.

Looking for a solution. Any help appreciated. The problem is making our public kiosks look embarrassing...

Rich K.
weather.havtrail.com

I have same problem about 5-6 days with my PWS (https://www.wunderground.com/personal-weather-station/dashboard?ID=IBRATISL587). Current conditions not updating but graph and table updating correctly. I wrote to support, but they answered only once, that is my issues with PWS and never more. Today I saw new issue with each PWS on whole WU. Randomly is not available PWS pages (attached image).


Amateur weather stations on eMeteo.sk

eMeteo.sk PWS = Raspberry Pi 3 + DHT22 + BMP180 + Sparkfun Weather Rack + SwitchDoc Weather Board + OpenSource Python Code + Own Shell scripts + Own page code

Offline orchidman

  • Member
  • *
  • Posts: 38
Re: WU - Let us know your issues
« Reply #756 on: July 18, 2018, 06:05:59 PM »
Hi, I'm having an odd problem with our WU PWS page (https://www.wunderground.com/personal-weather-station/dashboard?ID=KPAHAVER17) over the weekend. Our station has disappeared from the Radar Map and the Current Conditions for it have been static the whole time, yet the Weather History Graphs farther down on the PWS page are updating fine.

Have you tried a different web browser? Seriously, sometimes updates with the browser will "break" something, and often the cache gets locked so that certain parts of the page use old data.
I am having the same problem at 3 different locations.  2 are using Firefox and one is using chrome and IE.
Gary
Oklahoma City, OK
Davis Advantage Pro2, WL, VWS, WU KOKOKLAH58

Offline wunderground-PWS

  • Senior Member
  • **
  • Posts: 58
Re: WU - Let us know your issues
« Reply #757 on: July 19, 2018, 10:05:28 AM »
Please check the time on your station and or computer that uploads the data.  It looks like you might be sending data with a clock skew off about 10 minutes in the past.

Offline bagocina

  • Member
  • *
  • Posts: 4
    • eMeteo.sk
Re: WU - Let us know your issues
« Reply #758 on: July 19, 2018, 11:30:27 AM »
Please check the time on your station and or computer that uploads the data.  It looks like you might be sending data with a clock skew off about 10 minutes in the past.

Hello,
data which I send to WU is with actual time in UTC. As I wrote, data in graphs and table on station's page on WU (https://www.wunderground.com/personal-weather-station/dashboard?ID=IBRATISL590) are actual and updating correctly with correct time. But Currently Conditions data are freezed about week on same values 24 hours of day.

Currently Conditions on my PWS freezed from day to day, without any changes in code.

As I read, this problem have several people with their PWS in last time.

This not look like problem with PWS but with WU.


Amateur weather stations on eMeteo.sk

eMeteo.sk PWS = Raspberry Pi 3 + DHT22 + BMP180 + Sparkfun Weather Rack + SwitchDoc Weather Board + OpenSource Python Code + Own Shell scripts + Own page code

Offline orchidman

  • Member
  • *
  • Posts: 38
Re: WU - Let us know your issues
« Reply #759 on: July 19, 2018, 12:03:33 PM »
On my main page, my site doesn't show up on the map.  The circle is there but no value in it.  All the 'Current Conditions' are frozen (wrong) but below in the 'Weather History', all the values are correct and current.  The 'Weather History Graph' is current and correct.

When I select the 'Forecast' page for my site (Oklahoma City, OK) right below the city, next to my location, the temp is the wrong value.  However for the 'Today' tab, the time is correct along with the Temp and wind values.

This is so strange, the data is correct in some areas and not in other areas.  I will not be able to check the Davis & PC time to see if it is correct until this evening.
Gary
Oklahoma City, OK
Davis Advantage Pro2, WL, VWS, WU KOKOKLAH58

Offline weathereric

  • Member
  • *
  • Posts: 2
Re: WU - Let us know your issues
« Reply #760 on: July 19, 2018, 12:23:52 PM »
I'm experiencing all the issues with "current conditions" others have recently posted about.  The host computer's time is accurate to a few milliseconds.  Weather reported to APRS is correct as is weather history on WU.  I've been travelling a bit but I think this problem has been present for about a week.

Offline jerryg

  • Forecaster
  • *****
  • Posts: 738
  • weather is never boring
    • victoria texas weather
Re: WU - Let us know your issues
« Reply #761 on: July 19, 2018, 01:34:26 PM »
Wu is screwed up big time, this am my station was reporting fine now it is not reporting. When i send test it comes back ok and when i go to some of my favorite stations they come back with frozen info and all the info below that is blank. Man they sure got this site screwed up big time. I have been on wu for many years and never has it been this bad for so long.  ](*,)

Offline LizMarr

  • Liz M.
  • Member
  • *
  • Posts: 17
    • Marr family weather
Re: WU - Let us know your issues
« Reply #762 on: July 19, 2018, 06:11:00 PM »
Wu is screwed up big time, this am my station was reporting fine now it is not reporting. When i send test it comes back ok and when i go to some of my favorite stations they come back with frozen info and all the info below that is blank. Man they sure got this site screwed up big time. I have been on wu for many years and never has it been this bad for so long.  ](*,)

I just checked mine at 15:04 PST, 19 July 2018 and everything is in order. There are no major gaps in data in spite of the fact I just spent the last 3 hours configuring a new router. Even the webcam is working.

Perhaps there is some regional interference going on.

Offline wunderground-PWS

  • Senior Member
  • **
  • Posts: 58
Re: WU - Let us know your issues
« Reply #763 on: July 19, 2018, 06:30:42 PM »
Users who are having Issues with the data showing up in your graph, but not in the current conditions module.

1) What station are you using
2) what software

I think we know what is happening, and will implement a fix by the end of today.  We tried to separate out observations that are current, vs ones that are being sent to fill in gaps in history.  It looks like we tuned the history window a little too aggressively (anything older than 2 mins is considered not current)  we didn't take into account that 1) peoples clocks aren't always right and 2) that some stations go through a third party relay, and might take 2 minutes to get to us. 

We are setting the allowable delay to 15 minutes

Offline wunderground-PWS

  • Senior Member
  • **
  • Posts: 58
Re: WU - Let us know your issues
« Reply #764 on: July 19, 2018, 06:36:09 PM »
Wu is screwed up big time, this am my station was reporting fine now it is not reporting. When i send test it comes back ok and when i go to some of my favorite stations they come back with frozen info and all the info below that is blank. Man they sure got this site screwed up big time. I have been on wu for many years and never has it been this bad for so long.  ](*,)

I know this is a frustrating time, we have completely re-written the ingestion system, its a complex beast that had a lot of unacceptable hacks to "fix" stations that weren't reporting correctly.  We made some decisions to not support many of those hacks any longer.

As we move forward and notice issues, we are implementing solutions that gracefully deal with things like stations with time skew and with atypical payloads.  These things are not always possible to anticipate in testing.

We aren't re-writing this code for fun, it was in serious risk of failing permanently.  While we are experiencing glitches now, i hope you can appreciate the amount of work the WU team has put into fixing these systems and making it possible for the PWS network to continue for years to come

Offline havtrail

  • Senior Member
  • **
  • Posts: 51
    • Haverford Weather Station
Re: WU - Let us know your issues
« Reply #765 on: July 19, 2018, 08:26:13 PM »
My WU PWS page is now working normally again. Our data is relayed from HOBOlink, so yes there is a time delay. Any clock issue would be between their server clock and yours at WU. Thanks for sorting this out.

Rich K.
« Last Edit: July 19, 2018, 08:29:15 PM by havtrail »
Onset HOBO RX3003 Cellular
http://weather.havtrail.com
WU KPAHAVER17

Offline wunderground-PWS

  • Senior Member
  • **
  • Posts: 58
Re: WU - Let us know your issues
« Reply #766 on: July 19, 2018, 09:00:49 PM »
Glad we were able to resolve this issue.

My WU PWS page is now working normally again. Our data is relayed from HOBOlink, so yes there is a time delay. Any clock issue would be between their server clock and yours at WU. Thanks for sorting this out.

Rich K.

Offline jerryg

  • Forecaster
  • *****
  • Posts: 738
  • weather is never boring
    • victoria texas weather
Re: WU - Let us know your issues
« Reply #767 on: July 19, 2018, 09:11:01 PM »
Update, everything is working like it should. Kudos guys.

Offline orchidman

  • Member
  • *
  • Posts: 38
Re: WU - Let us know your issues
« Reply #768 on: July 19, 2018, 10:43:05 PM »
KOKOKLAH58 is now up and running properly.  Thanks so much.  We are using DAVIS equipment with VWS reporting the data to WU
Gary
Oklahoma City, OK
Davis Advantage Pro2, WL, VWS, WU KOKOKLAH58

Offline bagocina

  • Member
  • *
  • Posts: 4
    • eMeteo.sk
Re: WU - Let us know your issues
« Reply #769 on: July 20, 2018, 01:19:14 AM »
Woohoo, IBRATISL590 Curently Conditions updating now correctly too! Thanks guys!
« Last Edit: July 20, 2018, 01:21:12 AM by bagocina »


Amateur weather stations on eMeteo.sk

eMeteo.sk PWS = Raspberry Pi 3 + DHT22 + BMP180 + Sparkfun Weather Rack + SwitchDoc Weather Board + OpenSource Python Code + Own Shell scripts + Own page code

Offline quailvalleywx

  • Member
  • *
  • Posts: 19
Re: WU - Let us know your issues
« Reply #770 on: July 20, 2018, 08:59:49 AM »
I'm seeing improvement after yesterday's current conditions fix but dashboard?ID=KKSSHAWN60#history page has only circle (no temperature data) on radar map, last update message is fixed at "Station reported 8 seconds ago", yet current conditions are updating and graphs are good (improvement).  I've verified UTC date/time sent is correct.  This is the older version Ambient software which jumps around a lot when sending updates but is still generally 4 per minute - Weather%20logger%20V3.1.2&action=updateraw&realtime=1&rtfreq=5.  I'm staying with the older version for telnet use which allows me to intercept, store, and forward data.  I haven't changed the forwarding part of code in months.

Thanks for your hard work!  For me WU is still the most feature rich PWS host out there and when reliability gets back under control it will be awesome.

Offline Intheswamp

  • Early on one frosty morn'...
  • Forecaster
  • *****
  • Posts: 1366
  • Sure...I know enough to be dangerous, now.
    • Beeweather
Re: WU - Let us know your issues
« Reply #771 on: July 20, 2018, 02:59:47 PM »
WU took a nose-dive for me.  My station is basically three miles from Rutledge, AL and maybe six miles from Luverne, AL.  When I type in the zipcode or town name it pulls up the airport in Troy, AL...roughly 30 miles away.  I can still find my station on WU, it's just being replaced by this distant station.  BeeWeather is listed at the bottom of the list of nearby stations for the airport station.  Since I'm relegated to the bottom of the nearby list for my local area I guess I might as well kill BeeWeather's feed to WU and let them give folks the accurate conditions in a whole different county.<sigh>

Davis VP2, v3.12
Cumulus v1.9.4  Build 1079
Today's weather beats no weather at all!
www.beeweather.com

Offline wunderground-PWS

  • Senior Member
  • **
  • Posts: 58
Re: WU - Let us know your issues
« Reply #772 on: July 23, 2018, 04:16:07 PM »
Hmm, not sure why.  When I go to your page, it appears to be working.    If your station is failing QC there is a chance it won't show up there.

I'm seeing improvement after yesterday's current conditions fix but dashboard?ID=KKSSHAWN60#history page has only circle (no temperature data) on radar map, last update message is fixed at "Station reported 8 seconds ago", yet current conditions are updating and graphs are good (improvement).  I've verified UTC date/time sent is correct.  This is the older version Ambient software which jumps around a lot when sending updates but is still generally 4 per minute - Weather%20logger%20V3.1.2&action=updateraw&realtime=1&rtfreq=5.  I'm staying with the older version for telnet use which allows me to intercept, store, and forward data.  I haven't changed the forwarding part of code in months.

Thanks for your hard work!  For me WU is still the most feature rich PWS host out there and when reliability gets back under control it will be awesome.

Offline quailvalleywx

  • Member
  • *
  • Posts: 19
Re: WU - Let us know your issues
« Reply #773 on: July 24, 2018, 02:40:25 PM »
Hmm, not sure why.  When I go to your page, it appears to be working.    If your station is failing QC there is a chance it won't show up there.

Yes, 10 minutes after I posted the page was displaying correctly.  Over the weekend with ~20 page loads and just now, all correct.  Monday morning around 7:30AM the "Station reported XX seconds ago" field was non-updating and the station data icon on the map had a circle but no data.  All other page functions looked OK.  Reviewing Monday data sent I did send 3 out of range baro data at ~1AM (my Ambient Observer IP gets a reset 2x/wk to handle one of its bugs).  CWOP QCs look good.  Data send to WU appears to be chronological (was worried about updates sent out of order).  Bad data at 1AM affecting current conditions page operation at 7:30AM - hopefully not likely.

Low frequency intermittent problem with limited reduction in function - likely not actionable at this time.  Plenty of bigger fish to fry :)

Offline havtrail

  • Senior Member
  • **
  • Posts: 51
    • Haverford Weather Station
Re: WU - Let us know your issues
« Reply #774 on: July 25, 2018, 09:03:40 AM »
New issue:  When will WU make its "weather sticker" widgets HTTPS compliant?

My website host is moving us (or trying to move us) to HTTPS compliance. The WXForum has also made this transition. Starting soon, sites that are not compliant will be more severely identified as "risky" by browsers and will also be ranked lower in internet searches.

I've managed to make the transition successfully for my entire domain, except where I use the WU weather stickers.

What I would really like is a static version of the first-listed WU sticker, which shows more weather data than the others but is a movie object. A static version (like the others) with an hour/minute time stamp at the bottom instead of the "Updated: xx minutes ago" would be great, and would not need to use Adobe Flash.

While we're at it, must the other stickers really continue to show the English temp and wind speed to 6 decimal places? Seems excessive...

Rich K.
« Last Edit: July 25, 2018, 12:20:02 PM by havtrail »
Onset HOBO RX3003 Cellular
http://weather.havtrail.com
WU KPAHAVER17