Author Topic: VWS Internet Won't Start  (Read 383 times)

0 Members and 1 Guest are viewing this topic.

Offline deweydewdrops

  • Member
  • *
  • Posts: 9
VWS Internet Won't Start
« on: April 10, 2017, 02:47:38 PM »
Something happened this morning with my VWS Internet program.  The first thing I noticed was that it wasn't communicating with my Davis Vantage Pro weather station.  So I closed it and tried to open it again.  Nothing.  I tried updating to the latest public version.  Still nothing.  Won't open.

I am running Windows 10.  When I click on the VWS icon it doesn't open the program like it did in Windows 7.  Instead it places another icon on the taskbar and that one usually opens VWS.  The icon on the taskbar is there, but clicking on it does nothing.  I went into the Window Task Manager and I can see VWS running.  If I try to delete it in the Task Manager nothing happens.  I am stumped.

I tried something from another post where Ed said to delete C:\VWS\WININET.DLL and restart.  The only wininet.dll file on my system is in some Windows folders.  Nothing in the VWS folder.  Maybe that is a clue.

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6224
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: VWS Internet Won't Start
« Reply #1 on: April 10, 2017, 07:23:01 PM »
I had to delete a leftover C:\VWS\WININET.DLL from an older version that was previously installed.
On my Windows 10 system, I had to change the properties for c:\VWS\vws.exe to use Windows 7 compatibility mode, then it started up fine.  Give that a try.
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

Offline deweydewdrops

  • Member
  • *
  • Posts: 9
Re: VWS Internet Won't Start
« Reply #2 on: April 10, 2017, 07:55:14 PM »
Thanks.  I tried both 7 & 8.  No help.  Something has changed.  I have been using this program for several years.  It was only this morning that it quit working.  Maybe a Windows update, although I don't think there was one recently.

What's confusing is that I don't have a wininet.dll file.  Maybe Windows 10 doesn't need one?