Author Topic: Setting Correct Thermo-Hygro channel for WMR200  (Read 1564 times)

0 Members and 1 Guest are viewing this topic.

Offline BaronV

  • Member
  • *
  • Posts: 35
Setting Correct Thermo-Hygro channel for WMR200
« on: October 11, 2016, 01:01:42 PM »
Hello all!

Ive been trying to get weewx to work properly on my raspberry pi but I've been running into some confounding problems.

The first problem Im facing is probably related to the fact that I use Channel 2 for my outdoor thermo-hygro sensor. This is because I seem to have a little interference on Channel 1 which caused it to occasionally drop out. After changing to Channel 2 the drop outs stopped.

However I cant seem to find any way to tell weewx that my thermo-hygro sensor is on Channel 2. As a result Im not getting any readings for temperature or humidity

The other problem might be linked to the first one. Ive configured it to upload to Weather Underground, but it seems only the wind data is getting through. Nothing else is, not even Pressure which sits on the WMR200 itself and thus should not be an issue. Even locally on the website it just shows N/A for all readings.

Anyone encountered this problem before?

You can see my station here https://www.wunderground.com/personal-weather-station/dashboard?ID=IMELAKAM2

Offline BaronV

  • Member
  • *
  • Posts: 35
Re: Setting Correct Thermo-Hygro channel for WMR200
« Reply #1 on: October 11, 2016, 01:02:51 PM »
if it helps I changed the archive rate from 60s to 300s because I googled my symptoms and one person apparently fixed his problem by doing so, though it isnt working for me

Offline BaronV

  • Member
  • *
  • Posts: 35
Re: Setting Correct Thermo-Hygro channel for WMR200
« Reply #2 on: October 13, 2016, 02:28:06 AM »
Discussing this matter on the weewx user forums, it turns out that there is a bug for the WMR200 driver that causes it to not properly read the data being downloaded. There is a unofficial fix.

However to change which sensor channel is used for the outdoor sensor you must still edit the wmr200.py driver file to change the sensor_id value used for "outdoor sensor"